Bug 240982 - BUG: warning at kernel/softirq.c:138/local_bh_enable()
BUG: warning at kernel/softirq.c:138/local_bh_enable()
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 241485 241584 241637 242146 242963 243553 246462 248853 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-23 11:24 EDT by sangu
Modified: 2013-02-26 10:28 EST (History)
40 users (show)

See Also:
Fixed In Version: 2.6.21-1.3228.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 15:27:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg, /proc/cpuinfo, lspci -vv (44.98 KB, text/plain)
2007-05-23 11:24 EDT, sangu
no flags Details

  None (edit)
Description sangu 2007-05-23 11:24:34 EDT
Description of problem:
$dmesg
[...]
BUG: warning at kernel/softirq.c:138/local_bh_enable() (Tainted: P      )
 [<c042b2ef>] local_bh_enable+0x45/0x92
 [<c06036b7>] cond_resched_softirq+0x2c/0x42
 [<c059d5d0>] release_sock+0x54/0xa3
 [<c05c9428>] tcp_sendmsg+0x91b/0xa0c
 [<c04e8b30>] copy_to_user+0x3c/0x50
 [<c05a1b71>] memcpy_toiovec+0x27/0x4a
 [<c059d58f>] release_sock+0x13/0xa3
 [<c0604ad5>] _spin_unlock_bh+0x5/0xd
 [<c05e1bb9>] inet_sendmsg+0x3b/0x45
 [<c059af34>] sock_aio_write+0xf9/0x105
 [<c0475f31>] do_sync_readv_writev+0xc1/0xfe
 [<c0437265>] autoremove_wake_function+0x0/0x35
 [<c04e88e0>] copy_from_user+0x3a/0x66
 [<c0475dec>] rw_copy_check_uvector+0x5c/0xb0
 [<c047667a>] do_readv_writev+0xbc/0x187
 [<c059ae3b>] sock_aio_write+0x0/0x105
 [<c0476782>] vfs_writev+0x3d/0x48
 [<c0476bee>] sys_writev+0x41/0x95
 [<c0404f70>] syscall_call+0x7/0xb
 =======================


Version-Release number of selected component (if applicable):
2.6.21-1.3189.fc7

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 sangu 2007-05-23 11:24:34 EDT
Created attachment 155260 [details]
dmesg, /proc/cpuinfo, lspci -vv
Comment 2 Chuck Ebbert 2007-05-23 11:34:35 EDT
Dave, is this with the latest cond_resched_softirq() change from Ingo?
Comment 3 Chuck Ebbert 2007-05-23 12:24:10 EDT
Can this bug be reproduced without the proprietary module loaded?
Upstream kernel developers won't look at it with that present.
Comment 4 Orion Poplawski 2007-05-23 12:52:56 EDT
I've got it too.  This is new with 3189, didn't have it with 3175

> BUG: warning at kernel/softirq.c:138/local_bh_enable() (Not tainted)
>  [<c042b2ef>] local_bh_enable+0x45/0x92
>  [<c06036b7>] cond_resched_softirq+0x2c/0x42
>  [<c059d5d0>] release_sock+0x54/0xa3
>  [<c05c9428>] tcp_sendmsg+0x91b/0xa0c
>  [<c05e1bb9>] inet_sendmsg+0x3b/0x45
>  [<c059af34>] sock_aio_write+0xf9/0x105
>  [<c0476035>] do_sync_write+0xc7/0x10a
>  [<c0437265>] autoremove_wake_function+0x0/0x35
>  [<c047688e>] vfs_write+0xbc/0x154
>  [<c0476e8c>] sys_write+0x41/0x67
>  [<c0404f70>] syscall_call+0x7/0xb
>  [<c0600000>] wext_handle_ioctl+0x141/0x370
>  =======================
Comment 5 Tom London 2007-05-24 10:13:16 EDT
I'm getting this with .3194:

May 24 07:09:35 localhost kernel: BUG: warning at
kernel/softirq.c:138/local_bh_enable() (Not tainted)
May 24 07:09:35 localhost kernel:  [<c042b4af>] local_bh_enable+0x45/0x92
May 24 07:09:35 localhost kernel:  [<c060215d>] cond_resched_softirq+0x2c/0x42
May 24 07:09:35 localhost kernel:  [<c059cc6f>] release_sock+0x4f/0x9d
May 24 07:09:35 localhost kernel:  [<c05c859d>] tcp_sendmsg+0x90b/0x9f9
May 24 07:09:35 localhost kernel:  [<c05e0b29>] inet_sendmsg+0x3b/0x45
May 24 07:09:35 localhost kernel:  [<c059a5ad>] sock_aio_write+0xf6/0x102
May 24 07:09:35 localhost kernel:  [<c0476a7a>] do_sync_write+0xc7/0x10a
May 24 07:09:35 localhost kernel:  [<c0437259>] autoremove_wake_function+0x0/0x35
May 24 07:09:35 localhost kernel:  [<c04772d3>] vfs_write+0xbc/0x154
May 24 07:09:35 localhost kernel:  [<c04778ce>] sys_write+0x41/0x67
May 24 07:09:35 localhost kernel:  [<c0404f70>] syscall_call+0x7/0xb
May 24 07:09:35 localhost kernel:  =======================
Comment 6 quackhacker 2007-05-24 10:43:07 EDT
I also am getting this with the 3189 kernel when I send a message from locally
installed and compiled mutt 1.5.15.  I do not get the bug error when I send the
same message with the same mutt using the 3175 kernel.  Here's my error message:

May 24 08:54:08 makarioi kernel: BUG: warning at
kernel/softirq.c:138/local_bh_enable() (Not tainted)
May 24 08:54:08 makarioi kernel:  [<c042b2ef>] local_bh_enable+0x45/0x92
May 24 08:54:08 makarioi kernel:  [<c06036b7>] cond_resched_softirq+0x2c/0x42
May 24 08:54:08 makarioi kernel:  [<c059d5d0>] release_sock+0x54/0xa3
May 24 08:54:08 makarioi kernel:  [<c05c9428>] tcp_sendmsg+0x91b/0xa0c
May 24 08:54:08 makarioi kernel:  [<c0604ad5>] _spin_unlock_bh+0x5/0xd
May 24 08:54:08 makarioi kernel:  [<c05ca494>] tcp_recvmsg+0x8e1/0x9ed
May 24 08:54:08 makarioi kernel:  [<c0481590>] core_sys_select+0x218/0x2f3
May 24 08:54:08 makarioi kernel:  [<c05e1bb9>] inet_sendmsg+0x3b/0x45
May 24 08:54:08 makarioi kernel:  [<c059af34>] sock_aio_write+0xf9/0x105
May 24 08:54:08 makarioi kernel:  [<c0476035>] do_sync_write+0xc7/0x10a
May 24 08:54:08 makarioi kernel:  [<c0437265>] autoremove_wake_function+0x0/0x35
May 24 08:54:08 makarioi kernel:  [<c047688e>] vfs_write+0xbc/0x154
May 24 08:54:08 makarioi kernel:  [<c0476e8c>] sys_write+0x41/0x67
May 24 08:54:08 makarioi kernel:  [<c0404f70>] syscall_call+0x7/0xb
May 24 08:54:08 makarioi kernel:  =======================
Comment 7 Chuck Ebbert 2007-05-24 10:47:12 EDT
This is caused by:
linux-2.6-prevent-idle-softirq.patch
Comment 8 Antonio A. Olivares 2007-05-25 19:05:26 EDT
I also see it.  

BUG: warning at kernel/softirq.c:138/local_bh_enable() (Not tainted)
 [<c042b0cf>] local_bh_enable+0x45/0x92
 [<c06002bd>] cond_resched_softirq+0x2c/0x42
 [<c059adf3>] release_sock+0x4f/0x9d
 [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
 [<c05dec95>] inet_sendmsg+0x3b/0x45
 [<c0599180>] sock_sendmsg+0xd0/0xeb
 [<c0600901>] __wait_on_bit_lock+0x4b/0x52
 [<c048652a>] touch_atime+0x95/0xbb
 [<c0436e71>] autoremove_wake_function+0x0/0x35
 [<c045bfe3>] generic_file_aio_read+0x173/0x1a4
 [<c0599a44>] sys_sendto+0x118/0x138
 [<c04599bf>] find_get_page+0x18/0x38
 [<c045bce2>] filemap_nopage+0x18b/0x319
 [<c04647b8>] __handle_mm_fault+0x362/0x8f3
 [<c0599a9b>] sys_send+0x37/0x3b
 [<c059a406>] sys_socketcall+0x14a/0x261
 [<c0404f70>] syscall_call+0x7/0xb
 =======================
usb 1-1: new full speed USB device using ohci_hcd and address 11
usb 1-1: device descriptor read/64, error -62

Printing worked before and now it does not.  since 3189 kernel, 3175 worked if I
am not mistaken.
Comment 9 quackhacker 2007-05-25 20:53:04 EDT
It is happening again on kernel 3194.  Went back to 3190 and it doesn't happen
(same email, produces no error on 3190 but the following error on 3194):

May 25 19:45:27 makarioi kernel: BUG: warning at
kernel/softirq.c:138/local_bh_enable() (Not tainted)
May 25 19:45:27 makarioi kernel:  [<c042b0cf>] local_bh_enable+0x45/0x92
May 25 19:45:27 makarioi kernel:  [<c06002bd>] cond_resched_softirq+0x2c/0x42
May 25 19:45:27 makarioi kernel:  [<c059adf3>] release_sock+0x4f/0x9d
May 25 19:45:27 makarioi kernel:  [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
May 25 19:45:27 makarioi kernel:  [<c059adb6>] release_sock+0x12/0x9d
May 25 19:45:27 makarioi kernel:  [<c05c7755>] tcp_recvmsg+0x8d2/0x9de
May 25 19:45:27 makarioi kernel:  [<c04808dc>] core_sys_select+0x218/0x2f3
May 25 19:45:27 makarioi kernel:  [<c05dec95>] inet_sendmsg+0x3b/0x45
May 25 19:45:27 makarioi kernel:  [<c0598731>] sock_aio_write+0xf6/0x102
May 25 19:45:27 makarioi kernel:  [<c045da36>] get_page_from_freelist+0x23b/0x2a5
May 25 19:45:27 makarioi kernel:  [<c04754ee>] do_sync_write+0xc7/0x10a
May 25 19:45:27 makarioi kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
May 25 19:45:27 makarioi kernel:  [<c0475d47>] vfs_write+0xbc/0x154
May 25 19:45:27 makarioi kernel:  [<c0476342>] sys_write+0x41/0x67
May 25 19:45:27 makarioi kernel:  [<c0404f70>] syscall_call+0x7/0xb
May 25 19:45:27 makarioi kernel:  =======================
Comment 10 quackhacker 2007-05-25 21:00:07 EDT
Well!  Now it is occuring on 1390 as well:

May 25 19:55:20 makarioi kernel: BUG: warning at
kernel/softirq.c:138/local_bh_enable() (Not tainted)
May 25 19:55:20 makarioi kernel:  [<c042b2ef>] local_bh_enable+0x45/0x92
May 25 19:55:20 makarioi kernel:  [<c06036b7>] cond_resched_softirq+0x2c/0x42
May 25 19:55:20 makarioi kernel:  [<c059d5d0>] release_sock+0x54/0xa3
May 25 19:55:20 makarioi kernel:  [<c05c9428>] tcp_sendmsg+0x91b/0xa0c
May 25 19:55:20 makarioi kernel:  [<c0481526>] core_sys_select+0x1ae/0x2f3
May 25 19:55:20 makarioi kernel:  [<c05e1bb9>] inet_sendmsg+0x3b/0x45
May 25 19:55:20 makarioi kernel:  [<c059af34>] sock_aio_write+0xf9/0x105
May 25 19:55:20 makarioi kernel:  [<c05b7123>] netlink_insert+0x104/0x10e
May 25 19:55:20 makarioi kernel:  [<c0476035>] do_sync_write+0xc7/0x10a
May 25 19:55:20 makarioi kernel:  [<c0437265>] autoremove_wake_function+0x0/0x35
May 25 19:55:20 makarioi kernel:  [<c047688e>] vfs_write+0xbc/0x154
May 25 19:55:20 makarioi kernel:  [<c0476e8c>] sys_write+0x41/0x67
May 25 19:55:20 makarioi kernel:  [<c0404f70>] syscall_call+0x7/0xb
May 25 19:55:20 makarioi kernel:  =======================
Comment 11 Srihari Vijayaraghavan 2007-05-26 01:52:43 EDT
On 2.6.21-1.3189.x86_64.fc7:

BUG: warning at kernel/softirq.c:138/local_bh_enable() (Not tainted)

Call Trace:
 [<ffffffff8022a34e>] local_bh_enable+0x42/0x98
 [<ffffffff8025c08d>] cond_resched_softirq+0x35/0x4b
 [<ffffffff8022ef57>] release_sock+0x65/0xba
 [<ffffffff802256ee>] tcp_sendmsg+0x992/0xa9c
 [<ffffffff8024f242>] sock_sendmsg+0xea/0x107
 [<ffffffff80293441>] autoremove_wake_function+0x0/0x2e
 [<ffffffff802d2249>] core_sys_select+0x233/0x264
 [<ffffffff80264890>] math_state_restore+0x1a/0x49
 [<ffffffff8025de5d>] error_exit+0x0/0x84
 [<ffffffff803e9e36>] sys_sendto+0x128/0x151
 [<ffffffff8023f498>] sys_rt_sigreturn+0x282/0x34c
 [<ffffffff8023f52f>] sys_rt_sigreturn+0x319/0x34c
 [<ffffffff8025729c>] tracesys+0xdc/0xe1
Comment 12 Stewart Adam 2007-05-26 12:41:24 EDT
*** Bug 241485 has been marked as a duplicate of this bug. ***
Comment 13 Okke Timm 2007-05-26 12:47:58 EDT
If found this email from Ingo Molnar / Thomas Gleixner which looks like it
contains an explanation and a patch for this problem:

http://www.mail-archive.com/linux-kernel@vger.kernel.org/msg160274.html
Comment 14 Robin Humble 2007-05-27 08:29:40 EDT
is this the same problem? I'm seeing these pretty regularly on x86_64 with
kernel-2.6.21-1.3194.fc7 ... once I just booted and did a 'netstat -t' and that
was enough to trigger it.

May 27 17:56:39 localhost kernel: BUG: warning at
kernel/softirq.c:138/local_bh_enable() (Not tainted)
May 27 17:56:39 localhost kernel: 
May 27 17:56:39 localhost kernel: Call Trace:
May 27 17:56:39 localhost kernel:  [<ffffffff80229e7b>] local_bh_enable+0x42/0x98
May 27 17:56:39 localhost kernel:  [<ffffffff8025c008>]
cond_resched_softirq+0x35/0x4b
May 27 17:56:39 localhost kernel:  [<ffffffff8041837d>]
established_get_first+0x16/0xbe
May 27 17:56:39 localhost kernel:  [<ffffffff804184b8>] tcp_get_idx+0x93/0xb2
May 27 17:56:39 localhost kernel:  [<ffffffff8023c674>] seq_read+0xe5/0x28c
May 27 17:56:39 localhost kernel:  [<ffffffff8020af0a>] vfs_read+0xcb/0x173
May 27 17:56:39 localhost kernel:  [<ffffffff80210606>] sys_read+0x45/0x6e
May 27 17:56:39 localhost kernel:  [<ffffffff8025729c>] tracesys+0xdc/0xe1
May 27 17:56:39 localhost kernel: 
Comment 15 Adam Huffman 2007-05-28 08:10:49 EDT
I see this problem with kernel 1.3194 on an x86_64 Vaio SZ3:

BUG: warning at kernel/softirq.c:138/local_bh_enable() (Not tainted)

Call Trace:
 [<ffffffff80229e7b>] local_bh_enable+0x42/0x98
 [<ffffffff8025c008>] cond_resched_softirq+0x35/0x4b
 [<ffffffff8022e9f5>] release_sock+0x59/0xaa
 [<ffffffff802252a6>] tcp_sendmsg+0x9ae/0xab8
 [<ffffffff8024297c>] sock_aio_write+0x110/0x128
 [<ffffffff8024286c>] sock_aio_write+0x0/0x128
 [<ffffffff802cd13d>] do_sync_readv_writev+0xc0/0x107
 [<ffffffff8030ee3d>] file_has_perm+0x94/0xa3
 [<ffffffff80293107>] autoremove_wake_function+0x0/0x2e
 [<ffffffff802cd5ae>] do_readv_writev+0xd7/0x1ae
 [<ffffffff8030edf1>] file_has_perm+0x48/0xa3
 [<ffffffff802cd70c>] sys_writev+0x45/0x93
 [<ffffffff8025711e>] system_call+0x7e/0x83
Comment 16 Darren Naessens 2007-05-29 03:13:03 EDT
I too have this occur on every startup - only since 3190

BUG: warning at kernel/softirq.c:138/local_bh_enable() (Not tainted)
 [<c042b2ef>] local_bh_enable+0x45/0x92
 [<c06036b7>] cond_resched_softirq+0x2c/0x42
 [<c059d5d0>] release_sock+0x54/0xa3
 [<c04373af>] prepare_to_wait+0x24/0x3f
 [<c05e267f>] inet_stream_connect+0x116/0x1ff
 [<c0437265>] autoremove_wake_function+0x0/0x35
 [<c059c339>] sys_connect+0x82/0xad
 [<c059d58f>] release_sock+0x13/0xa3
 [<c0604ad5>] _spin_unlock_bh+0x5/0xd
 [<c059e714>] sock_setsockopt+0x4a8/0x4b2
 [<c0604ad5>] _spin_unlock_bh+0x5/0xd
 [<c05c80fa>] tcp_setsockopt+0x324/0x33c
 [<c059b521>] sys_setsockopt+0x6d/0xa7
 [<c059cb83>] sys_socketcall+0xac/0x261
 [<c0474c35>] filp_close+0x51/0x58
 [<c0404f70>] syscall_call+0x7/0xb
 [<c0600000>] wext_handle_ioctl+0x141/0x370
Comment 17 Bojan Smojver 2007-05-29 20:55:25 EDT
My 2 cents:

---------------------------------------
May 30 08:11:38 shrek kernel: BUG: warning at kernel/softirq.c:138/local_bh_enab
le() (Not tainted)
May 30 08:11:39 shrek kernel:  [<c042b2ef>] local_bh_enable+0x45/0x92
May 30 08:11:39 shrek kernel:  [<c06036b7>] cond_resched_softirq+0x2c/0x42
May 30 08:11:39 shrek kernel:  [<c059d5d0>] release_sock+0x54/0xa3
May 30 08:11:40 shrek kernel:  [<c05c9428>] tcp_sendmsg+0x91b/0xa0c
May 30 08:11:40 shrek kernel:  [<c059b8a7>] sock_recvmsg+0xec/0x107
May 30 08:11:40 shrek kernel:  [<c05e1bb9>] inet_sendmsg+0x3b/0x45
May 30 08:11:40 shrek kernel:  [<c059b992>] sock_sendmsg+0xd0/0xeb
May 30 08:11:40 shrek kernel:  [<c0437265>] autoremove_wake_function+0x0/0x35
May 30 08:11:40 shrek kernel:  [<c045aaee>] do_generic_mapping_read+0x412/0x459
May 30 08:11:40 shrek kernel:  [<c059c25c>] sys_sendto+0x11b/0x13b
May 30 08:11:40 shrek kernel:  [<c0604b74>] _read_unlock_irq+0x5/0x7
May 30 08:11:40 shrek kernel:  [<c045a150>] find_get_page+0x36/0x3b
May 30 08:11:40 shrek kernel:  [<c045c464>] filemap_nopage+0x18b/0x319
May 30 08:11:40 shrek kernel:  [<c04655a1>] __handle_mm_fault+0x8d9/0x8fb
May 30 08:11:40 shrek kernel:  [<c059db1f>] sk_free+0xb8/0xcd
May 30 08:11:40 shrek kernel:  [<c059c2b3>] sys_send+0x37/0x3b
May 30 08:11:40 shrek kernel:  [<c059cc21>] sys_socketcall+0x14a/0x261
May 30 08:11:40 shrek kernel:  [<c0404f70>] syscall_call+0x7/0xb
May 30 08:11:40 shrek kernel:  =======================
---------------------------------------
Comment 18 Chuck Ebbert 2007-05-30 12:51:40 EDT
We have an obsolete patch applied. Should be fixed soon.
Comment 19 Chuck Ebbert 2007-05-30 12:52:53 EDT
*** Bug 241584 has been marked as a duplicate of this bug. ***
Comment 20 Chuck Ebbert 2007-05-30 13:53:28 EDT
*** Bug 241637 has been marked as a duplicate of this bug. ***
Comment 21 Luke Macken 2007-06-01 23:24:01 EDT
*** Bug 242146 has been marked as a duplicate of this bug. ***
Comment 22 Luke Macken 2007-06-01 23:25:50 EDT
With 2.6.21-1.3194.fc7:

BUG: warning at kernel/softirq.c:138/local_bh_enable() (Not tainted)

 [<c042b0cf>] local_bh_enable+0x45/0x92

 [<c06002bd>] cond_resched_softirq+0x2c/0x42

 [<c059adf3>] release_sock+0x4f/0x9d

 [<c05c670d>] tcp_sendmsg+0x90b/0x9f9

 [<c05dec95>] inet_sendmsg+0x3b/0x45

 [<c0598731>] sock_aio_write+0xf6/0x102

 [<c04754ee>] do_sync_write+0xc7/0x10a

 [<c0436e71>] autoremove_wake_function+0x0/0x35

 [<c0475d47>] vfs_write+0xbc/0x154

 [<c0476342>] sys_write+0x41/0x67

 [<c0404f70>] syscall_call+0x7/0xb

 [<c0600000>] __sched_text_start+0x6e8/0x89e




Comment 23 Naresh 2007-06-02 06:03:58 EDT
==> same here on Latest Fedora 7 Kernel ( 2.6.21-1.3194.fc7)

BUG: warning at kernel/softirq.c:138/local_bh_enable() (Tainted: P      )
 [<c042b0cf>] local_bh_enable+0x45/0x92
 [<c06002bd>] cond_resched_softirq+0x2c/0x42
 [<c059adf3>] release_sock+0x4f/0x9d
 [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
 [<c04e7350>] copy_to_user+0x3c/0x50
 [<c059f285>] memcpy_toiovec+0x27/0x4a
 [<c059ddb8>] __kfree_skb+0xb5/0x113
 [<c06016f4>] _spin_lock_bh+0x8/0x18
 [<c05dec95>] inet_sendmsg+0x3b/0x45
 [<c0598731>] sock_aio_write+0xf6/0x102
 [<c04753ea>] do_sync_readv_writev+0xc1/0xfe
 [<c0436e71>] autoremove_wake_function+0x0/0x35
 [<c04e7100>] copy_from_user+0x3a/0x66
 [<c04752a5>] rw_copy_check_uvector+0x5c/0xb0
 [<c0475b33>] do_readv_writev+0xbc/0x187
 [<c059863b>] sock_aio_write+0x0/0x102
 [<c059a7dc>] sock_common_setsockopt+0x1d/0x22
 [<c0475c3b>] vfs_writev+0x3d/0x48
 [<c04760a4>] sys_writev+0x41/0x95
 [<c0404f70>] syscall_call+0x7/0xb
 =======================

http://smolt.fedoraproject.org/show?UUID=6e15ac85-1328-493f-96b5-16ae735ea22c
Comment 24 Jon Burgess 2007-06-02 12:30:48 EDT
I've been seeing the same issue and noticed that a patch to debug this was in
kernel-debug-2.6.21-1.3212.fc7.x86_64 so I installed this and now I get:

I get the following output:
...
br0: topology change detected, propagating
br0: port 1(eth0) entering forwarding state
irq event stamp: 94428
hardirqs last  enabled at (94428): [<ffffffff802078f7>] kmem_cache_free+0x25e/0x270
hardirqs last disabled at (94427): [<ffffffff80207737>] kmem_cache_free+0x9e/0x270
softirqs last  enabled at (94420): [<ffffffff80211d34>] __do_softirq+0xda/0xe3
softirqs last disabled at (94424): [<ffffffff80263ab2>] _spin_lock_bh+0x11/0x36
BUG: warning at kernel/softirq.c:144/local_bh_enable() (Not tainted)

Call Trace:
 [<ffffffff8022c7b8>] local_bh_enable+0xb7/0x149
 [<ffffffff80261156>] cond_resched_softirq+0x35/0x4b
 [<ffffffff802317eb>] release_sock+0x7b/0xd7
 [<ffffffff8022748b>] tcp_sendmsg+0xa08/0xb19
 [<ffffffff80323dda>] socket_has_perm+0x68/0x77
 [<ffffffff80244c08>] inet_sendmsg+0x46/0x53
 [<ffffffff802538ca>] sock_sendmsg+0x105/0x124
 [<ffffffff8029c451>] autoremove_wake_function+0x0/0x38
 [<ffffffff802df0b8>] put_filp+0x4a/0x4e
 [<ffffffff80232565>] release_open_intent+0x17/0x20
 [<ffffffff802240a7>] __path_lookup_intent_open+0x8d/0x9f
 [<ffffffff802e2f97>] path_lookup_open+0xc/0xe
 [<ffffffff8021ace5>] open_namei+0x72/0x654
 [<ffffffff80409fff>] sys_sendto+0x11e/0x143
 [<ffffffff80212537>] poison_obj+0x27/0x32
 [<ffffffff802078f7>] kmem_cache_free+0x25e/0x270
 [<ffffffff802bb23c>] audit_syscall_entry+0x148/0x17e
 [<ffffffff8025c2b5>] tracesys+0xdc/0xe1

ISO 9660 Extensions: Microsoft Joliet Level 3
Comment 25 Daniel Rowe 2007-06-03 06:00:46 EDT
I am getting this as well.

Kernel: 2.6.21-1.3194.fc7
Fedora 7 x86_64

BUG: warning at kernel/softirq.c:138/local_bh_enable() (Tainted: P      )

Call Trace:
 [<ffffffff80229e7b>] local_bh_enable+0x42/0x98
 [<ffffffff8025c008>] cond_resched_softirq+0x35/0x4b
 [<ffffffff8022e9f5>] release_sock+0x59/0xaa
 [<ffffffff802252a6>] tcp_sendmsg+0x9ae/0xab8
 [<ffffffff8024297c>] sock_aio_write+0x110/0x128
 [<ffffffff8024286c>] sock_aio_write+0x0/0x128
 [<ffffffff802cd13d>] do_sync_readv_writev+0xc0/0x107
 [<ffffffff8030ee3d>] file_has_perm+0x94/0xa3
 [<ffffffff80293107>] autoremove_wake_function+0x0/0x2e
 [<ffffffff802cd5ae>] do_readv_writev+0xd7/0x1ae
 [<ffffffff8030edf1>] file_has_perm+0x48/0xa3
 [<ffffffff802cd70c>] sys_writev+0x45/0x93
 [<ffffffff8025711e>] system_call+0x7e/0x83
Comment 26 Jan Engelhardt 2007-06-03 06:06:57 EDT
Everyone who has got Tainted:P loses. Retry without ever loading proprietary
modules first.
Comment 27 Martin 2007-06-03 11:13:54 EDT
smae issue here with 2.6.21-1.3194.fc7

loop: loaded (max 8 devices)
lp: driver loaded but no devices found
sonypi: Sony Programmable I/O Controller Driver v1.26.
BUG: warning at kernel/softirq.c:138/local_bh_enable() (Tainted: P      )
 [<c042b0cf>] local_bh_enable+0x45/0x92
 [<c06002bd>] cond_resched_softirq+0x2c/0x42
 [<c059adf3>] release_sock+0x4f/0x9d
 [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
 [<c04e7350>] copy_to_user+0x3c/0x50
 [<c059f285>] memcpy_toiovec+0x27/0x4a
 [<c059ddb8>] __kfree_skb+0xb5/0x113
 [<c06016f4>] _spin_lock_bh+0x8/0x18
 [<c05dec95>] inet_sendmsg+0x3b/0x45
 [<c0598731>] sock_aio_write+0xf6/0x102
 [<c04753ea>] do_sync_readv_writev+0xc1/0xfe
 [<c0436e71>] autoremove_wake_function+0x0/0x35
 [<c04e7100>] copy_from_user+0x3a/0x66
 [<c04752a5>] rw_copy_check_uvector+0x5c/0xb0
 [<c0475b33>] do_readv_writev+0xbc/0x187
 [<c059863b>] sock_aio_write+0x0/0x102
 [<c059a7dc>] sock_common_setsockopt+0x1d/0x22
 [<c0475c3b>] vfs_writev+0x3d/0x48
 [<c04760a4>] sys_writev+0x41/0x95
 [<c0404f70>] syscall_call+0x7/0xb
 =======================
No dock devices found.
Comment 28 Robert Scheck 2007-06-03 11:47:45 EDT
Well, this problem appears with and without tainted kernel but nobody from Red 
Hat is interested to take care of this problem. WHY?
Comment 29 Robert Scheck 2007-06-03 11:50:10 EDT
Finally this problem also occours at kernel-2.6.21-1.3201.fc7
Comment 30 Jan Engelhardt 2007-06-03 11:50:53 EDT
More importantly.. why was not this found before the release of FC7?
Comment 31 Robert Scheck 2007-06-03 11:54:40 EDT
This bug WAS found before release of Fedora 7 (hey, there is NO FC7) - but 
nobody was interested. But the Fedora 7 kernel is heavy buggy for a final 
release kernel at all...so who cares about one shitty bug report? </irony>
Comment 32 Jérôme Benoit 2007-06-04 07:37:19 EDT
Seems to be the same here on A7V600 motherboard with AMD Athlon(TM) XP 2500+ : 

ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 20
[drm] Initialized drm 1.1.0 20060810
[drm] Initialized radeon 1.25.0 20060524 on minor 0
BUG: warning at kernel/softirq.c:138/local_bh_enable() (Not tainted)
 [<c042b0cf>] local_bh_enable+0x45/0x92
 [<c06002bd>] cond_resched_softirq+0x2c/0x42
 [<c059adf3>] release_sock+0x4f/0x9d
 [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
 [<c04e7350>] copy_to_user+0x3c/0x50
 [<c059f285>] memcpy_toiovec+0x27/0x4a
 [<c059ddb8>] __kfree_skb+0xb5/0x113
 [<c06016f4>] _spin_lock_bh+0x8/0x18
 [<c05dec95>] inet_sendmsg+0x3b/0x45
 [<c0598731>] sock_aio_write+0xf6/0x102
 [<c04753ea>] do_sync_readv_writev+0xc1/0xfe
 [<c0436e71>] autoremove_wake_function+0x0/0x35
 [<c04e7100>] copy_from_user+0x3a/0x66
 [<c04752a5>] rw_copy_check_uvector+0x5c/0xb0
 [<c0475b33>] do_readv_writev+0xbc/0x187
 [<c059863b>] sock_aio_write+0x0/0x102
 [<c059a7dc>] sock_common_setsockopt+0x1d/0x22
 [<c0475c3b>] vfs_writev+0x3d/0x48
 [<c04760a4>] sys_writev+0x41/0x95
 [<c0404f70>] syscall_call+0x7/0xb
 =======================
No dock devices found.
input: Power Button (FF) as /class/input/input4

Cheers.
Comment 33 Brian Millett 2007-06-04 08:59:43 EDT
Me too on F7 kernel that is labeled with a non existing os

kernel-2.6.21-1.3194.fc7

fc7 doesn't exist.   Yeah right.
Comment 34 Andre Costa 2007-06-04 19:06:09 EDT
It happens here as well (A7N8X-E Deluxe 2.0, Nvidia GeForce4 6800 GT, kernel
2.6.21-1.3194.fc7):

Jun  4 18:35:57 localhost kernel: agpgart: Found an AGP 3.0 compliant device at
0000:00:00.0.
Jun  4 18:35:57 localhost kernel: agpgart: Putting AGP V3 device at 0000:00:00.0
into 8x mode
Jun  4 18:35:57 localhost kernel: agpgart: Putting AGP V3 device at 0000:02:00.0
into 8x mode
Jun  4 18:35:57 localhost kernel: BUG: warning at
kernel/softirq.c:138/local_bh_enable() (Tainted: P      )
Jun  4 18:35:57 localhost kernel:  [<c042b0cf>] local_bh_enable+0x45/0x92
Jun  4 18:35:57 localhost kernel:  [<c06002bd>] cond_resched_softirq+0x2c/0x42
Jun  4 18:35:57 localhost kernel:  [<c059adf3>] release_sock+0x4f/0x9d
Jun  4 18:35:57 localhost kernel:  [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
Jun  4 18:35:57 localhost kernel:  [<c04e7350>] copy_to_user+0x3c/0x50
Jun  4 18:35:57 localhost kernel:  [<c059f285>] memcpy_toiovec+0x27/0x4a
Jun  4 18:35:57 localhost kernel:  [<c059ddb8>] __kfree_skb+0xb5/0x113
Jun  4 18:35:57 localhost kernel:  [<c06016f4>] _spin_lock_bh+0x8/0x18
Jun  4 18:35:57 localhost kernel:  [<c05dec95>] inet_sendmsg+0x3b/0x45
Jun  4 18:35:57 localhost kernel:  [<c0598731>] sock_aio_write+0xf6/0x102
Jun  4 18:35:57 localhost kernel:  [<c04753ea>] do_sync_readv_writev+0xc1/0xfe
Jun  4 18:35:57 localhost kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
Jun  4 18:35:57 localhost kernel:  [<c04e7100>] copy_from_user+0x3a/0x66
Jun  4 18:35:57 localhost kernel:  [<c04752a5>] rw_copy_check_uvector+0x5c/0xb0
Jun  4 18:35:57 localhost kernel:  [<c0475b33>] do_readv_writev+0xbc/0x187
Jun  4 18:35:57 localhost kernel:  [<c059863b>] sock_aio_write+0x0/0x102
Jun  4 18:35:57 localhost kernel:  [<c059a7dc>] sock_common_setsockopt+0x1d/0x22
Jun  4 18:35:57 localhost kernel:  [<c0475c3b>] vfs_writev+0x3d/0x48
Jun  4 18:35:57 localhost kernel:  [<c04760a4>] sys_writev+0x41/0x95
Jun  4 18:35:57 localhost kernel:  [<c0404f70>] syscall_call+0x7/0xb
Jun  4 18:35:57 localhost kernel:  =======================
Comment 35 D. Hugh Redelmeier 2007-06-05 01:03:16 EDT
Me too.  Folks: don't get too worked up, help is on the way: read message 18.

Linux version 2.6.21-1.3194.fc7 (kojibuilder@hammer2.fedora.redhat.com) (gcc
version 4.1.2 20070502 (Red Hat 4.1.2-12)) #1 SMP Wed May 23 22:47:07 EDT 2007

BUG: warning at kernel/softirq.c:138/local_bh_enable() (Not tainted)

Call Trace:
 [<ffffffff80229e7b>] local_bh_enable+0x42/0x98
 [<ffffffff8025c008>] cond_resched_softirq+0x35/0x4b
 [<ffffffff8022e9f5>] release_sock+0x59/0xaa
 [<ffffffff802252a6>] tcp_sendmsg+0x9ae/0xab8
 [<ffffffff8024297c>] sock_aio_write+0x110/0x128
 [<ffffffff8024286c>] sock_aio_write+0x0/0x128
 [<ffffffff802cd13d>] do_sync_readv_writev+0xc0/0x107
 [<ffffffff8030ee3d>] file_has_perm+0x94/0xa3
 [<ffffffff80293107>] autoremove_wake_function+0x0/0x2e
 [<ffffffff802cd5ae>] do_readv_writev+0xd7/0x1ae
 [<ffffffff802ac2ff>] audit_syscall_entry+0x141/0x174
 [<ffffffff802cd70c>] sys_writev+0x45/0x93
 [<ffffffff8025729c>] tracesys+0xdc/0xe1
Comment 36 Chuck Ebbert 2007-06-05 16:52:34 EDT
Fix is in CVS, will be in the next kernel update.
Comment 37 Robert Scheck 2007-06-06 01:52:28 EDT
WHEN will the next kernel update be available?
Comment 38 Gene Heskett 2007-06-06 12:47:34 EDT
I too am getting this, but only once so far. HP dv5120us lappy, PowerNow K8,
ndiswrapper to make the bcm4318 radio work.  None of the traces above are
identical to mine, but are close enough to be essentially the same first 3 line
preamble
Comment 39 Gene Heskett 2007-06-06 12:49:44 EDT
Here is the trace to match comment #38
BUG: warning at kernel/softirq.c:138/local_bh_enable() (Tainted: P      )
 [<c042b0cf>] local_bh_enable+0x45/0x92
 [<c06002bd>] cond_resched_softirq+0x2c/0x42
 [<c059adf3>] release_sock+0x4f/0x9d
 [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
 [<c059adb6>] release_sock+0x12/0x9d
 [<c05c7755>] tcp_recvmsg+0x8d2/0x9de
 [<c04808dc>] core_sys_select+0x218/0x2f3
 [<c05dec95>] inet_sendmsg+0x3b/0x45
 [<c0598731>] sock_aio_write+0xf6/0x102
 [<c045da36>] get_page_from_freelist+0x23b/0x2a5
 [<c04754ee>] do_sync_write+0xc7/0x10a
 [<c0436e71>] autoremove_wake_function+0x0/0x35
 [<c0475d47>] vfs_write+0xbc/0x154
 [<c0476342>] sys_write+0x41/0x67
 [<c0404f70>] syscall_call+0x7/0xb
 =======================
ACPI: PCI Interrupt 0000:01:05.0[A] -> GSI 17 (level, low) -> IRQ 17
Comment 40 Chuck Ebbert 2007-06-06 14:19:09 EDT
*** Bug 242963 has been marked as a duplicate of this bug. ***
Comment 41 dex 2007-06-06 14:29:18 EDT
<rant>
please please Please no more tainted kernels in redhat bugzilla. for instance if
you modify your car engine which then breaks you wouldn't take it back to the
original manufacturer because they would say your warranty is void due to mods.
this case applies here, It just clouds the real issue.
</rant>     

BUG: warning at kernel/softirq.c:138/local_bh_enable() (Tainted: P      )
is a useless report.
Comment 42 Bernard Fouché 2007-06-07 04:32:13 EDT
I was upgrading many different computers with F7 until I ran into this bug. Too
bad it made to the final release, it's the first time I have to regret to make a
fedora upgrade so fast after its release.

Here it is on a Dell Precision 370:

Jun  7 10:21:49 linuxbf kernel: BUG: warning at
kernel/softirq.c:138/local_bh_enable() (Not tainted)
Jun  7 10:21:49 linuxbf kernel:  [<c042b0cf>] local_bh_enable+0x45/0x92
Jun  7 10:21:49 linuxbf kernel:  [<c06002bd>] cond_resched_softirq+0x2c/0x42
Jun  7 10:21:49 linuxbf kernel:  [<c059adf3>] release_sock+0x4f/0x9d
Jun  7 10:21:49 linuxbf kernel:  [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
Jun  7 10:21:49 linuxbf kernel:  [<c059adb6>] release_sock+0x12/0x9d
Jun  7 10:21:49 linuxbf kernel:  [<c05c7755>] tcp_recvmsg+0x8d2/0x9de
Jun  7 10:21:49 linuxbf kernel:  [<c05dec95>] inet_sendmsg+0x3b/0x45
Jun  7 10:21:49 linuxbf kernel:  [<c0598731>] sock_aio_write+0xf6/0x102
Jun  7 10:21:49 linuxbf kernel:  [<c04753ea>] do_sync_readv_writev+0xc1/0xfe
Jun  7 10:21:49 linuxbf kernel:  [<c04754ee>] do_sync_write+0xc7/0x10a
Jun  7 10:21:49 linuxbf kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
Jun  7 10:21:49 linuxbf kernel:  [<c0475d47>] vfs_write+0xbc/0x154
Jun  7 10:21:49 linuxbf kernel:  [<c0476342>] sys_write+0x41/0x67
Jun  7 10:21:49 linuxbf kernel:  [<c0404f70>] syscall_call+0x7/0xb
Jun  7 10:21:49 linuxbf kernel:  [<c0600000>] __sched_text_start+0x6e8/0x89e

I've tried to use the kernel 'nosmp' option: the system was not able to boot.
I've disabled hyperthreading from the bios and get the bug report above.

A fix is badly needed, I now have 5 computers that can hang at any time...
Comment 43 raf_ku 2007-06-07 10:00:57 EDT
Same here (not tainted :)
I wonder if this is related to e1000 bug which still exists? My network would
lock up when I was using Intel's Gigabit ( Intel Corporation 82541GI Gigabit
Ethernet) with this message being usually (always?) right when the eth0 would
lock up. I switched to build-in Boradcomm and no lockups but the Intel;s card is
still in the mobo.

# uname -a
Linux rna.genomicslab.ca 2.6.21-1.3194.fc7 #1 SMP Wed May 23 22:35:01 EDT 2007
i686 i686 i386 GNU/Linux


Jun  6 11:38:08 rna kernel: BUG: warning at kernel/softirq.c:138/local_bh_enable
() (Not tainted)
Jun  6 11:38:08 rna kernel:  [<c042b0cf>] local_bh_enable+0x45/0x92
Jun  6 11:38:08 rna kernel:  [<c06002bd>] cond_resched_softirq+0x2c/0x42
Jun  6 11:38:08 rna kernel:  [<c059adf3>] release_sock+0x4f/0x9d
Jun  6 11:38:08 rna kernel:  [<c05cec7d>] tcp_send_ack+0xeb/0xef
Jun  6 11:38:08 rna kernel:  [<c05c7755>] tcp_recvmsg+0x8d2/0x9de
Jun  6 11:38:08 rna kernel:  [<c059a7a9>] sock_common_recvmsg+0x3e/0x54
Jun  6 11:38:08 rna kernel:  [<c0598839>] sock_aio_read+0xfc/0x108
Jun  6 11:38:08 rna kernel:  [<c04755f8>] do_sync_read+0xc7/0x10a
Jun  6 11:38:08 rna kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
Jun  6 11:38:08 rna kernel:  [<c0475e99>] vfs_read+0xba/0x152
Jun  6 11:38:08 rna kernel:  [<c04762db>] sys_read+0x41/0x67
Jun  6 11:38:08 rna kernel:  [<c0404f70>] syscall_call+0x7/0xb
Jun  6 11:38:08 rna kernel:  =======================
Comment 44 Christopher Wawak 2007-06-08 21:22:58 EDT
Not sure if still needed, but here's my 2 cents:

AMIBIOS(C)2003 American Megatrends, Inc.                                        
Supermicro H8DAR-T/E BIOS Date: 03/24/06 09:45:29 Ver:1.1                       
CPU : Dual Core AMD Opteron(tm) Processor 270                                   

Jun  8 18:37:16 slab kernel: BUG: warning at
kernel/softirq.c:138/local_bh_enable() (Not tainted)
Jun  8 18:37:16 slab kernel:  [<c042b0cf>] local_bh_enable+0x45/0x92
Jun  8 18:37:16 slab kernel:  [<c06002bd>] cond_resched_softirq+0x2c/0x42
Jun  8 18:37:16 slab kernel:  [<c059adf3>] release_sock+0x4f/0x9d
Jun  8 18:37:16 slab kernel:  [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
Jun  8 18:37:16 slab kernel:  [<c059adb6>] release_sock+0x12/0x9d
Jun  8 18:37:16 slab kernel:  [<c05c7755>] tcp_recvmsg+0x8d2/0x9de
Jun  8 18:37:16 slab kernel:  [<c04808dc>] core_sys_select+0x218/0x2f3
Jun  8 18:37:16 slab kernel:  [<c05dec95>] inet_sendmsg+0x3b/0x45
Jun  8 18:37:17 slab kernel:  [<c0598731>] sock_aio_write+0xf6/0x102
Jun  8 18:37:17 slab kernel:  [<c045da36>] get_page_from_freelist+0x23b/0x2a5
Jun  8 18:37:17 slab kernel:  [<c04754ee>] do_sync_write+0xc7/0x10a
Jun  8 18:37:17 slab kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
Jun  8 18:37:17 slab kernel:  [<c0475d47>] vfs_write+0xbc/0x154
Jun  8 18:37:17 slab kernel:  [<c0476342>] sys_write+0x41/0x67
Jun  8 18:37:17 slab kernel:  [<c0404f70>] syscall_call+0x7/0xb
Jun  8 18:37:17 slab kernel:  =======================
Comment 45 Christopher Wawak 2007-06-08 21:24:12 EDT
Linux x 2.6.21-1.3194.fc7 #1 SMP Wed May 23 22:35:01 EDT 2007 i686 athlon i386
GNU/Linux

Sorry, add to #44 above.
Comment 46 dex 2007-06-09 22:33:07 EDT
kernel-2.6.21-1.3219.fc7 clears this up for me I suggest a trip to
updates-testing or koji there is a gotcha, I could not get kernel 3219.fc7 or
3224.fc7 to boot with mkinitrd-6.0.9-6 from updates-testing reverting back to 
mkinitrd-6.0.9-5 solved this.

 
Comment 47 dex 2007-06-10 20:51:26 EDT
update, kernel-2.6.21-1.3226.fc7 & mkinitrd-6.0.9-6 works well.
Comment 48 Bill C. Riemers 2007-06-11 09:36:25 EDT
*** Bug 243553 has been marked as a duplicate of this bug. ***
Comment 49 dex 2007-06-11 15:18:57 EDT
It seems mkinitrd-6.0.9-6 has been officially marked Bad.
Comment 50 Need Real Name 2007-06-12 00:38:47 EDT
Jun 12 05:59:11 darkstar kernel: BUG: warning at
kernel/softirq.c:138/local_bh_enable() (Not tainted)
Jun 12 05:59:11 darkstar kernel:  [<c042b0cf>] local_bh_enable+0x45/0x92
Jun 12 05:59:11 darkstar kernel:  [<c06002bd>] cond_resched_softirq+0x2c/0x42
Jun 12 05:59:11 darkstar kernel:  [<c059adf3>] release_sock+0x4f/0x9d
Jun 12 05:59:11 darkstar kernel:  [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
Jun 12 05:59:11 darkstar kernel:  [<c05dec95>] inet_sendmsg+0x3b/0x45
Jun 12 05:59:11 darkstar kernel:  [<c0599180>] sock_sendmsg+0xd0/0xeb
Jun 12 05:59:11 darkstar kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
Jun 12 05:59:11 darkstar kernel:  [<c04878d6>] mntput_no_expire+0x11/0x6a
Jun 12 05:59:11 darkstar kernel:  [<c047da8a>] link_path_walk+0xa9/0xb3
Jun 12 05:59:11 darkstar kernel:  [<c0598d2d>] sys_setsockopt+0x88/0xa7
Jun 12 05:59:11 darkstar kernel:  [<c045da36>] get_page_from_freelist+0x23b/0x2a5
Jun 12 05:59:11 darkstar kernel:  [<c0599a44>] sys_sendto+0x118/0x138
Jun 12 05:59:11 darkstar kernel:  [<c045db08>] __alloc_pages+0x68/0x2aa
Jun 12 05:59:11 darkstar kernel:  [<c0469fea>] anon_vma_prepare+0x20/0xb5
Jun 12 05:59:11 darkstar kernel:  [<c0464d24>] __handle_mm_fault+0x8ce/0x8f3
Jun 12 05:59:11 darkstar kernel:  [<c0599a9b>] sys_send+0x37/0x3b
Jun 12 05:59:11 darkstar kernel:  [<c059a406>] sys_socketcall+0x14a/0x261
Jun 12 05:59:11 darkstar kernel:  [<c0404f70>] syscall_call+0x7/0xb
Jun 12 05:59:11 darkstar kernel:  [<c0600000>] __sched_text_start+0x6e8/0x89e
Jun 12 05:59:11 darkstar kernel:  =======================

Intel(R) Core(TM)2 CPU          6600  @ 2.40GHz
Linux foo 2.6.21-1.3194.fc7 #1 SMP Wed May 23 22:35:01 EDT 2007 i686 i686 i386
GNU/Linux
Comment 51 Robert Scheck 2007-06-12 02:04:06 EDT
!! Please don't report tainted kernels and try to update to kernel-2.6.21-1
.3219.fc7, .3224.fc7 or .3226.fc7 to see whether they solve your problem. The
initial F7 kernel is known to have this problem/bug, so just report here if
you can reproduce it with a newer kernel, too !!
Comment 52 Chuck Ebbert 2007-07-05 16:55:27 EDT
*** Bug 246462 has been marked as a duplicate of this bug. ***
Comment 53 Chuck Ebbert 2007-07-19 09:59:13 EDT
*** Bug 248853 has been marked as a duplicate of this bug. ***
Comment 54 Linux Semi 2007-07-30 18:54:40 EDT
> Comment #36 From Chuck Ebbert  	 on 2007-06-05 16:52 EST  	[reply]
> Fix is in CVS, will be in the next kernel update.

Is this fix available as part of a build yet?
Comment 55 Linux Semi 2007-07-30 19:00:48 EDT
(In reply to comment #54)
> > Comment #36 From Chuck Ebbert  	 on 2007-06-05 16:52 EST  	[reply]
> > Fix is in CVS, will be in the next kernel update.
> 
> Is this fix available as part of a build yet?

Nevermind...   "Fixed In   	2.6.21-1.3228.fc7"
Missed that important detail.

Note You need to log in before you can comment on or make changes to this bug.