This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 241630 - [F7] make the choices understandable to users
[F7] make the choices understandable to users
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: im-chooser (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Akira TAGOH
: i18n
: 244635 246097 (view as bug list)
Depends On: 243563
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-29 01:10 EDT by Jens Petersen
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 06:31:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2007-05-29 01:10:00 EDT
Description of problem:
Now that scim and im-chooser are always installed by default in F7
we need to fix im-chooser's choices to not confuse users using
non-Asian desktop who don't know how to turn on IM.

How reproducible:
every time

Steps to Reproduce:
1. start default desktop in non-Asian locale
2. run im-chooser
  
Actual results:
2. Shows "Follow system-wide configuration [SCIM]"
3. need to select "Use custom input method" -> scim, to select scim IM.

Expected results:
2. Should say "Follow system-wide configuration", ideally with "[off]" appended.
3. Need something like "Always use input methods" choice, ie to override
locale restriction in xinput.sh.

Additional info:
See also:
https://www.redhat.com/archives/fedora-maintainers/2007-April/msg00393.html
but initially the full solution is not required.
Comment 1 Andreas Tunek 2007-06-13 12:48:56 EDT
I also think this is a really important issue, it took me about 2 hours to
understand this issue.今できるけど…好的好!
Comment 2 Jens Petersen 2007-06-20 21:31:14 EDT
*** Bug 244635 has been marked as a duplicate of this bug. ***
Comment 3 Y. N. 2007-06-23 11:43:10 EDT
I changed setting on im-chooser following.
  Use custom input method : scim

Since, login window changed language from English to Japanese.

Does the issue occurred to change settings on im-chooser?
Comment 4 Jens Petersen 2007-06-24 21:36:47 EDT
(In reply to comment #3)
> Since, login window changed language from English to Japanese.

I don't know what happened on your system but im-chooser
should effect the system or desktop language (locale).
Comment 5 Akira TAGOH 2007-07-30 03:28:08 EDT
should be fixed in 0.4.1-2.fc8.
Comment 6 Jens Petersen 2007-07-31 01:39:38 EDT
Thanks - looks better now. :)

Will there be a F7 update or is that not possible?
Comment 7 Jens Petersen 2007-07-31 01:56:26 EDT
I am wondering if the UI could be simplified though,
say to be chooser widget with just as few choices as possible.
So if scim is installed, the choice would just be:

  Do not use IM.
  Use IM (SCIM).

That would be very intuitive and easy for users to understand.
Comment 8 Akira TAGOH 2007-07-31 19:40:28 EDT
(In reply to comment #6)
> Thanks - looks better now. :)
> 
> Will there be a F7 update or is that not possible?

a bug has to be filed for xinput.sh transition first.

(In reply to comment #7)
> I am wondering if the UI could be simplified though,
> say to be chooser widget with just as few choices as possible.
> So if scim is installed, the choice would just be:
> 
>   Do not use IM.
>   Use IM (SCIM).
> 
> That would be very intuitive and easy for users to understand.
> 

Could you tell me more details? it sounds like you would make it more
scim-specific, is it what you are expecting there? or what's the expected behavior?

I'd put this as a neutral tool for all of IMs and I'm still thinking that having
a separate options for all-in-one IMs (such as scim and uim) and
language-specific IM (such as XIM), because the language-specific IM can't be
brought up on every languages and I think those should be split up to not
confuse people who wants to use the same IM on some languages.

I have an idea to improve much more to get less confusion. since the default
input method can be displayed against current language, we can do the same thing
for the legacy input method too. then they can know which the legacy input
method is available for their language.
Comment 9 Jens Petersen 2007-08-01 19:45:33 EDT
No, it would not be scim specific, just a different UI.
(By "chooser widget" above I meant a Combo box BTW, sorry.)

So rather than using GtkRadioButton's I would suggest using
a GtkComboBox which would just list the available choices
(for most users there would just be one or two probably).
Comment 10 Jens Petersen 2007-08-01 19:51:46 EDT
So the entries in the ComboBox would be something like:

A) For no IM installed - no choice:

* "Do not use IM" or "No IM available".

B) Typical case - only scim installed:

* "Do not use IM"
* "Use IM always (SCIM)"

C) various IM's installed:

* "Do not use IM"
* "Use SCIM (default)"
* "Use UIM"
* "Use kinput2 (legacy XIM)"
Comment 11 Akira TAGOH 2007-08-01 23:28:42 EDT
Okay, I see what you mean. that basically sounds good though, there are some issues.

Since any changes is applied immediately regardless of it was expected or
unexpected, that way may breaks the IM configuration when im-chooser is brought
up if current one is somehow not available.  Current behavior for such case just
disables that option from UI and should keeps that as is till people chooses
another one.

Also I'm a bit concerned it may becomes unusable and be messed up then when more
IMs are added under xinput.d, because people has to choose one from a lot of IMs
at the ComboBox.

What do you think about them?
Comment 12 Jens Petersen 2007-08-02 00:09:04 EDT
> Since any changes is applied immediately regardless of it was expected or
> unexpected, that way may breaks the IM configuration when im-chooser is 
> brought up if current one is somehow not available.  Current behavior for such 
> case just disables that option from UI and should keeps that as is till people 
> chooses another one.

Good question.  So you mean for example if uim was installed and user
had chosen that with Custom -> UIM and now uim was removed and the user
runs im-chooser again.  Hmm, maybe add a ComboBox entry like
"Custom .xinputrc", maybe labelling it as a broken symlink say?

BTW how does im-chooser handle real customized .xinputrc files
(ie .xinputrc edited by hand by user) currently?

> Also I'm a bit concerned it may becomes unusable and be messed up then when 
> more IMs are added under xinput.d, because people has to choose one from a lot 
> of IMs at the ComboBox.

True.  In that case I might suggest having a checkbox "Turn on IM"
which would enable the ComboBox defaulting to SCIM say (system default) -
then the ComboBox would be more an advanced option.
Comment 13 Akira TAGOH 2007-08-02 03:26:32 EDT
(In reply to comment #12)
> > Since any changes is applied immediately regardless of it was expected or
> > unexpected, that way may breaks the IM configuration when im-chooser is 
> > brought up if current one is somehow not available.  Current behavior for such 
> > case just disables that option from UI and should keeps that as is till people 
> > chooses another one.

Hmm, the behavior is a bit inconsistent right now:

a. If one chooses the legacy IM at im-chooser, and run im-chooser again after
XIM packages has been removed, im-chooser keeps an option at the legacy IM and
just disables it.

b. If one chooses something from the custom, and run im-chooser again after that
package has been removed, im-chooser points to the default but no changes in
.xinputrc.

> Good question.  So you mean for example if uim was installed and user
> had chosen that with Custom -> UIM and now uim was removed and the user
> runs im-chooser again.  Hmm, maybe add a ComboBox entry like
> "Custom .xinputrc", maybe labelling it as a broken symlink say?

maybe, need more better words though.

> BTW how does im-chooser handle real customized .xinputrc files
> (ie .xinputrc edited by hand by user) currently?

In that case, im-chooser just shows "User Specific" at the custom, because there
are no guarantees that it has the proper variables. so im-chooser just gets off
evaluating and parsing it.

> True.  In that case I might suggest having a checkbox "Turn on IM"
> which would enable the ComboBox defaulting to SCIM say (system default) -
> then the ComboBox would be more an advanced option.

Hm, ok. just thought the sort of this UI was an initial idea before Warren's.

FWIW we should use a drop-down list or a list instead of a combination boxes
because of this:

<quote
from="http://developer.gnome.org/projects/gup/hig/2.0/controls-combo-boxes.html">
 * If the user types a value into the drop-down combination box that is not
already in the drop-down list, add it to the list when the drop-down combination
box loses focus so they can select it next time
</quote>
Comment 14 Akira TAGOH 2007-09-14 06:31:43 EDT
For the reference, im-chooser should be improved now according to
http://fedoraproject.org/wiki/AkiraTagoh/IMChooser/UIImprovements
Comment 15 Jens Petersen 2007-10-16 02:55:41 EDT
*** Bug 246097 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.