Bug 244635 - Doesn't use japanese language in anthy.
Doesn't use japanese language in anthy.
Status: CLOSED DUPLICATE of bug 241630
Product: Fedora
Classification: Fedora
Component: im-chooser (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-18 05:05 EDT by Y. N.
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-20 21:31:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Y. N. 2007-06-18 05:05:40 EDT
Description of problem:
I changed language from English to Japanese.
Then, i put "zenkaku_hankaku" key.

But language didn't change from English to Japanese.

When i installed Fedora7, System language was English.
After installed Fedora7, I installed scim, anthy, and japanese language.

I found following similar issue.
URL:http://bbs.fedora.jp/read.php?FID=11&TID=5803

So, I changed xmodmap file.
But, the issue doesn't resolve.

If other doc needed, please send me mail.

Colud you please answer above the issue.

Version-Release number of selected component (if applicable):
$ uname -a
Linux localhost.localdomain 2.6.21-1.3228.fc7 #1 SMP Tue Jun 12 14:56:37 EDT
2007 x86_64 x86_64 x86_64 GNU/Linux

$ yum list scim
Loading "installonlyn" plugin
Installed Packages
scim.x86_64                              1.4.5-21.fc7           installed 

yum list anthy
Loading "installonlyn" plugin
Installed Packages
anthy.x86_64                             8706-2.fc7             installed       
Available Packages
anthy.i386                               8706-2.fc7             fedora 

How reproducible:


Steps to Reproduce:
1.Edditor application(gedit, writer, and web browser etc...) start up
2.Put "zenkaku_hankaku" key. 
3.Doesn't start anthy.
  
Actual results:
When I put "zenkaku_hankaku" key, i can use japanese language.

Expected results:
I can't use japanese language.

Thank you and Best Regards Y. N.
Comment 1 Jens Petersen 2007-06-18 20:35:25 EDT
Does upgrading to scim-1.4.5-21.fc7, help?
Comment 2 Jens Petersen 2007-06-18 20:42:09 EDT
(In reply to comment #1)
> Does upgrading to scim-1.4.5-21.fc7, help?
| scim.x86_64                              1.4.5-21.fc7           installed

Sorry I see you already updated to that.
Comment 3 Akira TAGOH 2007-06-18 21:08:05 EDT
I'm not still sure what issues are exactly related to that. but apparently there
are two things there.

One is, if you ran scim initially on English locale, you can't use
Zenkaku_Hankaku key to activate IM by default unless you modify it on
scim-setup. we have a hack to have suitable keybinding for the language. and it
only affects at the initial running because all the configurations are stored
under $HOME/.scim. in this case, removing $HOME/.scim might helps you.

Another one is, if you're still logging into the desktop with English locale but
just want to use scim and anthy to input Japanese on even English locale, you
need to choose scim with im-chooser explicitly on F7, because we have scim
installed by default regardless of what language people uses now. and we have
disabled IM for non-CJKI locales by default due to hitting the on/off keys
accidentally and some of them are annoying on some applications.

Or do you mind any different thing?
Comment 4 Y. N. 2007-06-19 09:14:30 EDT
I want to use English in system language.
And in the environment on machine, i want to use japanese language.

See attached command output
--------------------------------
# more $HOME/.scim/config
/DefaultIMEngineFactory/ta_IN = IMEngine-M17N-ta-tamil99
/DefaultIMEngineFactory/zh_CN = 05235cfc-43ce-490c-b1b1-c5a2185276ae
/DefaultIMEngineFactory/zh_HK = e5e88504-6fae-4c34-8324-49508cfad72a
/DefaultIMEngineFactory/zh_SG = 05235cfc-43ce-490c-b1b1-c5a2185276ae
/DefaultIMEngineFactory/zh_TW = fcff66b6-4d3e-4cf2-833c-01ef66ac6025
/FrontEnd/ChangeFactoryGlobally = false
/FrontEnd/OnTheSpot = true
/FrontEnd/SharedInputMethod = false
/FrontEnd/Socket/ConfigReadOnly = false
/FrontEnd/Socket/MaxClients = 512
/FrontEnd/X11/BrokenWchar = true
/FrontEnd/X11/Dynamic = false
/FrontEnd/X11/OnTheSpot = true
/FrontEnd/X11/ServerName = SCIM
/Hotkeys/FrontEnd/NextFactory = 
/Hotkeys/FrontEnd/NextFactory/zh_CN =
Control+Alt+Down,Shift+Control+KeyRelease+Shift_L,Shift+Control+KeyR
elease+Shift_R
/Hotkeys/FrontEnd/NextFactory/zh_HK =
Control+Alt+Down,Shift+Control+KeyRelease+Shift_L,Shift+Control+KeyR
elease+Shift_R
/Hotkeys/FrontEnd/NextFactory/zh_SG =
Control+Alt+Down,Shift+Control+KeyRelease+Shift_L,Shift+Control+KeyR
elease+Shift_R
/Hotkeys/FrontEnd/NextFactory/zh_TW =
Control+Alt+Down,Shift+Control+KeyRelease+Shift_L,Shift+Control+KeyR
elease+Shift_R
/Hotkeys/FrontEnd/Off = 
/Hotkeys/FrontEnd/On = 
/Hotkeys/FrontEnd/PreviousFactory = 
/Hotkeys/FrontEnd/PreviousFactory/zh_CN =
Control+Alt+Up,Shift+Control+KeyRelease+Control_L,Shift+Control+
KeyRelease+Control_R
/Hotkeys/FrontEnd/PreviousFactory/zh_HK =
Control+Alt+Up,Shift+Control+KeyRelease+Control_L,Shift+Control+
KeyRelease+Control_R
/Hotkeys/FrontEnd/PreviousFactory/zh_SG =
Control+Alt+Up,Shift+Control+KeyRelease+Control_L,Shift+Control+
KeyRelease+Control_R
/Hotkeys/FrontEnd/PreviousFactory/zh_TW =
Control+Alt+Up,Shift+Control+KeyRelease+Control_L,Shift+Control+
KeyRelease+Control_R
/Hotkeys/FrontEnd/ShowFactoryMenu = 
/Hotkeys/FrontEnd/Trigger = Control+space
/Hotkeys/FrontEnd/Trigger/ja_JP = Zenkaku_Hankaku,Alt+grave,Control+space
/Hotkeys/FrontEnd/Trigger/ko_KR =
Alt+Alt_L+KeyRelease,Shift+space,Control+space,Hangul
/Hotkeys/FrontEnd/ValidKeyMask = Shift+Control+Alt+CapsLock+Meta+Super+Hyper
/IMEngine/RawCode/Locales = default
/Panel/Gtk/Color/ActiveBackground = light sky blue
/Panel/Gtk/Color/ActiveText = black
/Panel/Gtk/Color/NormalBackground = #F7F3F7
/Panel/Gtk/Color/NormalText = black
/Panel/Gtk/DefaultSticked = false
/Panel/Gtk/Font = default
/Panel/Gtk/LookupTableEmbedded = true
/Panel/Gtk/LookupTableVertical = true
/Panel/Gtk/ShowStatusBox = false
/Panel/Gtk/ShowTrayIcon = true
/Panel/Gtk/ToolBar/AlwaysShow = false
/Panel/Gtk/ToolBar/AutoSnap = true
/Panel/Gtk/ToolBar/HideTimeout = 2
/Panel/Gtk/ToolBar/POS_X = -1
/Panel/Gtk/ToolBar/POS_Y = -1
/Panel/Gtk/ToolBar/ShowFactoryIcon = true
/Panel/Gtk/ToolBar/ShowFactoryName = true
/Panel/Gtk/ToolBar/ShowHelpIcon = true
/Panel/Gtk/ToolBar/ShowMenuIcon = true
/Panel/Gtk/ToolBar/ShowSetupIcon = true
/Panel/Gtk/ToolBar/ShowStickIcon = false
/UpdateTimeStamp = 1182258083:937525

# more $HOME/.scim/global
/DefaultKeyboardLayout = Japanese

# locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

# im-chooser
  popup window
   -> Follow the system-wide configuration[SCIM]
---------------------------------
Comment 5 Akira TAGOH 2007-06-19 09:56:59 EDT
I'd like to clarify one thing - What you are claiming here is only to be able to
activate IM with Zenkaku_Hankaku key on even English locale and you have a
Japanese keyboard right?

Then it's a first case I mentioned above. and apparently this is not a bug,
because Zenkaku_Hankaku key are only enabled when one runs the desktop on
Japanese locale, and also need to ensure there are no $HOME/.scim that created
by scim running on other locale.

1. run scim-setup
2. click FrontEnd->Global Setup from the left side tree
3. click "..." button for Trigger
4. click "..." button on "Select the trigger keys" window
5. press Zenkaku_Hankaku key
6. click "Add" button and "OK" button then

The above instructions should works to get your Zenkaku_Hankaku key working for
turning scim on/off.
Comment 6 Jens Petersen 2007-06-19 20:47:30 EDT
I agree with Tagoh's accessment:

(In reply to comment #4)
> /Hotkeys/FrontEnd/Trigger = Control+space

This is your trigger hotkey.

> /Hotkeys/FrontEnd/Trigger/ja_JP = Zenkaku_Hankaku,Alt+grave,Control+space

This is only used (the first time) when you run scim in Japanese
without a .scim/config file.

> LANG=en_US.UTF-8

Since you are in English locale, you will not get Zenkaku_Hankaku.

> # im-chooser
>    -> Follow the system-wide configuration[SCIM]

In Fedora 7 with en_US.UTF-8 you actually need to set
"Custom -> scim" in im-chooser to use scim.
Comment 7 Y. N. 2007-06-20 10:34:18 EDT
I changed settings in im-chooser to use scim.
 -> "Custom -> scim"

So, I can use japanese language.
This setting is used log-in windows in japanese.


Thank you for your kind supports.
Comment 8 Jens Petersen 2007-06-20 21:31:11 EDT

*** This bug has been marked as a duplicate of 241630 ***

Note You need to log in before you can comment on or make changes to this bug.