Bug 241858 - FC6.93 rawhide sees my ata/ide drives as scsi - sda, sdb......
FC6.93 rawhide sees my ata/ide drives as scsi - sda, sdb......
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hal-info (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
: 241857 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-31 03:19 EDT by lynn evan sorenson
Modified: 2013-03-05 22:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-31 10:40:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description lynn evan sorenson 2007-05-31 03:19:24 EDT
Description of problem: (not positive this is HAL)

I have no scsi, sata, usb connected.  Mount shows only
sdb5(boot),sdb6(root),sdb3(swap).

Original device.map had (hd0) /dev/sda, (hd1) /dev/sdb.

Version-Release number of selected component (if applicable):
Fedora6.93

How reproducible:
Impossible to get rid of.

Steps to Reproduce:
1.open shell tool, type mount:/dev/sdb6 on / type ext3 (rw), /dev/sdb5 on /boot
type ext3 (rw), /dev/sdb3 (swap).  All these are on hdb.
2.In /dev, the only device starting w/ h is 'hpet'.  No
hda,hda1...hdb,hdb1,hdb2,etc.
3.
  
Actual results:
On boot up I get errors: usb 1-1 device descriptor read error/64 -62 (repeat 4
times), then 'not accepting address 5', 'not accepting address 6'.

Expected results:
ata/ide identified correctly.  usb identified correctly.

Additional info:  Can send examples of mount, mtab, /proc/partitions, sfdisk,
and more if asked.
Comment 1 lynn evan sorenson 2007-05-31 03:22:28 EDT
Remember!  I have no sata, usb, scsci (unless CDs are considered scsci) but they
should be hdc & hdd.  The following is short and from /proc/partitions:
major minor  #blocks  name

   8     0  117220824 sda
   8     1   58733608 sda1
   8     2          1 sda2
   8     5   58484601 sda5
   8    16  117220824 sdb
   8    17      64228 sdb1
   8    18   10185210 sdb2
   8    19    2096482 sdb3
   8    20          1 sdb4
   8    21     112423 sdb5
   8    22   20490876 sdb6
Comment 2 David Zeuthen 2007-05-31 10:34:32 EDT
*** Bug 241857 has been marked as a duplicate of this bug. ***
Comment 3 David Zeuthen 2007-05-31 10:40:12 EDT
Hmm, sorry to rant but

 - you filed two bugs; it would have been nice if you closed
   bug 241857 - done that for you

 - it's not a bug that the devices are named sd* instead of hd*;
   that's just a side effect of moving from ide to new pata drivers
   that use the SCSI midlayer internally - which makes sense
   as recent SATA and all ATAPI is basically just SCSI at the low
   level anyway

 - what's in a device name *anyway*? You should never ever depend
   on device names; use the persistent names in /dev/disk/*; that's
   what they're there for

 - the usb errors should be filed as a bug against the kernel; because
   that's the package the USB drivers originate from

 - have no idea why you filed this against hal-info

Sorry if this response comes across as offensive; it's written in the hope that
it will help you file bugs in the future. Thanks!




Note You need to log in before you can comment on or make changes to this bug.