Bug 242075 - device-mapper mirror: Writes to non-synced regions must be marked/cleared in the log
device-mapper mirror: Writes to non-synced regions must be marked/cleared in ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Jonathan Earl Brassow
Martin Jenner
:
Depends On: 242074
Blocks: 425461
  Show dependency treegraph
 
Reported: 2007-06-01 11:31 EDT by Jonathan Earl Brassow
Modified: 2008-01-15 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 17:06:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Earl Brassow 2007-06-01 11:31:46 EDT
+++ This bug was initially created as a clone of Bug #242074 +++

During normal mirror operation (i.e. when the devices are
in-sync), a write is preceded by marking the log and is
followed by clearing the log.  However, when the mirror is
in recovery, the marks and clears are not performed.

For single machine mirroring, this is fine; because the
mirroring code can control conflicts between writes and
re-syncing via the region hashing code.  However, this
is not possible in a cluster.  If a remote machine does not
mark the log for a non-sync'ed write, it is impossible
to tell when/if there will be a conflict with the re-syncing
process.

Marking/clearing regions that are not-in-sync will allow
the (cluster) logging code to avoid handing out re-sync work
that might conflict with an outstanding write.  It can also
delay writes briefly to a region that is being resync'ed.
Comment 1 RHEL Product and Program Management 2007-06-01 11:44:33 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Jay Turner 2007-06-01 13:49:06 EDT
What testing do we have to verify this change is effective and doesn't introduce
regressions?
Comment 5 Jonathan Earl Brassow 2008-01-15 17:06:35 EST
This change is not necessary.

The 'is_remote_recovering' call which is made before a write takes place is all that is ever needed - as long 
as it returns /true/ if the region is not in-sync for cluster implementations.

Note You need to log in before you can comment on or make changes to this bug.