Bug 242074 - device-mapper mirror: Writes to non-synced regions must be marked/cleared in the log
device-mapper mirror: Writes to non-synced regions must be marked/cleared in ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.5
All Linux
low Severity low
: ---
: ---
Assigned To: Jonathan Earl Brassow
Martin Jenner
:
Depends On:
Blocks: 242075 243773
  Show dependency treegraph
 
Reported: 2007-06-01 11:29 EDT by Jonathan Earl Brassow
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:28:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Earl Brassow 2007-06-01 11:29:34 EDT
During normal mirror operation (i.e. when the devices are
in-sync), a write is preceded by marking the log and is
followed by clearing the log.  However, when the mirror is
in recovery, the marks and clears are not performed.

For single machine mirroring, this is fine; because the
mirroring code can control conflicts between writes and
re-syncing via the region hashing code.  However, this
is not possible in a cluster.  If a remote machine does not
mark the log for a non-sync'ed write, it is impossible
to tell when/if there will be a conflict with the re-syncing
process.  [RHEL 4 must currently delay writes to non-synced
regions until they have been recovered - a sometimes excessive
delay.]

Marking/clearing regions that are not-in-sync will allow
the (cluster) logging code to avoid handing out re-sync work
that might conflict with an outstanding write.  It can also
delay writes briefly to a region that is being resync'ed.
Comment 1 RHEL Product and Program Management 2007-06-01 11:45:07 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Jonathan Earl Brassow 2007-06-01 14:32:34 EDT
assigned -> post
Comment 3 RHEL Product and Program Management 2007-06-01 14:41:51 EDT
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 4 Jason Baron 2007-06-29 18:20:03 EDT
committed in stream U6 build 55.15. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 7 errata-xmlrpc 2007-11-15 11:28:01 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html

Note You need to log in before you can comment on or make changes to this bug.