Bug 242103 - Closing an active chess game kills gnome
Closing an active chess game kills gnome
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 242392 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 14:11 EDT by Brendan Wood
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.18.2.1-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-28 09:18:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (906 bytes, text/plain)
2007-06-04 09:14 EDT, Brendan Wood
no flags Details
Log of running X when crash occured (53.06 KB, text/plain)
2007-06-04 09:15 EDT, Brendan Wood
no flags Details
Current X log (52.07 KB, text/plain)
2007-06-04 09:15 EDT, Brendan Wood
no flags Details
Dmesg output (30.82 KB, text/plain)
2007-06-04 09:16 EDT, Brendan Wood
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 443073 None None None Never

  None (edit)
Description Brendan Wood 2007-06-01 14:11:02 EDT
Description of problem:
When closing a running instance of the "chess game", the display manager (gnome)
reloads and I am taken back to the GDM login screen.  I do have desktop effects
enabled.

(this is on a brand new F7 install)


How reproducible:
Open the chess application, start a game and then close the window.


Actual results:
The DM dies.

Expected results:
The application closes.

Additional info:
I have reproduced this on 2 machines here, but both machines are the exact same
hardware and configuration - so I can't say that this isn't unique to my
environment.  Please let me know if I can provide any logs or anything.

Thanks.
Comment 1 Andreas Røsdal 2007-06-01 19:33:00 EDT
Reported upstream here: http://bugzilla.gnome.org/show_bug.cgi?id=443073
Comment 2 Andreas Weggel 2007-06-03 10:04:16 EDT
I have the same problem here Fedora 7.

AMD Athlon XP 2800+ 1GB Ram Nvidia Geforce 6600GT
Comment 3 Matěj Cepl 2007-06-04 04:57:50 EDT
In order to investigate this from the xorg point-of-view (xorg should never
crash whatever applicaton does), could I ask you for some more information about
X? I know that you were saying in bug 242175 comment 2 that you don't have FC7
anymore, but could you bear with us for a little more; otherwise we cannot solve
this problem?

We would need your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) attached to the bug report as individual uncompressed
file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

Thanks in advance.
Comment 4 Matěj Cepl 2007-06-04 05:00:08 EDT
Sorry, Brendan, I confused your name with Andreas. Hopefully, you haven't given
up on FC7 yet ;-), so could you please provide us the information required.
Comment 5 Brendan Wood 2007-06-04 09:14:51 EDT
Created attachment 156071 [details]
xorg.conf
Comment 6 Brendan Wood 2007-06-04 09:15:26 EDT
Created attachment 156072 [details]
Log of running X when crash occured
Comment 7 Brendan Wood 2007-06-04 09:15:49 EDT
Created attachment 156073 [details]
Current X log
Comment 8 Brendan Wood 2007-06-04 09:16:06 EDT
Created attachment 156074 [details]
Dmesg output
Comment 9 Brendan Wood 2007-06-04 09:20:46 EDT
I attached a bunch of log files, hopefully something of value will be in there.

I am more than happy to help work out this issue.  It is by no means a "show
stopper" for me, as I don't play chess.  I noticed the app, tried it -> noticed
the crash and figured I would tell someone.  No plans to give up on FC7. 

One thing I did notice is that xorg is now using the "intel" driver, not the
normal i810 driver I have used in the past (my laptop has an integrated i915
intel card).  The driver works fine, except with playing video clips (which
gives me an error such as:

X11 error: BadAlloc (insufficient resources for operation)0.3% 0 0              
X11 error: BadAlloc (insufficient resources for operation)

If I switch to the i810 driver, movies play fine but it won't resume after a
suspend (something that has always worked flawlessly in the past). 

Not sure if this issue is driver related - so I am mentioning this.

All in all, I love fc7 though.

-Brendan

Comment 10 Ray Strode [halfline] 2007-06-04 10:29:12 EDT
what version of gnome-games do you have installed?
Comment 11 Ray Strode [halfline] 2007-06-04 10:30:16 EDT
If you run glxgears, does it also crash your system?
Comment 12 Ray Strode [halfline] 2007-06-04 10:34:30 EDT
*** Bug 242392 has been marked as a duplicate of this bug. ***
Comment 13 Brendan Wood 2007-06-04 11:30:37 EDT
gnome-games-2.18.1.1-1.fc7

glxgears does not crash anything, it runs/closes fine.
Comment 14 Faolan 2007-06-08 14:59:43 EDT
I'm having the same problem. I can send in my info if you'd like. Although, I
did note that when I open it in terminal, and then close it out, it doesn't kill
the X session. (It hasn't so far at the very least.)
Comment 15 Robert Ancell 2007-06-10 08:07:31 EDT
This bug is now fixed in Gnome svn. See bug link for details:
http://bugzilla.gnome.org/show_bug.cgi?id=443073

Comment 16 Jim Cornette 2007-06-10 11:28:33 EDT
Adding self to report. Running on the below hardware. DEsktop effects enabled
and compiz as desktop manager.

00:00.0 Host bridge: ATI Technologies Inc AGP Bridge [IGP 320M] (rev 13)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 320M] (rev 01)
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link
Controller Audio Device (rev 02)
00:07.0 ISA bridge: ALi Corporation M1533/M1535 PCI to ISA Bridge [Aladdin IV/V/V+]
00:08.0 Modem: ALi Corporation M5457 AC'97 Modem Controller
00:0a.0 CardBus bridge: O2 Micro, Inc. OZ601/6912/711E0 CardBus/SmartCardBus
Controller
00:0c.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000
Controller (PHY/Link)
00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
00:11.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:12.0 Ethernet controller: National Semiconductor Corporation DP83815
(MacPhyter) Ethernet Controller
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility U1
Comment 17 Fedora Update System 2007-06-16 09:22:04 EDT
gnome-games-2.18.2.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Jim Cornette 2007-06-17 07:35:02 EDT
It closed down now without killing X.
Comment 19 Fedora Update System 2007-06-18 12:39:10 EDT
gnome-games-2.18.2.1-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2007-06-28 09:18:30 EDT
gnome-games-2.18.2.1-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.