Bug 242274 - xfig fonts error when input text
xfig fonts error when input text
Status: CLOSED DUPLICATE of bug 56490
Product: Fedora
Classification: Fedora
Component: xfig (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Depends On:
  Show dependency treegraph
Reported: 2007-06-02 18:13 EDT by Yusuf Ma
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-15 17:43:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Screen shot of the xfig error message (38.64 KB, image/png)
2007-06-02 18:13 EDT, Yusuf Ma
no flags Details

  None (edit)
Description Yusuf Ma 2007-06-02 18:13:16 EDT
Description of problem:
xfig can't find fonts when input text

Version-Release number of selected component (if applicable):

How reproducible:
Every time

Steps to Reproduce:
1. Open a new xfig file
2. Choose text tool
3. Click to input text
Actual results:
The following error message pops up:
"Can't find -*-times-medium-r-normal--13-*-*-*-*-*-ISO8859-*, using 6x13"

Expected results:
Should be able to input text

Additional info:
This happens for almost all fonts. Remove xfig package and install the old FC6
xfig package (version 3.2.4-21.1) and there is no such problem.

The screen shot of the error message is attached.
Comment 1 Yusuf Ma 2007-06-02 18:13:16 EDT
Created attachment 156001 [details]
Screen shot of the xfig error message
Comment 2 David Munro 2007-07-11 17:06:52 EDT
I can confirm this bug.  It makes xfig-3.2.5-1.fc7 unusable; it will not read
old .fig files that contain any of the "missing" fonts, which is almost all as
mentioned above.  Not only does xfig 3.2.4 work, but also 3.2.5_alpha5 (compiled
from source).  The problem seems to be in the latest 3.2.5 source.  The problem
sounds like Debian bug #366948, although the resolution of that bug report does
not seem to match the problem in Fedora.
Comment 3 David Munro 2007-07-25 20:09:28 EDT
I traced the problem to the scalablefonts resource; it was off by default in
earlier versions, but now the default is on.  If you start xfig like this:

xfig -noscalablefonts

or if you add the X11 resource

Fig.scalablefonts: false

to either /usr/share/X11/app-defaults/Fig or to ~/.Xresources, you get back to
the correct behavior.  One possible fix would be to add this to the Fig.ad file
in the source.  However, it is possible that there is some obscure xorg font
package I have not installed which would fix this problem.  If so, xfig should
be made dependent on it; without this workaround, xfig is unusable.
Comment 4 Hans de Goede 2007-11-15 17:43:21 EST

I'm a new co-maintainer for xfig, this is a duplicate of bug 56490, closing as such.

*** This bug has been marked as a duplicate of 56490 ***

Note You need to log in before you can comment on or make changes to this bug.