Bug 56490 - fonts in xfig are wrong
fonts in xfig are wrong
Status: CLOSED DUPLICATE of bug 210278
Product: Fedora
Classification: Fedora
Component: xfig (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
:
: 242274 294111 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-19 17:14 EST by Jonathan Kamens
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 17:45:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2001-11-19 17:14:26 EST
When I try to use font Zapf-Chancery in xfig, I get a pop-up dialog with
this error in it:

Can't load font -*-itc zapf
chancery-medium-i-normal--12-*-*-*-*-*-ISO8859-*
  trying -*-itc zapf chancery-medium-i-normal--12-*-*-*-*-*-ISO8859-*
No good, using 6x13

As far as I can tell, the font names are hard-coded in xfig (that's
unfortunate).

Either different font names need to be hard-coded in, or the X fonts need
to be updated to include the aliases that xfig is looking for.  I assume
that other font names besides this one are wrong.
Comment 1 Sammy 2001-11-23 23:16:11 EST
Try putting font.alias files in 100dpi and 75dpi directories that 
associate itc font with whatever ZapfChancery font you have.
There are different names for these fonts that couse confusion.
I had done this long time ago and it worked.
Comment 2 Ngo Than 2001-12-20 04:04:32 EST
It's a bug in XFree86.
Comment 3 Mike A. Harris 2002-05-30 02:17:34 EDT
Patches welcome.  ;o)
Comment 4 Mike A. Harris 2002-11-03 02:17:18 EST
I haven't seen any upstream movement on this, and haven't seen anyone
care enough to report it upstream either, so I assume it is a trivial
problem not too worthy of attention.  I definitely consider it a minor
issue myself, and one which should be dealt with by upstream if anyone
is maintaining xfig at all.  If xfig is unmaintained and nobody upstream
is willing to fix it, then perhaps I should remove it.  Red Hat simply
doesn't have the engineering resources to take over maintainership of
every upstream piece of software that someone chooses to not want to
fix bugs in.

Closing WONTFIX
Comment 5 Jonathan Kamens 2002-11-03 17:07:12 EST
Have you reported it upstream?
Comment 6 Mike A. Harris 2002-11-04 01:08:27 EST
No, and I don't plan on it.  I can't be the middle man on every bug reported
here that isn't of high enough significance to warrant me dealing with it
myself.

We rely on the open source community to fix bugs/problems in their code
as much as we help to contribute fixes.  And we expect people to also report
bugs directly to upstream authors/projects too, and not just rely on Red Hat
being a catch all for bug reports.  The more time I spend in bugzilla
bouncing bugs to upstream people and fiddling around, the less time I'm
doing real work.

I've been extremely liberal in bug reports in the past, and it has shown
me that doing so raises people's expectations that I will troubleshoot
every problem reported, or that I will report it myself and follow through
until a resolution is found.  I don't have the time for that, and many
issues are very trivial, and should be reported in the first place to
the people whom give the problem a larger exposure and chance of being
fixed.  Reporting directly to XFree86.org via xpert@xfree86.org mailing
list, and continuing to follow up there actively with developers is the
best way to get issues addressed, in particular things like this.

For example, if I were to encounter a bug in xfig, I would look at the
manpage, and find out who exactly wrote it, and then email them a bug
report, and possibly other core X members, in an attempt to find out
whom is the best to report the problem to.  That person stands the best
chance to look into the problem, and fix it in a manner consistant with
their source code and experience in the problem domain.

Bug reports are never ending, and as such, I'll be redirecting many
future trivial bug reports to upstream maintainers if I can't justify
spending my time on them personally, and have no personal interest in
the problem.

We here at Red Hat appreciate people reporting bugs, but we also get
a lot of very trivial problems reported here that would never get fixed
by us, simply because there are always much more important priority
bug reports coming in that demand our attention and affect a much much
larger userbase.  All trivial bug reports should thus be reported where
they have the biggest bang.

I'm just being honest about the realities of prioritization and time
resource management, because I do care that these types of bugs get fixed,
and I also know the likelyhood of me personally ever addressing some of
them is very slim.  So, by me telling people to report it elsewhere, and
point them to the proper places, if they follow through, they end up
accelerating the chances of someone fixing the problem being reported,
and a solution coming forth.  I've done this a few times now experimentally,
and have seen the results - bugs do get fixed, and then we can pick up
the fixes.  The end result is faster solutions to problems via delegation.

People do not like to be told "go somewhere else please" sometimes, and
that is always a risk. What is important though, is that people understand
the reason behind it.  The reason, as stated above, is to delegate or
parallelize problem solving, and accelerate the time to a fix.

Sorry if I've went into this deeper than you needed to know, but I've been
delegating a bit more lately, and have had some complaints about it, so I'd
just like to be honest with everyone reading this, so that they know it
is in their own best interest, even if they disagree.  I do wish I had
48 hours in a day, and 9 days in a week....  but I don't.  ;o/

Anyway...  I can now point others here for my delegation speech.  ;o)

TTYL
Comment 7 Jonathan Kamens 2002-11-04 21:58:51 EST
Upon further investigation, it appears that this is a bug in neither xfig nor
XFree86, but rather a bug in RedHat's installation of xfig.  See "NOTE 3" in the
README file included with the xfig source distribution.

Either Red Hat should patch the font names used by xfig, or it should install
the fonts as described in the README file.
Comment 8 Mike A. Harris 2002-11-07 07:12:27 EST
Interesting.  If this is the case, why is it reported against XFree86?

xfig is not part of XFree86.  Reassigning to "xfig" component.

Not a bug in XFree86.

Suggested solution:  Remove xfig from the distro and comps.  OpenOffice
and other utilities duplicate the functionality of this legacy application
anyway.
Comment 9 Sammy 2002-11-12 11:21:24 EST
This font name was changed upon my request a number of years ago since then the 
only vendor providing the zapf fonts was Silicon Graphics. Didn't using font.alias files 
fix the problem? I do not agree to remove xfig from distro, openoffice is no tool for 
technical drawings.
Comment 10 Bill Nottingham 2006-08-07 21:38:52 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.
Comment 11 Jonathan Kamens 2006-08-10 04:23:48 EDT
The version of xfig in fc5 no longer prints an error when you try to use the
font, but the font doesn't work -- it gets displayed as courier, apparently
because xfig still can't find it.  This happens for other fonts as well, so
whenever and however you fix this, you should review all the fonts on the menu
and make sure they all work before considering it fixed.
Comment 12 Hans de Goede 2007-11-15 17:00:32 EST
Hi,

I'm a new co-maintainer for xfig, and I can confirm that this bug is still
present in Fedora 8. I'll be do my best to fix it.
Comment 13 Hans de Goede 2007-11-15 17:43:22 EST
*** Bug 242274 has been marked as a duplicate of this bug. ***
Comment 14 Hans de Goede 2007-11-15 17:43:48 EST
*** Bug 294111 has been marked as a duplicate of this bug. ***
Comment 15 Hans de Goede 2007-11-15 17:45:31 EST
Someone has written a patch for this and it looks decent, I'll give it a try
tomorrow. In the mean time I'm closing this as a duplicate of the bug with the
patch.


*** This bug has been marked as a duplicate of 210278 ***

Note You need to log in before you can comment on or make changes to this bug.