Bug 242275 - Yum crashes when installing package
Yum crashes when installing package
Status: CLOSED DUPLICATE of bug 241604
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 18:16 EDT by Clodoaldo Pinto Neto
Modified: 2014-01-21 17:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-03 03:06:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clodoaldo Pinto Neto 2007-06-02 18:16:36 EDT
When trying to install postgresql:

# yum install postgresql*
Loading "installonlyn" plugin
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package postgresql-python.i386 0:8.2.3-2.fc7 set to be updated
---> Package postgresql-server.i386 0:8.2.3-2.fc7 set to be updated
---> Package postgresql-libs.i386 0:8.2.3-2.fc7 set to be updated
---> Package postgresql.i386 0:8.2.3-2.fc7 set to be updated
--> Processing Dependency: mx for package: postgresql-python
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package mx.i386 0:2.0.6-3 set to be updated

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 postgresql              i386       8.2.3-2.fc7      fedora            3.0 M
 postgresql-libs         i386       8.2.3-2.fc7      fedora            195 k
 postgresql-python       i386       8.2.3-2.fc7      fedora             66 k
 postgresql-server       i386       8.2.3-2.fc7      fedora            4.1 M
Installing for dependencies:
 mx                      i386       2.0.6-3          fedora            4.5 M

Transaction Summary
=============================================================================
Install      5 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 12 M
Is this ok [y/N]: y
Downloading Packages:
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 172, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 302, in doTransaction
    problems = self.downloadPkgs(downloadpkgs) 
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 798, in downloadPkgs
    remote_pkgs.sort(mediasort)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 747, in mediasort
    a = a.getDiscNum()
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 485, in getDiscNum
    return int(fragid)
ValueError: invalid literal for int() with base 10: ''
Comment 1 Ignacio Vazquez-Abrams 2007-06-02 18:23:59 EDT
Are you trying to use your DVD as a repository for yum?
Comment 2 Clodoaldo Pinto Neto 2007-06-02 19:24:53 EDT
It only crashes when using a copy of the install DVD as repository:

/etc/yum.repos.d/fedora.repo:
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
baseurl=http://yumrepo.s0/7/os/
#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$basearch

When using the mirror list it downloads and installs without problems.
Comment 3 Clodoaldo Pinto Neto 2007-06-02 19:38:53 EDT
I issued a createrepo in the DVD directory copy and now I can install from my
own repo.
Comment 4 Kahlil Hodgson 2007-06-02 20:23:35 EDT
I had the same problem with a similar set up.  
Can confirm that running createrepo fixes it for me:-)
Comment 5 Ignacio Vazquez-Abrams 2007-06-03 03:06:46 EDT

*** This bug has been marked as a duplicate of 241604 ***

Note You need to log in before you can comment on or make changes to this bug.