Bug 241604 - yum installs fails trying to install more than one package
Summary: yum installs fails trying to install more than one package
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 7
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords:
: 241964 242275 242967 243203 245496 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-28 20:20 UTC by IBM Bug Proxy
Modified: 2014-01-21 22:58 UTC (History)
9 users (show)

Fixed In Version: 3.2.1-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-28 01:49:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch that fixes the bug (463 bytes, patch)
2007-05-28 20:20 UTC, IBM Bug Proxy
no flags Details | Diff
patch.diff (461 bytes, text/plain)
2007-05-29 13:13 UTC, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 34414 None None None Never

Description IBM Bug Proxy 2007-05-28 20:20:48 UTC
I tried to install some packages via yum. The installations failed, if there
were to install some deps.

Example:

[root@blade1 ~]# yum list | grep eclipse
eclipse-ecj.ppc                          1:3.2.2-8.fc7          core
[root@blade1 ~]# yum install eclipse-ecj.ppc
Loading "installonlyn" plugin
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package eclipse-ecj.ppc 1:3.2.2-8.fc7 set to be updated
Checking deps for eclipse-ecj.ppc 1-3.2.2-8.fc7 - u
--> Processing Dependency: libgcj_bc.so.1 for package: eclipse-ecj
--> Processing Dependency: /usr/bin/rebuild-gcj-db for package: eclipse-ecj
--> Processing Dependency: libgcj >= 4.0.2 for package: eclipse-ecj
--> Processing Dependency: java-gcj-compat >= 1.0.64 for package: eclipse-ecj
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package libgcj.ppc 0:4.1.2-8 set to be updated
Checking deps for libgcj.ppc 0-4.1.2-8 - u
---> Package java-1.5.0-gcj.ppc 0:1.5.0.0-14.fc7 set to be updated
Checking deps for java-1.5.0-gcj.ppc 0-1.5.0.0-14.fc7 - u
Importing additional filelist information
--> Processing Dependency: sinjdoc for package: java-1.5.0-gcj
--> Processing Dependency: /usr/bin/rebuild-security-providers for package:
java-1.5.0-gcj
--> Processing Dependency: jpackage-utils >= 1.7.3 for package: java-1.5.0-gcj
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package sinjdoc.ppc 0:0.5-4.fc7 set to be updated
Checking deps for sinjdoc.ppc 0-0.5-4.fc7 - u
---> Package jpackage-utils.noarch 0:1.7.3-1jpp.2.fc7 set to be updated
Checking deps for jpackage-utils.noarch 0-1.7.3-1jpp.2.fc7 - u
--> Processing Dependency: java_cup >= 0.10 for package: sinjdoc
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package java_cup.ppc 1:0.10-0.k.6jpp.1 set to be updated
Checking deps for java_cup.ppc 1-0.10-0.k.6jpp.1 - u
 
Dependencies Resolved
 
=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 eclipse-ecj             ppc        1:3.2.2-8.fc7    core              8.1 M
Installing for dependencies:
 java-1.5.0-gcj          ppc        1.5.0.0-14.fc7   core              104 k
 java_cup                ppc        1:0.10-0.k.6jpp.1  core              202 k
 jpackage-utils          noarch     1.7.3-1jpp.2.fc7  core               61 k
 libgcj                  ppc        4.1.2-8          core               20 M
 sinjdoc                 ppc        0.5-4.fc7        core              869 k
 
Transaction Summary
=============================================================================
Install      6 Package(s)
Update       0 Package(s)
Remove       0 Package(s)
 
Total download size: 29 M
Is this ok [y/N]: y
Downloading Packages:
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 172, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 301, in doTransaction
    problems = self.downloadPkgs(downloadpkgs)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 791, in downloadPkgs
    remote_pkgs.sort(mediasort)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 740, in mediasort
    a = a.getDiscNum()
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 484, in getDiscNum
    return int(fragid)
ValueError: invalid literal for int() with base 10: ''
[root@blade1 ~]#

Thanks Rene for retesting it. 
What drop of FC7 are you using?
I noted that the error stack lines don't match with the Fedora Cora 7 Test 4
source code. Could you retest using the last drop as well?

Thanks 


I'm using a to the http-server loop-mounted F-6.93-ppc-DVD.iso. It's date is
April, 30th. 

I've created a repository, which createrepo,  with a mounted iso and the
problem persists. 


I did a small patch that fix this problem.

Comment 1 IBM Bug Proxy 2007-05-28 20:20:48 UTC
Created attachment 155557 [details]
A patch that fixes the bug

Comment 2 IBM Bug Proxy 2007-05-29 13:13:01 UTC
Created attachment 155589 [details]
patch.diff

Comment 3 IBM Bug Proxy 2007-05-29 13:13:07 UTC
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #28092|0                           |1
        is obsolete|                            |




------- Additional Comments From brenohl@br.ibm.com  2007-05-29 09:09 EDT -------
 
A patch that fixes the bug

The same patch, just removing the ; in the end of the return statement. 

Comment 4 Ignacio Vazquez-Abrams 2007-06-03 07:06:27 UTC
*** Bug 241964 has been marked as a duplicate of this bug. ***

Comment 5 Ignacio Vazquez-Abrams 2007-06-03 07:06:49 UTC
*** Bug 242275 has been marked as a duplicate of this bug. ***

Comment 6 Ignacio Vazquez-Abrams 2007-06-03 07:28:32 UTC
Updating the version since it exhibits this behavior.

Comment 7 James Bowes 2007-06-03 11:19:46 UTC
Patch applied to yum CVS

Comment 8 Michał Bentkowski 2007-06-08 10:03:41 UTC
(In reply to comment #7)
> Patch applied to yum CVS

When will it be applied to yum available in F7?


Comment 9 Jeremy Katz 2007-06-13 18:35:59 UTC
We're hoping to do a yum 3.2.1 release soon and it'll then be available as an f7
update after a short while in f7-updates-testing.

Comment 10 Jeremy Katz 2007-06-13 18:36:06 UTC
*** Bug 242967 has been marked as a duplicate of this bug. ***

Comment 11 Jeremy Katz 2007-06-13 19:39:46 UTC
*** Bug 243203 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2007-06-21 22:03:56 UTC
yum-3.2.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Ignacio Vazquez-Abrams 2007-06-24 11:56:04 UTC
*** Bug 245496 has been marked as a duplicate of this bug. ***

Comment 14 Fedora Update System 2007-06-28 01:49:00 UTC
yum-3.2.1-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.