Bug 242280 - VNC won't serve WindowMaker as it did in FC6
VNC won't serve WindowMaker as it did in FC6
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 19:02 EDT by Ian Laurie
Modified: 2013-04-30 19:35 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.1.2-19.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 15:06:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of WindowMaker through VNC server. (84.94 KB, image/png)
2007-06-02 19:02 EDT, Ian Laurie
no flags Details

  None (edit)
Description Ian Laurie 2007-06-02 19:02:36 EDT
Description of problem:
VNC won't serve WindowMaker as it did with FC6.

Version-Release number of selected component (if applicable):
vnc-server-4.1.2-16.fc7
WindowMaker-0.92.0-12.fc7


How reproducible:
Always.

Steps to Reproduce:
1. Set up /etc/sysconfig/vncservers like this:

  VNCSERVERS="1:vnc"
  VNCSERVERARGS[1]="-geometry 1024x768 -depth 16"

2. Set up $HOME/.vnc/xstartup like this:

  [ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
  [ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
  #xsetroot -solid grey
  vncconfig -iconic &
  xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
  # twm &
  # mwm &
  wmaker &

3. Launch the VNC server.
4. Launch the VNC client to localhost:1
5. WindowMaker is unusable.
  
Actual results:
WindowMaker is unusable.  You cannot move windows due to corruption
within the windows.  Icons also get corrupted.

Expected results:
This worked well in FC6.  I always serve WindowMaker via VNC because
it uses up far less memory than GNOME and is a lot more usable than
say twm or mwm.  WindowMaker works fine when used as a login session
from gdm.


Additional info:
VNC doesn't work at all at color depth 24 (see bug# 242277).
See the attached file for an example of the screen corruption.
Comment 1 Ian Laurie 2007-06-02 19:02:36 EDT
Created attachment 156008 [details]
Screenshot of WindowMaker through VNC server.
Comment 2 Ian Laurie 2007-06-02 21:09:58 EDT
Because this is a show stopper for me, I have uninstalled vnc-server-4.1.2-16.fc7,
vnc-4.1.2-16.fc7 & vnc-libs-4.1.2-16.fc7 and installed vnc-4.1.2-3.fc6 & 
vnc-server-4.1.2-3.fc6 from the FC6 distribution.

Works perfectly as far as I can tell.  This downgrade also fixes VNC bug# 242277.

Using VNC from FC6 is an easy fix for others who find they have these problems.
Comment 3 Adam Tkac 2007-06-04 15:15:10 EDT
Screen corruption is due bad handling of Composite extension. You could try
"vncserver -depth :1 -extension Composite". Works fine for me. I'm going to
investigate where problem is and fix it

Regards, Adam
Comment 4 Adam Tkac 2007-06-07 11:13:20 EDT
I've found that problem is in main X source. I've filled bug #243142. If you run
Xvnc in 16bit mode and disable Composite extension (fc6 vnc doesn't support so
you don't have any problems with that version) all works nicely. (as I write
upper, try "vncserver :1 -extension Composite").

A
Comment 5 Ian Laurie 2007-06-08 04:48:11 EDT
Adam, I'll try vnc-4.1.2-17.1.fc8.src.rpm if you can fix the build errors for me.
At them moment I need VNC to work so I want to stick with the FC6 version.  If
you can post a fixed source rpm or post binaries Friday your time, I'll test 
over the weekend.
Comment 6 Ian Laurie 2007-06-08 07:18:09 EDT
vnc-4.1.2-17.1.fc7.i386.rpm downloaded from
http://koji.fedoraproject.org/koji/taskinfo?taskID=30866 with an
/etc/sysconfig/vncservers file of:

VNCSERVERS="1:vnc 2:vnc 3:vnc"
VNCSERVERARGS[1]="-geometry 1280x1024 -depth 24 -extension Composite"
VNCSERVERARGS[2]="-geometry 1280x960  -depth 24 -extension Composite"
VNCSERVERARGS[3]="-geometry 1024x768  -depth 24 -extension Composite"

seems to work with twm and WindowMaker.  GNOME apps run OK under either also.
Will continue to test.
Comment 7 Adam Tkac 2007-06-08 07:34:19 EDT
(In reply to comment #6)
> /etc/sysconfig/vncservers file of:
> 
> VNCSERVERS="1:vnc 2:vnc 3:vnc"
> VNCSERVERARGS[1]="-geometry 1280x1024 -depth 24 -extension Composite"
> VNCSERVERARGS[2]="-geometry 1280x960  -depth 24 -extension Composite"
> VNCSERVERARGS[3]="-geometry 1024x768  -depth 24 -extension Composite"
> 
> seems to work with twm and WindowMaker.  GNOME apps run OK under either also.
> Will continue to test.
> 
With 24bit depth you don't have to disable Composite extension. Only 16 bit
depth + Composite is buggy. (you could simple run -geometry 1280x1024 -depth 24
for example)

Adam
Comment 8 Ian Laurie 2007-06-08 07:54:11 EDT
Adam, confirmed, the new vnc-server-4.1.2-17.1.fc7.i386.rpm works at 24-bit
without the composite option.
Comment 9 Fedora Update System 2007-10-29 15:06:15 EDT
vnc-4.1.2-19.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.