Bug 242277 - VNC non functional with -depth 24
VNC non functional with -depth 24
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
:
: 245391 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 18:39 EDT by Ian Laurie
Modified: 2013-04-30 19:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.1.2-18.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 18:07:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Laurie 2007-06-02 18:39:16 EDT
Description of problem:
VNC non functional with -depth 24

Version-Release number of selected component (if applicable):
vnc-server-4.1.2-16.fc7

How reproducible:
Always

Steps to Reproduce:
1. Set /etc/sysconfig/vncservers to:

   VNCSERVERS="1:vnc"
   VNCSERVERARGS[1]="-geometry 1024x768 -depth 16"

2. Issue "service vncserver start" command.
3. After a few moments server is dead.
  
Actual results:
Server dies with the following in the VNC log file:

Xvnc Free Edition 4.1.2
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
Underlying X server release 10299902, The X.Org Foundation


Sun Jun  3 08:27:01 2007
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5901
 vncext:      Listening for HTTP connections on port 5801
 vncext:      created VNC server for screen 0
No matching visual for __GLcontextMode with visual class = 4 (32770), nplanes = 24
No matching visual for __GLcontextMode with visual class = 4 (32770), nplanes = 24
No matching visual for __GLcontextMode with visual class = 4 (32770), nplanes = 24
No matching visual for __GLcontextMode with visual class = 4 (32770), nplanes = 24
vncconfig: unable to open display ":1"
xterm Xt error: Can't open display: :1
twm:  unable to open display ":1"

Expected results:
Same configuration would work fine in FC6.

Additional info:
Comment 1 Ian Laurie 2007-06-03 00:26:32 EDT
There is a typo above in step 1, it should read "-geometry 1024x768 -depth 24".
"-depth 16" does work for twm (but not for WindowMaker, see bug# 242280).
Comment 2 Adam Tkac 2007-06-04 06:39:00 EDT
bug# 242280 looks like different issue (bad handling of RENDER extension looks
for me). You could try
http://people.redhat.com/atkac/test_srpms/vnc-4.1.2-18.fc7.src.rpm which has
24bit support and tell me your opinion.

Regards, Adam
Comment 3 Ian Laurie 2007-06-06 08:55:33 EDT
vnc-4.1.2-18.fc7 runs with "-depth 24" but there are other problems with this
version.  For example, you cannot run GNOME applications like gedit.

From xterm:

zaurak$ gedit
The program 'gedit' received an X Window System error.
This probably reflects a bug in the program.
The error was '163'.
  (Details: serial 372 error_code 163 request_code 150 minor_code 4)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
zaurak$ 

No GNOME application I have tried will run under WindowMaker or twm.
This worked fine in FC6, and works fine in Fedora 7 using VNC from FC6
(vnc-server-4.1.2-3.fc6 appears to work perfectly in F7).
Comment 4 Ian Laurie 2007-06-06 09:13:41 EDT
Another odd thing;  with vnc-4.1.2-18.fc7 in twm, when resizing or moving a
window, you don't get the wire-frame outline that is normal for twm.

I have moved back to vnc-server-4.1.2-3.fc6 and twm/WindowMaker work perfectly.
In twm, wire-frame when moving & resizing is back etc.

Can you not just re-release the FC6 version as an update to F7 ?  It seems to
just work.
Comment 5 Adam Tkac 2007-06-06 09:16:56 EDT
(In reply to comment #4)
Hm :) Much development have been done on Xvnc so better is find and fix bugs.

Adam

Comment 6 Adam Tkac 2007-06-07 11:41:49 EDT
I've done next version and 24bit depth works perfectly also with gnome
applications. Could you please test it? This could be final 24bit F7 version.
http://people.redhat.com/atkac/test_srpms/vnc-4.1.2-17.1.fc8.src.rpm

Thanks for your cooperation, Adam
Comment 7 Ian Laurie 2007-06-08 04:40:28 EDT
Adam - build errors (I have no idea how to fix them) as follows:

Patch #14 (vnc-s390.patch):
+ patch -p3 -b --suffix .s390 -s
1 out of 1 hunk FAILED -- saving rejects to file
hw/xfree86/os-support/linux/lnx_video.c.rej
1 out of 1 hunk FAILED -- saving rejects to file
hw/xfree86/os-support/misc/SlowBcopy.c.rej
error: Bad exit status from /var/tmp/rpm-tmp.91873 (%prep)
    .
  [snip]
    .
Bad exit status from /var/tmp/rpm-tmp.91873 (%prep)

Can you post binaries or fix the src rpm ?  I will be able to test over this
weekend if so.



Comment 8 Adam Tkac 2007-06-08 05:54:35 EDT
You could download your architecture from
http://koji.fedoraproject.org/koji/taskinfo?taskID=30862 .

Adam
Comment 9 Ian Laurie 2007-06-08 07:14:47 EDT
Adam, you src above was labeled "fc8" while the link in comment# 8 points to
"fc7" .  However I installed it and it seems to work OK.  My
/etc/sysconfig/vncservers file look like this:

VNCSERVERS="1:vnc 2:vnc 3:vnc"
VNCSERVERARGS[1]="-geometry 1280x1024 -depth 24 -extension Composite"
VNCSERVERARGS[2]="-geometry 1280x960  -depth 24 -extension Composite"
VNCSERVERARGS[3]="-geometry 1024x768  -depth 24 -extension Composite"

It seems to work OK so far with twm and WindowMaker (GNOME apps run OK too).
I will test further over the weekend.

Comment 10 Adam Tkac 2007-06-08 07:22:38 EDT
(In reply to comment #9)
> Adam, you src above was labeled "fc8" while the link in comment# 8 points to
> "fc7" .  However I installed it and it seems to work OK.

Currently fc7 & fc8 versions are same. Only problem was that someone made change
in main X source about two days ago and "s390" patch do something with changed
code so looks like you don't have latest xorg-x11-server-source package (>=
1.3.0.0-7 it's possible that update wasn't pushed yet) :)

A
Comment 11 Fedora Update System 2007-06-11 18:07:03 EDT
vnc-4.1.2-18.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Adam Tkac 2007-07-02 11:56:27 EDT
*** Bug 245391 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.