Bug 242336 - tkcvs yum update fails because of missing GPG signature
tkcvs yum update fails because of missing GPG signature
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tkcvs (Show other bugs)
7
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
: Reopened
: 242347 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-03 09:04 EDT by Raphael SALSON
Modified: 2013-01-09 23:20 EST (History)
3 users (show)

See Also:
Fixed In Version: tkcvs-8.0.4-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 02:51:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raphael SALSON 2007-06-03 09:04:40 EDT
Description of problem:


Version-Release number of selected component (if applicable):
tkcvs-8.0.4-2.fc7.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1.Context: Upgrade FC6 --> F7
2.yum update tkcvs (or graphical interface)
3.
  
Actual results:
Cannot upgrade:
> Package tkcvs-8.0.4-2.fc7.noarch.rpm is not signed


Expected results:


Additional info:
> yum --nogpgcheck update tkcvs 
works fine
Comment 1 Gérard Milmeister 2007-06-03 11:16:08 EDT
This is a known problem. It will take some time for the packages to be signed
and make through the mirrors again.
Comment 2 David Juran 2007-06-17 08:25:57 EDT
Reopening this bug since it's still not fixed. 
  Since this bug blocks yum from updating a system, with far-reaching
consequences for system security, I believe it can not wait for the next release
(Fedora 8?!?!?) Adjusting priority and severity accordingly.
Comment 3 Gérard Milmeister 2007-06-17 12:56:18 EDT
*** Bug 242347 has been marked as a duplicate of this bug. ***
Comment 4 Gérard Milmeister 2007-06-17 12:57:39 EDT
However, I don't think this is the right component for the problem.
The only thing I can do is to rebuild the packages.
Comment 5 David Juran 2007-06-19 08:42:46 EDT
Jesse, an rpm that got pushed without being signed, is that you area?
Comment 6 Jesse Keating 2007-06-19 09:08:59 EDT
A signed copy is now on the mirrors.
Comment 7 David Juran 2007-06-21 03:14:59 EDT
No, it's not )-:
And the Koji web interface is down.
Hmmm, maybe this issue ought to be transferred to component 'distribution'...
Comment 8 Jesse Keating 2007-06-21 10:18:44 EDT
Erm, Can you show me where on the master mirror this package is unsigned?  Are
you sure you don't have an out of date mirror?
Comment 9 Raphael SALSON 2007-06-23 20:00:24 EDT
hmmm, not too sure. How can I know which mirror was used when the update was run?

Here is my yum conf (standard I think):
[fedora]
name=Fedora $releasever - $basearch
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
file:///etc/pki/rpm-gpg/RPM-GPG-KEY

and: 
[updates]
name=Fedora $releasever - $basearch - Updates
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/$releasever/$basearch/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f$releasever&arch=$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora

Comment 10 Jesse Keating 2007-06-24 10:19:13 EDT
do a yum clean metadata; uncomment the baseurl in both fedora and updates,
comment out the mirrorlist, then do your update.  That should force it to pull
from the master mirrors.
Comment 11 David Juran 2007-06-27 02:51:37 EDT
Ahhh I see, I was looking for an updated package in the updates directory, not a
fixed package in the "base" directory. Are mirrors really synching the base
directory since it's presumably supposed to be immutable? E.g.
ftp://ftp.uci.edu/mirrors/fedora/linux/releases/7/Everything/i386/os/Fedora/tkcvs-8.0.4-2.fc7.noarch.rpm
is not...

Anyway, this problem with tkcvs is fixed, thanks for the help (-:
Comment 12 Jesse Keating 2007-06-27 08:42:47 EDT
I announced to our mirrors that I was updating the content.  Maybe some of them
didn't get the memo :/

Note You need to log in before you can comment on or make changes to this bug.