Bug 242350 - Nautilus crashes when application font size set to 7
Nautilus crashes when application font size set to 7
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Alexander Larsson
: Desktop
: 243943 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-03 11:41 EDT by Dawid Lorenz
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 22:08:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Nautilus debug output (1.44 KB, text/plain)
2007-06-03 11:41 EDT, Dawid Lorenz
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 454884 None None None Never

  None (edit)
Description Dawid Lorenz 2007-06-03 11:41:17 EDT
Description of problem:
When Application Font size is set to 7 (via ), Nautilus crashes. Chosen font is
DejaVu Sans Book, but crashes with any other.

Also, when font size is set to 7.3 and font is DejaVu Sans Book, visible font
size is still 8. It used to work properly in FC6. Work ok with different fonts.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Open System -> Preferences -> Look & feel -> Font
2. Select Application Font
3. Set font size to 7 and confirm
  
Actual results:
Nautilus crash.

Expected results:
Font size set properly.

Additional info:
After crash, I have found some debug output in my ~ (attached).
Comment 1 Dawid Lorenz 2007-06-03 11:41:17 EDT
Created attachment 156024 [details]
Nautilus debug output
Comment 2 Zoltán Magyar 2007-07-12 07:14:51 EDT
I could reproduce the bug using: Gnome 2.18.2, Nautilus 2.18.1-2.fc7 and Pango
1.16.4-1.fc7
I think the same bug is reported at gnome:
http://bugzilla.gnome.org/show_bug.cgi?id=454884
Comment 3 Zoltán Magyar 2007-07-12 07:27:06 EDT
*** Bug 243943 has been marked as a duplicate of this bug. ***
Comment 4 Alex Kloss 2007-07-17 20:00:24 EDT
Confirmed on Gnome 2.18.3, Nautilus 2.18.3-1.fc7

The error is being generated from eel's
eel_pango_font_description_get_largest_fitting_font_size function. The function
is passed a minimum font size and a maximum, but it will return an error if the
maximum is smaller than the minimum. Since the minimum font size appears to be
8, a size of 7 will cause the function to return an error. Then, when Nautilus
calls Pango to set the font size, it crashes, because Nautilus is passing Pango
an error value as the arguments.

The call to the function can be found at line 371 of
src/nautilus-sidebar-title.c, from Nautilus SVN.
Comment 5 Matthias Clasen 2007-10-02 22:08:51 EDT
Thanks for tracking this down.
Fixed in 2.20.0-3.fc8

Note You need to log in before you can comment on or make changes to this bug.