Bug 243943 - nautilus (various gnome apps) crashes when application font is too small
Summary: nautilus (various gnome apps) crashes when application font is too small
Status: CLOSED DUPLICATE of bug 242350
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus   
(Show other bugs)
Version: 7
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-12 21:17 UTC by Devrim GUNDUZ
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-12 11:26:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 242350 None None None Never

Description Devrim GUNDUZ 2007-06-12 21:17:07 UTC
Description of problem:
Hello,

I just found this problem: When I set application font (System->Look and
Feel->Fonts) to 7, many Gnome apps, including nautilus, crash.

Here is the error message:
----------- .xsession-errors ---------------------
(evolution:3237): e-data-server-ui-DEBUG: ep_msg_send: in main thread? 1
(evolution:3237): e-data-server-ui-DEBUG: ep_msg_send: in main thread? 0
(evolution:3237): e-data-server-ui-DEBUG: ep_msg_send: in main thread? 0
camel-Message: --
camel-Message: --
camel-Message: --
(nautilus:25604): Eel-CRITICAL **:
eel_pango_font_description_get_largest_fitting_font_size: assertion
`maximum_acceptable_font_size > minimum_acceptable_font_size' failed
(nautilus:25604): Pango-WARNING **: shape engine failure, expect ugly output.
the offending font is 'DejaVu LGC Sans Bold Not-Rotated 0'
seahorse nautilus module initialized
(nautilus:27851): Eel-CRITICAL **:
eel_pango_font_description_get_largest_fitting_font_size: assertion
`maximum_acceptable_font_size > minimum_acceptable_font_size' failed
(nautilus:27851): Pango-WARNING **: shape engine failure, expect ugly output.
the offending font is 'DejaVu LGC Sans Bold Not-Rotated 0'
============================================================================


Version-Release number of selected component (if applicable):

Fedora 7, up2date as of now.

How reproducible:

Always. 

Steps to Reproduce:
1. Click System -> Look and Feel -> Fonts
2. Set application font to sans,7px
3. Run nautilus
  
Actual results:

I see bug buddy instead of Nautilus ;)

Expected results:

Nautilus would run cleanly

Additional info:

Comment 1 sangu 2007-06-17 00:16:35 UTC
Duplicate  of bug 242350 ?

Comment 2 Zoltán Magyar 2007-07-12 11:26:57 UTC
I marked it as a duplicate.

*** This bug has been marked as a duplicate of 242350 ***


Note You need to log in before you can comment on or make changes to this bug.