Bug 242369 - anaconda freeze at checking for dependancie
anaconda freeze at checking for dependancie
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 247721 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-03 15:24 EDT by dominique
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.22.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 15:57:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dsdt.hex with-out errors (202.62 KB, application/octet-stream)
2007-06-16 15:20 EDT, dominique
no flags Details

  None (edit)
Description dominique 2007-06-03 15:24:01 EDT
Description of problem:when I install F7, anaconda freeze at checking for
dependencies...
I try also in text mode and anaconda freeze at 49% checking for dependencies
the DVD is OK


Version-Release number of selected component (if applicable):
F7 

How reproducible:
I try whith 3 DVD and the result is the same

Steps to Reproduce:
1.
2.
3.
  
Actual results:
anaconda freeze

Expected results:
F7 insatlled

Additional info:my laptop is an ACER1682WLMI intel pentium M 725, ATI MOBILITY
RADEON 9700, HDD:Hitahi 100GB-7200tr/mn, 1024MB DDR
I was not problems when I have installed FC5 and FC6

Excuse my english 
A friendly french man
Comment 1 Chris Lumens 2007-06-04 10:55:43 EDT
When it freezes, do you see anything on tty3 or tty4 that could indicate a failure?
Comment 2 dominique 2007-06-05 00:54:59 EDT
when anaconda freeze I can't do nothing.
My loptop is freeze and I shut-down and re-start it
Comment 3 Dave Jones 2007-06-05 17:29:52 EDT
can you try booting with nohz=off ? and see if that helps.
clocksource=acpi_pm may also be interesting.
Comment 4 dominique 2007-06-06 00:30:04 EDT
thank for your help
I try those two options but the results are the same:
my laptop freeze at checking for depedencies...
I dont konw why... 
I have installed FC5 and FC6 without problems...
May be the future F8 resolv that...

Comment 5 dominique 2007-06-07 01:19:53 EDT
Yeepeee!!!
I am under F7!!!!
I adds just "linux acpi=off" at the begin of installation...
thank for your help
Comment 6 Tim Püschel 2007-06-16 08:08:42 EDT
I had the same problem and installed with acpi=off.

Further investigation showed that as long as I boot with "acpi=off" there are no
problems.

If I boot without "acpi=off" the system freezes if there is high cpu utilization
for a while (usually a few minutes). If I try to reboot again directly the
kernel panics during boot. If I wait a while to let the system cool down a bit
it boots and works without problems as long as I don't let it run at full
frequency and full cpu utilization for to long. 

The problem exists with both kernel-2.6.21-1.3194.fc7 and
kernel-2.6.21-1.3228.fc7. I've had no such problems with Fedora Core 6 or earlier.

My system is
http://smolt.fedoraproject.org/show?UUID=981a80fe-5c66-4a9d-ab93-89a7e405de7f
Comment 7 Tim Püschel 2007-06-16 08:50:59 EDT
When booting with a "hot" system and without "acpi=off" either the following
message 
"BUG: scheduling while atomic: kacpid/0x000000d8/47" 
or a large screen with errors, call traces, etc appears.
Among others it contains the following lines (stuff left out wherever there's ...):
...
Process kacpid (pid:47, ti=f7c5400, task=f7c7b290 task.fi=f7c55000)
Stack: ...
Call Trace:
...
BUG: unable to handle kernel NULL pointer derefence at virtual address 00000007
...
Kernel panic - not syncing: Fatal exception in interrupt
Comment 8 dominique 2007-06-16 15:20:15 EDT
Created attachment 157201 [details]
dsdt.hex with-out errors
Comment 9 dominique 2007-06-16 15:31:35 EDT
I have the same problems...when I am with acpi=on my laptop freeze when the
cpu-temp is 65°... I think it is a problem with dsdt table... I have compiled a
new dsdt table without errors but I don't know how to integrate this file in a
new kernel
Comment 10 dominique 2007-06-19 13:39:26 EDT
Ihave a temporary solution... (thank' google...)

when I do:
[root@88-138-11-104 ~]# cat /proc/acpi/thermal_zone/THRM/trip_points
 I have:
critical (S5):           100 C
passive:                 92 C: tc1=2 tc2=3 tsp=100 devices=0xc18eb57c
active[0]:               73 C: devices=0xf7d04590
active[1]:               66 C: devices=0xf7d04680

then I do:
echo 100:0:92:73:73 > /proc/acpi/thermal_zone/THRM/trip_points

and I have:
critical (S5):           100 C
passive:                 92 C: tc1=2 tc2=3 tsp=100 devices=0xc18eb57c
active[0]:               73 C: devices=0xf7d04590
active[1]:               73 C: devices=0xf7d04680

and now no freeze (my cpu-temp up to 71° but no more)

I can do this code every time I start my laptop  (I think it is possible to
automated this solution for starting computer)

Excuse my english...
chepioq

Comment 11 Wilfried Philips 2007-07-11 08:43:13 EDT
The problem may be related to this bug:
http://bugzilla.kernel.org/show_bug.cgi?id=8385
Comment 12 Wilfried Philips 2007-07-11 08:46:05 EDT
*** Bug 247721 has been marked as a duplicate of this bug. ***
Comment 13 dominique 2007-07-15 14:57:53 EDT
I have tested the kernel vanilla 2.6.22.1
and they are not acpi's bug with him
When for F7?
Comment 14 Wilfried Philips 2007-07-16 20:14:55 EDT
I can confirm that this acpi bug is gone in 2.6.22.1
Comment 15 Christopher Brown 2007-09-13 15:57:56 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

This bug appears resolved so I am closing it. If I have erred please forgive me,
re-open the bug and I will attempt to assist you in its resolution.

Cheers
Chris

Note You need to log in before you can comment on or make changes to this bug.