Bug 242393 - Comments on /etc/modprobe.conf make anaconda bootloader installation fail
Summary: Comments on /etc/modprobe.conf make anaconda bootloader installation fail
Status: CLOSED DUPLICATE of bug 241991
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-03 23:41 UTC by Andre Costa
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 14:00:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andre Costa 2007-06-03 23:41:24 UTC
Description of problem:
During FC6->F7 upgrade, anaconda bootloader installation failed with "array
index out of bounds" (can't recall the exact error message) on line #78 of
/usr/lib/anaconda/iw/upgrade_bootloader_gui.py. Stacktrace suggested that
comments on /etc/modprobe.conf were the cause.


Version-Release number of selected component (if applicable): don't know


How reproducible: only tried it once


Steps to Reproduce:
1. start upgrade process
2. choose language and keyboard
3. choose 'upgrade' instead of 'install'
  
Actual results:
Dialog with error message and stacktrace.

Expected results:
Successful bootloader installation.

Additional info:
Booting back to FC6 and removing all comments from /etc/modprobe.conf allowed F7
upgrade to proceeed.

Comment 1 Chris Lumens 2007-06-04 14:00:31 UTC

*** This bug has been marked as a duplicate of 241991 ***


Note You need to log in before you can comment on or make changes to this bug.