Bug 242399 - [FAQ] Information in "man mount" is incomplete
Summary: [FAQ] Information in "man mount" is incomplete
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux-ng (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: 435246
TreeView+ depends on / blocked
 
Reported: 2007-06-04 01:39 UTC by Răzvan Sandu
Modified: 2008-03-13 10:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 10:15:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Răzvan Sandu 2007-06-04 01:39:55 UTC
Description of problem:

Hello,

Since passing to the new method of having a dynamic /dev (udev), information in
"man mount" is incomplete.

Describing a mounting process simply as:

mount -t type device dir

is not satisfactory, since one cannot know in advance the "device" denomination.

For quick reference, "man mount" should describe the canonical way of mounting a
drive in command-line mode, including a method of quickly discovering the
"device" name.

Regards,
Răzvan


Version-Release number of selected component (if applicable):
util-linux-2.13-0.51.fc7

How reproducible:
Always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
"man mount" doesn't include  all information which is necessary to mount a drive
in text mode.


Expected results:
"man mount" should describe the canonical way of mounting a drive in
command-line mode, including a method of quickly discovering the "device" name.


Additional info:

Comment 1 Karel Zak 2007-09-20 22:13:31 UTC
Use LABELS or UUIDs. Also.. there are /dev/disk/by-* symlinks.

Comment 2 Răzvan Sandu 2007-10-08 07:10:39 UTC
Sorry, but I won't conside this "fixed" until someone doesn't point to some more
extensive documentation/procedure.

"mount -t type device dir" used to be a *simple* task. Now, without a quick
reference in the man page, viewing a CD or a floppy in text mode requires a
degree in Computer Science... ?  ;-)

Regards,
Răzvan


Comment 3 Karel Zak 2008-01-23 13:05:06 UTC
Well, I'll add some note about blkid(8), vol_id(8) and /dev/disk/by-* to the
mount man page.

Comment 4 Răzvan Sandu 2008-02-28 07:43:31 UTC
Hello,

Could you please point me to a step-by-step procedure for mounting a CD/DVD ?

Imagine the following situation:

1. I connect to some machine remotely.
2. I know *nothing* about the remote hardware (names of drives, labels, etc.)
3. I have a disk in the remote DVD drive.
4. I want to mount the disk via ssh and copy its content on the HDD.

How do I do ? Pliiiiiiiz... It used to be *simple*: mount device dir.

Now ?
We (users) simply don't want (or have time) to read details about the filesystem
structure and philosophy just to mount a disk...

Thank you,
Răzvan

Comment 5 Karel Zak 2008-03-13 10:15:13 UTC
mount /dev/cdrom /mointpoint


Note You need to log in before you can comment on or make changes to this bug.