Bug 242519 - ThunderBird exits/crashes with profiles
ThunderBird exits/crashes with profiles
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
TB12ReproductionRequest
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-04 13:26 EDT by Doncho N. Gunchev
Modified: 2008-10-30 17:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.0.0.17.
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 17:55:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doncho N. Gunchev 2007-06-04 13:26:43 EDT
Description of problem:
ThunderBird just exits or crashes when working with more than one profile.
Profile manager can not be started.

Version-Release number of selected component (if applicable):
thunderbird-2.0.0.0-1.fc7

How reproducible:
always

Steps to Reproduce:
1. thunderbird -ProfileManager
  just exits
2. thunderbird
  just exits if > 1 profiles are present
3. thunderbird
  exits with 'Segmentation fault' if only one profile is present. I created a
new one (mv ~/.thunderbird ~/.thunderbird_save). When starting for the first
time there are no google, newsgroups... choices.

Expected results:
Should work no worser than the upstream version (tar.gz from mozilla.com).

Additional info:
Upstream works just fine and is 11MB (tar.gz, 32MB installed), FC7's is
23MB(rpm, 43MB installed) and ... :-(
package-cleanup --problems shows 'No problems found'.
Another related problem is maybe bug # 242432
I tried
sh -x /usr/bin/thunderbird
... export the same variables and so on ...
strace /usr/lib/thunderbird-2.0.0.0/thunderbird-bin -ProfileManager
...
open("/usr/lib/thunderbird-2.0.0.0/components/xpti.dat.tmp",
O_WRONLY|O_CREAT|O_TRUNC|O_LARGEFILE, 0666) = -1 EACCES (Permission denied)
...
which is quite strange, no program (I'm running as normal user, but root's not
exception) should try to write in /usr/lib/whatever AFAIK.
Comment 1 Doncho N. Gunchev 2007-06-04 13:27:53 EDT
Forgot to mention thar in 3. it works fine, when you close it (normal program
exit) it segfaults.
Comment 2 Doncho N. Gunchev 2007-06-15 03:33:26 EDT
thunderbird-2.0.0.4-0.rc1.fc7 still has the same problems.
Comment 3 Nico Timeo 2007-07-25 04:17:30 EDT
I'm having the same problem... using Fedora 7 and Thunderbird 2.0.0.5.
Comment 4 Nico Timeo 2007-08-02 09:34:21 EDT
Still no solution... I must use only one profile with Thunderbird on Fedora! :-(
Comment 5 Christopher Aillon 2007-08-07 12:56:05 EDT
As a note, multiple profiles is sort of unsupported upstream.  There's some
lingering code there which is intended to go away.  The preferred solution is to
have a different user.  With fast user switching, this should be made easier.
Comment 6 Christopher Aillon 2007-08-07 13:13:46 EDT
Though I wonder if this is a side effect of bug 244901.
Comment 7 Ola Thoresen 2007-08-22 13:53:20 EDT
I do not think it is related to #244501 - although that bug made Thunderbird not
start at all.
I can start Thunderbird with multiple profiles if I select the profile from
commandline:

thunderbird -p default
thunderbird -p work

This seems to work (after rpm -e thunderbird and rm -Rf
/usr/lib/thunderbird-2.0.0.* and yum install thunderbird again)

Comment 8 Pere Pie 2007-11-18 18:18:57 EST
Using Fedora 8 and Thunderbird 2.0.0.9 (20071115).

Having the same problem, 

1.- 
$ thunderbird -ProfileManager

do not run nothing

2.- Runing thunderbird with a profiles.ini with more than one profile 
$ thunderbird

seems to run but closes.

3.- Specifing a profile of a profiles.ini with more than one profile
$ thunderbird -P profile01

workd fine


Comment 9 Matěj Cepl 2008-03-07 17:42:45 EST
At this point, we're going to only be taking security fixes and major stability
fixes into this release of Fedora.  However, we still want to ensure the bug is
fixed in the next version.  We'd appreciate if you could test with the latest
version of Thunderbird (2.0.0.12) now available for your distribution and
provide feedback as to whether the problem still exists so we can file a ticket
upstream as soon as possible.
Comment 10 Doncho N. Gunchev 2008-03-07 19:25:50 EST
thunderbird-2.0.0.12-1.fc8 -ProfileManager results in a very fast exit. The last
part of the messages from strace looks just the same (components/xpti.dat.tmp)...
The options --sync --no-xshm -safe-mode have no effect.

The thunderbird binary (2.0.0.12) from mozilla.com works just fine on the same
machine/session. I used that to create some profiles. When the checkbox to not
ask about profile on startup is checked fedora's tb starts the last selected
profile, but if it is not checked exits as fast as with -ProfileManager.

Should we update the version to 8?
Comment 11 Doncho N. Gunchev 2008-03-07 19:27:28 EST
The "I am providing the requested information for this bug." checkbox did not
work, retrying.
Comment 12 Bug Zapper 2008-05-14 08:47:36 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Doncho N. Gunchev 2008-05-30 14:46:19 EDT
Just tried with FC8 - the same problem.
Comment 14 Doncho N. Gunchev 2008-10-28 18:01:26 EDT
Can reproduce with thunderbird-2.0.0.16-1.fc9.x86_64
Comment 15 Matěj Cepl 2008-10-28 18:26:31 EDT
Cannot reproduce with thunderbird-2.0.0.17-1.fc10.i386 -- it just works as it should.
Comment 16 Doncho N. Gunchev 2008-10-30 16:51:27 EDT
Yep, it's OK with 2.0.0.17.

Note You need to log in before you can comment on or make changes to this bug.