Bug 242538 - knetworkmanager: fails to start reliably
knetworkmanager: fails to start reliably
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: knetworkmanager (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-04 14:32 EDT by Niko Mirthes
Modified: 2007-11-30 17:12 EST (History)
7 users (show)

See Also:
Fixed In Version: 0.2-0.1.svn20070815.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 12:43:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niko Mirthes 2007-06-04 14:32:24 EDT
Description of problem:
knetworkmanager does not place a .desktop file in $KDEDIRS/share/autostart 
causing it to not always appear in the systray applet on login. 
knetworkmanager's .desktop is in $KDEDIRS/share/autostart while running the F7 
livecd and it has the required entries for KDE to autostart it.

Version-Release number of selected component (if applicable):
knetworkmanager-0.1-0.9.svn20070409.fc7 (I chose kdenetwork as the component 
because knetworkmanager is not yet in the list.)

How reproducible:
With a fresh user created, knetworkmanager does appear to start. Upon 
restoring my existing /home partition and user, knetworkmanager fails to 
start.

Steps to Reproduce:
1. Login, knetworkmanager icon is not present in the systray.
2. Find it on the menu and start it. Icon appears in the systray, 
configuration set to start at login.
3.Re-login and note the absence of knetworkmanager's icon in the systray.
  
Actual results:
knetworkmanager refuses to start with KDE even after checking the associated 
checkbox in the app's configuration tool.

Expected results:
knetworkmanager should start at login if configured to do so.

Additional info:
I've noticed kpowersave (also start-able at login) does place a .desktop file 
in $KDEDIRS/share/autostart.

Simply copying

/usr/share/applications/fedora-knetworkmanager.desktop

to

/usr/share/autostart/knetworkmanager-autostart.desktop

works for me.

I've also been told Novell/SuSE 
include /usr/share/autostart/knetworkmanager-autostart.desktop in their 
packages.
Comment 1 Doncho N. Gunchev 2007-06-09 13:59:22 EDT
Kerry Beagle does not start too.
Comment 2 Rex Dieter 2007-06-19 16:19:44 EDT
may be related to bug #243611

Doncho, probably worth filing a separate bug against kerry.
Comment 3 Matthew Truch 2007-07-04 16:28:48 EDT
I'd like to confirm that this bug (knetworkmanager not starting with your
session) is affecting me as well.  Fedora 7,
knetworkmanager-0.1-0.9.svn20070409.fc7.  
Comment 4 Rex Dieter 2007-08-28 16:26:05 EDT
Tried out the knetworkmanger-0.2 koji build, and it actually started with my kde
session!  Looks like we have a winner.
Comment 5 Fedora Update System 2007-08-29 13:25:30 EDT
knetworkmanager-0.2-0.1.svn20070815.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Roland Wolters 2007-08-29 15:16:03 EDT
You might want to add "OnlyShowIn=KDE;" to the desktop file 
in /usr/share/autostart since Gnome has its own panel.
Comment 7 Fedora Update System 2007-09-12 12:43:29 EDT
knetworkmanager-0.2-0.1.svn20070815.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.