This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 243611 - kdelibs: /etc/xdg/autostart doesn't
kdelibs: /etc/xdg/autostart doesn't
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
: Reopened
: 238507 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-10 14:45 EDT by Mark
Modified: 2014-01-21 17:58 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 08:41:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2007-06-10 14:45:03 EDT
Description of problem:
When you install the Fedora 7 KDE Live CD puplet isn't started.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.install fedora 7 KDE (probably gnome as well) Live CD
2.Wait for updates to popup.. they won`t come.
3.
  
Actual results:
The update notification won`t show up.

Expected results:
The update notification won`t show up.

Additional info:
i created a how to for this problem to fix it.
you can find it here: http://forums.fedoraforum.org/showthread.php?p=808059
Comment 1 Jeremy Katz 2007-06-11 11:31:58 EDT

*** This bug has been marked as a duplicate of 212934 ***
Comment 2 Mark 2007-06-11 16:11:03 EDT
This is not a duplicate of that other bug!!
that other bug is the puplet icon that`s not being shown. that not the problem
here. in this case the puplet service itself isn't started (i need to start it
manually with /etc/init.d/puplet start)

the fix for this bug is:
ln -s /usr/bin/puplet ~/.kde/Autostart/puplet
and:
yum -y install puplet :P (yes that`s right.. it wasn`t installed for me with the
default livecd installation)

So not a duplicate of tat bug.
re-opened bug.
Comment 3 Sebastian Vahl 2007-06-13 15:42:13 EDT
Just to make this clear: "puplet" is part of the package "pirut" and is not 
existing as an own package. The name of the service 
is /etc/init.d/yum-updatesd. yum-updatesd is disabled on the livecds (both, 
gnome and kde), but running normally after an installation. Also the 
package "pirut" is included in the livecd.
This bug is also present after a dvd installation of fedora with KDE. So it's 
not livecd only.

But we will have a look into this. I leave this bug assigned to me for now.
Comment 4 Sebastian Vahl 2007-06-13 17:24:45 EDT
Well, is KDE 3.5. already using XDG_CONFIG_DIRS or /etc/xdg/autostart? The 
only thing I could find so far is this (one year old ) discussion about 
implementing it: http://marc.info/?l=freedesktop-xdg&m=117278186111444&w=2
eg. http://lists.kde.org/?l=kde-core-devel&m=114296588628282&w=2

Also the current autostart specification from fd.o says: 
"Example: If $XDG_CONFIG_DIRS is not set the system wide Autostart Directory 
is /etc/xdg/autostart/"
http://standards.freedesktop.org/autostart-spec/autostart-spec-0.5.html

But when I remove XDG_CONFIG_DIRS from /etc/kde/env/env.sh /etc/xdg/autostart 
is still not used.
Comment 5 Mark 2007-06-14 18:50:46 EDT
What i needed to do is run puplet. (by typing puplet in the console)
also i have 4 entries in /etc/xdg/autostart and none of them are started by
default (like you said).

If there is anything you want me to test for you on kde?
just give me a sign and i will test it for you.
Comment 6 Sebastian Vahl 2007-06-19 12:17:21 EDT
As discussed in kde-sig-meeting (2007-06-19) I reassign it against kdelibs.
Comment 7 Rex Dieter 2007-06-26 12:18:30 EDT
*** Bug 238507 has been marked as a duplicate of this bug. ***
Comment 8 Ngo Than 2007-09-25 08:41:39 EDT
it's fixed in kdelibs-3_5_7-23_fc8

Note You need to log in before you can comment on or make changes to this bug.