Bug 24256 - /etc/skel/.bash_profile sets empty $USERNAME
Summary: /etc/skel/.bash_profile sets empty $USERNAME
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: setup   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
: 24257 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-18 00:01 UTC by John Hardin
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 15:29:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Hardin 2001-01-18 00:01:53 UTC
The default .bash_profile in /etc/skel sets $USERNAME to "".

It should either set it to $USER, or `id -un` (ala /etc/profile) or leave
it undefined. Setting it explicitly to empty makes no sense.

This problem also exists in 7.0

Comment 1 Trond Eivind Glomsrxd 2001-01-18 01:43:04 UTC
*** Bug 24257 has been marked as a duplicate of this bug. ***

Comment 2 Trond Eivind Glomsrxd 2001-01-18 01:51:56 UTC
This is now part of bash...

Comment 3 Florian La Roche 2001-02-07 15:29:04 UTC
I have changed /etc/skel/.bash_profile to "unset USERNAME"

We should at some point investigate why /root/.bash_profile
sets USERNAME="root" or just through that away.






Comment 4 Bernhard Rosenkraenzer 2001-05-21 20:07:34 UTC
USERNAME isn't set at all in the current setup.



Note You need to log in before you can comment on or make changes to this bug.