Bug 24257 - /etc/skel/.bash_profile sets empty $USERNAME
/etc/skel/.bash_profile sets empty $USERNAME
Status: CLOSED DUPLICATE of bug 24256
Product: Red Hat Linux
Classification: Retired
Component: etcskel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-17 19:03 EST by John Hardin
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-17 19:03:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Hardin 2001-01-17 19:03:53 EST
The default .bash_profile in /etc/skel sets $USERNAME to "".

It should either set it to $USER, or `id -un` (ala /etc/profile) or leave
it undefined. Setting it explicitly to empty makes no sense.

This problem also exists in 7.0
Comment 1 Trond Eivind Glomsrxd 2001-01-17 20:43:07 EST

*** This bug has been marked as a duplicate of 24256 ***

Note You need to log in before you can comment on or make changes to this bug.