Bug 242583 - Link curses module with ncursesw.so
Link curses module with ncursesw.so
Status: CLOSED DUPLICATE of bug 246385
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: James Antill
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-04 18:04 EDT by Guillaume Chazarain
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-16 20:55:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Untested, suggested fix (831 bytes, patch)
2007-06-04 18:04 EDT, Guillaume Chazarain
no flags Details | Diff

  None (edit)
Description Guillaume Chazarain 2007-06-04 18:04:53 EDT
Description of problem:

The curses module in Python-2.5 handles UTF-8 more gracefully if linked with
ncursesw. For more information, see:

http://mail.python.org/pipermail/patches/2006-February/018840.html
http://mail.python.org/pipermail/python-list/2006-February/366356.html

Version-Release number of selected component (if applicable):
Python-2.5
Comment 1 Guillaume Chazarain 2007-06-04 18:04:53 EDT
Created attachment 156142 [details]
Untested, suggested fix
Comment 2 Iñigo Serna 2007-08-16 16:01:05 EDT
Hi all,

I've reported this same issue this morning in #fedora-python and they told me to
open a wishlist bug report, but as I can see, I'm not the only one here.

This is also related to bug #250782.

Please, fix this before F8, as it's quite easy.

Thanks,
Iñigo Serna
Comment 3 Jeremy Katz 2007-08-16 20:55:46 EDT

*** This bug has been marked as a duplicate of 246385 ***

Note You need to log in before you can comment on or make changes to this bug.