Bug 246385 - UTF-8 with ncurses
Summary: UTF-8 with ncurses
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i386 Linux
low
urgent
Target Milestone: ---
Assignee: James Antill
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 242583 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-01 16:36 UTC by Granville Xiong
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-06 20:32:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Granville Xiong 2007-07-01 16:36:28 UTC
Description of problem:

It seems that the Python 2.5 in F7 is linked with ncurses so that the display of
UTF-8 characters seems messed up.

Version-Release number of selected component (if applicable):

2.5-12.fc7

How reproducible:

Always

Steps to Reproduce:
1. Try this small code:

#! /usr/bin/env python
# -*- coding: utf-8 -*-
import curses, locale
s = curses.initscr()
s.addstr(u'\u20ac U+20ac Euro Dollar\n'.encode('utf-8'))
s.refresh()
s.getstr()
curses.endwin()

2.
3.
  
Actual results:


Expected results:


Additional info:

How about link python to ncursesw library contained in
ncurses-5.6-6.20070303.fc7 to solve this UTF-8 problem?

Comment 1 Jeremy Katz 2007-07-06 20:32:24 UTC
Sounds good; fixed in CVS.  Assuming it plays out okay in rawhide, will get
pushed to F7-updates at some point

Comment 2 Granville Xiong 2007-07-08 02:07:52 UTC
Wonderful! This is very nice! Thank you!
P.S. Where can I download the updated version to try it out first? Thanks!

Comment 3 Jeremy Katz 2007-08-17 00:55:50 UTC
*** Bug 242583 has been marked as a duplicate of this bug. ***

Comment 4 Jeremy Katz 2007-08-24 13:54:26 UTC
*** Bug 250782 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.