Bug 242604 - Network Installation FC6 to F7 causes anaconda to crash.
Network Installation FC6 to F7 causes anaconda to crash.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
: 247959 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-04 20:48 EDT by John E. Harbold
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.2.2-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 15:48:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Crash Dump (85.51 KB, text/plain)
2007-06-27 22:32 EDT, John E. Harbold
no flags Details
Anaconda Crash Dump (84.74 KB, patch)
2007-06-29 09:52 EDT, John E. Harbold
no flags Details | Diff
Anaconda Crash Dump (86.09 KB, patch)
2007-06-30 11:46 EDT, John E. Harbold
no flags Details | Diff
Anaconda Crash Dump (85.61 KB, patch)
2007-07-02 01:50 EDT, John E. Harbold
no flags Details | Diff

  None (edit)
Description John E. Harbold 2007-06-04 20:48:41 EDT
Attempting a network upgrade results in anaconda crashing.  In all attempts the
anaconda crash log shows:

Description of problem:/usr/bin/update-gdk-pixbuf-loaders: line 27:
/etc/gtk-2.0/i386-redhat-linux-gnu/gdk-pixbuf.loaders: No such file or directory
error: %postun(librsvg2-2.14.4-1.fc5.1.i386) scriptlet failed, exit status 1

I removed librsvg2-2.14.4-1.fc5.1.i386 using "rpm -e", but subsequent upgrades
resulted in the same error.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Boot vmlinuz/initrd for Fedora 7 installation.
2. Select FTP installation.
3. Choose mirrors.kernel.org with /fedora/releases/7/Fedora/i386/os.
4. Select upgrade.
  
Actual results:

After search the current installation, anaconda crashes.

Expected results:

Network installation should continue.


Additional info:
Comment 1 John E. Harbold 2007-06-06 17:26:56 EDT
I'm having trouble creating an attachment.  This attachment is the anaconda
crash dump.  Anybody, any ideas?
Comment 2 David Cantrell 2007-06-07 14:00:33 EDT
http://fedoraproject.org/wiki/AnacondaBugReporting
Comment 3 John E. Harbold 2007-06-27 22:32:37 EDT
Created attachment 158090 [details]
Anaconda Crash Dump

This will be my second attempt at creating an attachment of the ANACDUMP.TXT
file. If I can't do, will someone clue me in another way I can get this
information to Bugzilla?
Comment 4 John E. Harbold 2007-06-27 22:43:06 EDT
I forgot to check the "I am providing the requested information for this bug." 
box below!
Comment 5 Jeremy Katz 2007-06-28 10:56:35 EDT
Where's the gnotepad+ package from?  It's tripping things up, so if I can find a
copy of the package, I can probably figure out a real fix.  Workaround would be
to temporarily remove the package.
Comment 6 John E. Harbold 2007-06-29 09:52:17 EDT
Created attachment 158206 [details]
Anaconda Crash Dump

I used yum to remove gnotepad+-1.3.1-3.i386 and attempted to upgrade using FTP
again and anaconda crashed, again.  Peruse the attached anaconda crash dump,
another install package is the problem.
Comment 7 John E. Harbold 2007-06-30 11:46:11 EDT
Created attachment 158293 [details]
Anaconda Crash Dump

I did it again!  I removed aout and helpdoc and tried again and still failed. 
Look at the crash dump.  Something funny is going on here.
Comment 8 John E. Harbold 2007-07-02 01:50:04 EDT
Created attachment 158320 [details]
Anaconda Crash Dump

It appears that old RPM packages from previous upgrades are still laying about.
 Shouldn't anaconda be able to handle these files?  Over several upgrade
attempt, I've removed the RPM package specified in the "po:" field of the
Anaconda Crash Dump file.  Also, I've run "rpm --rebuilddb".   Is there a way
of removing these old RPM packages?
Comment 9 John E. Harbold 2007-07-03 02:23:03 EDT
I finally was able to get past the Anaconda Crash.  After several cycles of 
attempting to do a network upgrade and removing the offending RPM package, I 
was to start the upgrade process.  My only problem is I need to free up 477 MB 
of disk space in my /usr partition.

This Bugzilla bug reminds me of a 50's "B" sci-fi film by Roger Corman, "The 
Attack of the RPM Zombies from Fedora Core".
Comment 10 John E. Harbold 2007-07-03 22:00:54 EDT
It is done!  I have successfully upgraded from Fedora Core 6 to Fedora 7.  
This bug should be renamed to the "The Attack of the RPM Zombies from Fedora 
Core" because if there are any RPM zombies on your system earlier than the 
version that is going to be upgraded, you are Sierra Oscar Lima!  There must 
be a way to determine the RPM zombies on your system.

Mr. Katz, this bug should have it's status change.  To what, that will be up 
to you.
Comment 11 Jeremy Katz 2007-07-06 15:34:14 EDT
Okay, I see what was going on and have fixed it up in yum CVS.  Thanks for the
report and debugging!
Comment 12 Jeremy Katz 2007-07-16 16:34:44 EDT
*** Bug 247959 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2007-07-23 11:46:20 EDT
yum-3.2.2-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Martin Smith 2007-07-29 04:28:25 EDT
As I noted in 247959 I am still having this problem despite the workaround that
was suggested in that bug report. 

The machine in question is a server and I have to take it down and physically
move it to attempt the upgrade then put it it back when it blows up.

Please advise on what I can try next. Does the new version of yum help me? If so
how do I get the installation to make use of it?

Comment 15 John E. Harbold 2007-08-06 00:31:21 EDT
My suggestion is to remove the offending RPM package and retry the upgrade.  
This is what I did and it took several tries until anaconda was able to 
continue.  Now, for my question, are you installing or upgrading.  My problem 
occurred because I only upgraded continually from RedHat 5.0.  What I can 
surmise is that the RPM packages that weren't replaced became, what I 
euphemistically call "RPM Zombies".  This zombies will accumulate as you 
upgrade from version to version.  Mr. Katz, I believe, is trying to solve this 
problem.

All I can say is to look at the attached "Anaconda Crash Dumps" for this bug 
and keep on trying, you are bound to eventually remove all the offending "RPM 
Zombies".
Comment 16 John E. Harbold 2007-08-07 09:41:33 EDT
My suggestion is to remove the offending RPM package and retry the upgrade.  
This is what I did and it took several tries until anaconda was able to 
continue.  Now, for my question, are you installing or upgrading.  My problem 
occurred because I only upgraded continually from RedHat 5.0.  What I can 
surmise is that the RPM packages that weren't replaced became, what I 
euphemistically call "RPM Zombies".  This zombies will accumulate as you 
upgrade from version to version.  Mr. Katz, I believe, is trying to solve this 
problem.

All I can say is to look at the attached "Anaconda Crash Dumps" for this bug 
and keep on trying, you are bound to eventually remove all the offending "RPM 
Zombies".
Comment 17 Fedora Update System 2007-08-15 15:47:32 EDT
yum-3.2.2-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.