Bug 247959 - F7 upgrade fails: %postun(librsvg2-2.14.4-1.fc5.1.i386) scriptlet failed, exit status 1
Summary: F7 upgrade fails: %postun(librsvg2-2.14.4-1.fc5.1.i386) scriptlet failed, exi...
Status: CLOSED DUPLICATE of bug 242604
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-12 09:09 UTC by Martin Smith
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 20:34:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Exception log produced by anaconda (130.38 KB, text/plain)
2007-07-12 09:09 UTC, Martin Smith
no flags Details

Description Martin Smith 2007-07-12 09:09:50 UTC
Description of problem:

Attempting to upgrade an FC6 install to F7 produces an exception traceback. The
end of this file is:

Upgrading python-docs - 2.4.3-1.1.noarch
Upgrading cyrus-sasl-md5 - 2.1.22-4.i386
Upgrading k3b - 0.12.15-3.1.1.i386
Upgrading xfig - 3.2.4-21.1.i386
Upgrading gimp-devel - 2:2.2.13-1.fc6.i386
Upgrading system-config-bind - 4.0.1-2.fc6.noarch
Upgrading hwbrowser - 0.27-2.noarch
/usr/bin/update-gdk-pixbuf-loaders: line 27:
/etc/gtk-2.0/i386-redhat-linux-gnu/gdk-pixbuf.loaders: No such file or directory
error: %postun(librsvg2-2.14.4-1.fc5.1.i386) scriptlet failed, exit status 1

I will attach the complete log to this report.

Version-Release number of selected component (if applicable):

FC6 -> F7

How reproducible:

It's repeatable on my system. 

Steps to Reproduce:
1. Start F7 upgrade using VNC method from local CDROM
2. Proceed past the Grub update screens
3. Boom!
  
Actual results:

Upgrade halts with an exception.

Expected results:

Happiness.

Additional info:

Presumably this is some quirk of my install? I couldn't see this on the top bugs
list but the site was really slow this morning and I couldn't do as much
searching as I'd liked.

Comment 1 Martin Smith 2007-07-12 09:09:50 UTC
Created attachment 159040 [details]
Exception log produced by anaconda

Comment 2 Jeremy Katz 2007-07-16 20:34:41 UTC
Removing the compat-glibc package will fix this.  

*** This bug has been marked as a duplicate of 242604 ***

Comment 3 Martin Smith 2007-07-22 07:55:27 UTC
Unfortunately, removing compat-glibc hasn't stopped this error happening, nor
has rpm --rebuilddb. Is there anything else I can try?

Comment 4 Martin Smith 2007-08-05 09:55:38 UTC
Ok I have now solved it after several hours this morning spent finding and
removing obsolete packages.

In summary:

Get a list of packages with package-cleanup --obsoletes from yum-utils. 

Scan this list very carefully, take any important third party packages and any
that you've updated from rawhide as well as kernel packages etc off the list. 

Cross reference this list with the output of rpm -q -a --last to get confidence
that these are packages hanging over from a previous release. 

Then feed the remaining obsolete packages on the list to rpm --erase. 

Now upgrade to F7.



Note You need to log in before you can comment on or make changes to this bug.