Bug 242650 - GNOME panel locking up
Summary: GNOME panel locking up
Status: CLOSED DUPLICATE of bug 213283
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-05 09:56 UTC by Andrew Clayton
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 17:01:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Clayton 2007-06-05 09:56:11 UTC
Description of problem:

Every now and again gnome-panel seems to lock up. I don't have a lot of stuff in
it. A menu, some icons, task switcher, notification area and a clock.

When it locks up the clock is working but nothing else on the panel is useable.

A strace on gnome-panel during this time shows this

Process 6106 attached - interrupt to quit
futex(0x2b9e1ad99960, FUTEX_WAIT, 2, NULL

A killall -HUP gnome-panel gets it back (restarts it anyway)


Version-Release number of selected component (if applicable):

gnome-panel-2.18.0-9.fc7.x86_64


How reproducible:

Random

Comment 1 Jack Deslippe 2007-06-10 08:08:51 UTC
I have a similar problem where after a period of time my main menu and icons
(launchers) don't work, but everything else does (workspace switcher, show
desktop, window list, clock).  

-Jack  

Comment 2 Edmond Hui 2007-06-15 00:34:48 UTC
I am seeing a similar problem too, in my case after a while (i.e. over-night)
the panel locks up and all icon on it disappeared.

Comment 3 Andrew Clayton 2007-06-20 09:47:02 UTC
Just happened again with gnome-panel-2.18.2-2.fc7.x86_64

Comment 4 J.Jansen 2007-06-25 07:08:56 UTC
I see the same on a i686 system using the livna-Nvidia driver. I see exactly
what is described in comment #1. When you blank the screen (i.e. running the
screen saver) the launcher icons and the main menu disappear completely from the
panel. 

On my Lap-top with different hard-ware I have not experienced the problem.

Comment 5 Hans de Goede 2007-07-18 17:01:57 UTC
There are many reports of this, which are all being closed now as dup of 213283,
please add further comments in bug 213283.


*** This bug has been marked as a duplicate of 213283 ***


Note You need to log in before you can comment on or make changes to this bug.