Bug 213283 - Gnome panel hangs in i386 and x86_64 systems when open for extended periods of time
Gnome panel hangs in i386 and x86_64 systems when open for extended periods o...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 224369 228559 233141 242650 247598 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 11:18 EST by scott
Modified: 2008-03-18 14:41 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:41:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description scott 2006-10-31 11:18:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.7) Gecko/20061011 Fedora/1.5.0.7-7.fc6 Firefox/1.5.0.7

Description of problem:
I have had the panel become unresponsive on both my i386 desktop at home and my X86_64 workstation at work.  The two are not configured in the same way though both access the livnia and the freshrpm repositories.

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2798.fc6, gnome-panel-2.16.0-4.fc6 (appears twice after rpm - q gnome-panel)

How reproducible:
Sometimes


Steps to Reproduce:
1.Boot up
2.Leave the machine on
3.

Actual Results:
Eventually -- after at least 2 days -- the gnome panel hangs.

Expected Results:
Dropdown menues should have dropped down when the mouse cursor is over them and the left button is clicked.

Additional info:
No error message.  I was surprosed that rpm -q gnome-panel returned gnome-panel-2.16.0-4.fc6 twice.  Certainly, I haven't installed it a second time.
Comment 1 scott 2006-10-31 17:43:37 EST
Happened again but when cursor was over System drop-down menu.  All function
lost, couldn't move cursor or change focus or anything.
Comment 2 Ray Strode [halfline] 2006-10-31 21:19:29 EST
so the mouse pointer doesn't move at all?  Can you toggle caps lock or switch to
a vt with ctrl-alt-f1?
Comment 3 Matt Rickard 2006-12-12 16:54:21 EST
I have what sounds like the same problem on my x86_64 system.  The gnome panel
seems to lock up after being open for extended periods of time (can range from a
few hours to a few days).  When this happens, the menus/quick launch icons
disappear on me, although the rest of the session functions normally.

If I bring up a terminal and 'killall gnome-panel' the panel restarts itself and
then functions normally until the next lockup occurs a few hours/days later.  I
haven't been able to find anything useful being logged when this happens.  Is
there anywhere in particular I should be looking?
Comment 4 Jonathan Kamens 2007-04-06 11:03:41 EDT
This is happening to me as well, with Fedora Devel.  I ran an strace on
gnome-panel while it's happening and it's stuck in futex.  I don't know how to
debug what it's waiting on; are there tools or techniques for doing that?

The mouse pointer moves just fine, it's just that clicking on launchers or menu
buttons in the panel doesn't do anything.  Applets and application icons in the
panel do *not* hang -- it's just the panel launcher and menu buttons that are
nonfunctional.
Comment 5 Ray Strode [halfline] 2007-04-08 15:03:05 EDT
if you could attach to the process and get a stacktrace with gdb that would be
good (gdb attach $(/sbin/pidof gnome-panel), then bt full from the gdb prompt)

also, doing gnome-session-remove gnome-panel followed by export
G_SLICE=always-malloc; valgrind --tool=memcheck gnome-panel

and waiting until it locks up and then giving the output might be useful.
Comment 6 Hans de Goede 2007-07-18 05:28:49 EDT
I've been seeing this too on my x86_64 system for a long time (I never
considered filing a bug for this my bad) this has happened to me with various
versions since atleast FC-6, maybe even earlier.

I think this always happens when I've just installed / updated an application
which adds / changes a .desktop file under /usr/share/applications. I believe
that the hang is in code that rescans /usr/share/applications, or it is related
to the icon cache, but I could be wrong. There could be multiple hanger causes even.

Scott, when you say leave on for atleast 2 days, could it be that you are
installing updates and or new packages during this time?

About some people seeing the icons disappearing, this happens when you force a
redraw, for example by running the screensaver. The icons disappearing on a
redraw is quite normal for a hanging app, so this is most likely one and the
same problem.

BTW, I believe that bug 224369, bug 247598, bug 242650, bug 233141 and bug
228559 are all dups of this. Notice that several reporters have made the same
observation that I have, that this seems to always happen on upgrading /
installing new applications.

Ray let me know if you want me to close them all as a dup of this for you.
Comment 7 Ray Strode [halfline] 2007-07-18 11:36:30 EDT
Ah, yea, if you want to dupe those, that'd be great (it's a bit embarrassing
that there are so many duplicates of this bug, and I haven't moved any of them
past NEW)
Comment 8 Hans de Goede 2007-07-18 13:00:40 EDT
*** Bug 224369 has been marked as a duplicate of this bug. ***
Comment 9 Hans de Goede 2007-07-18 13:00:53 EDT
*** Bug 247598 has been marked as a duplicate of this bug. ***
Comment 10 Hans de Goede 2007-07-18 13:02:03 EDT
*** Bug 242650 has been marked as a duplicate of this bug. ***
Comment 11 Hans de Goede 2007-07-18 13:02:18 EDT
*** Bug 233141 has been marked as a duplicate of this bug. ***
Comment 12 Hans de Goede 2007-07-18 13:02:43 EDT
*** Bug 228559 has been marked as a duplicate of this bug. ***
Comment 13 Ray Strode [halfline] 2008-03-18 14:41:37 EDT
Hi,

We no longer support Fedora Core 6 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.