Bug 242736 - Wrong init script
Summary: Wrong init script
Status: CLOSED DUPLICATE of bug 246878
Alias: None
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On: 242734
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-05 15:26 UTC by Michal Marciniszyn
Modified: 2014-02-10 23:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-17 06:11:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Marciniszyn 2007-06-05 15:26:42 UTC
+++ This bug was initially created as a clone of Bug #242734 +++

Description of problem:
There are several constructions in named init script that return incorrect error
codes and some of them prevent status function call. For example:
[ "${NETWORKING}" = "no" ] && exit 1

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.

-- Additional comment from pm-rhel@redhat.com on 2007-06-05 11:24 EST --
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 1 Adam Tkac 2007-06-12 13:06:28 UTC
Proposed LSB compatible initscript is on
http://people.redhat.com/atkac/bind/named.init.lsb. Please check it

A

Comment 2 Adam Tkac 2007-07-17 06:11:23 UTC

*** This bug has been marked as a duplicate of 246878 ***


Note You need to log in before you can comment on or make changes to this bug.