Bug 246878 - Initscript Review
Summary: Initscript Review
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 242736 (view as bug list)
Depends On:
Blocks: InitscriptStatus
TreeView+ depends on / blocked
 
Reported: 2007-07-05 13:47 UTC by Harald Hoyer
Modified: 2013-04-30 23:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-17 10:48:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Harald Hoyer 2007-07-05 13:47:36 UTC
Please have a look at the wikipage 
http://fedoraproject.org/wiki/FCNewInit/Initscripts
and change your initscripts to comply with the LSB standard.
Especially check the exit status and add a LSB Header.
E.g. starting a service should return with 0, if the service is already running and stopping a stopped service should also return with 0.

Also check, if your service has to be _on_ per default, and turn it off in the old chkconfig line, if not.

Thank you.

Comment 1 Adam Tkac 2007-07-17 06:11:26 UTC
*** Bug 242736 has been marked as a duplicate of this bug. ***

Comment 2 Adam Tkac 2007-07-17 06:18:05 UTC
I'm not sure _why_ service has to be enabled by default. (I prefer disable it by
default and explicitly enable)

Adam

Comment 3 Harald Hoyer 2007-07-17 09:13:18 UTC
me, too, cause you have to configure it anyway.

Comment 4 Adam Tkac 2007-07-17 10:48:39 UTC
Fixed in rawhide (commited, not build yet) but I enabled only 3 and 5 runlevels
by default (when all
runlevels is on it doesn't works). I'm ready change it when all will be ready
(or you could do it)

Adam


Note You need to log in before you can comment on or make changes to this bug.