Bug 242748 - Inkscape fails to install dependencies
Inkscape fails to install dependencies
Status: CLOSED DUPLICATE of bug 242368
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
: 243597 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-05 12:35 EDT by Andy Burns
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 19:08:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Burns 2007-06-05 12:35:37 EDT
Description of problem:
Inkscape on F7 fails to install all required share runtime libraries

Version-Release number of selected component (if applicable):
inkscape.i386 0.45.1-1.fc7

How reproducible:
100%

Steps to Reproduce:
1. install fedora 7
2. install inkscape
3. run inkscape
  
Actual results:
Error while loading shared libraries: libgtkmm-2.4.so.1: cannot open shared
object file: No such file or directory

Expected results:
RPMs should include runtime dependencies

Additional info:
Manually installing missing libraries in turn then reveals further missing
dependencies, in total I installed the following manually to allow inkscape to run.

Jun 05 17:24:18 Installed: glibmm24.i386 2.12.8-1.fc7
Jun 05 17:25:18 Installed: gtkmm24.i386 2.10.9-1.fc7
Jun 05 17:26:59 Installed: cairomm.i386 1.2.4-1.fc7
Jun 05 17:27:40 Installed: libsigc++.i386 1.2.7-4.fc6
Jun 05 17:28:13 Installed: libsigc++20.i386 2.0.17-2
Jun 05 17:31:44 Installed: gc.i386 6.8-3.fc7
Comment 1 Denis Leroy 2007-06-05 18:25:22 EDT
Hmmm, i've never seen that happen before. yum will of course install the
dependencies. As a matter of fact, it's technically impossible to install the
inkscape RPM if the deps aren't present, not unless you install with '--nodeps'.

Is this on i386 ? Did you do a clean F-7 install ? Did you install inkscape with
'yum install inkscape' ? 

What does 'rpm -qR inkscape' return ?
Comment 2 Andy Burns 2007-06-05 18:38:47 EDT
This is a clean F7 install, I didn't use rpm --nodeps, actually I didn't use rpm
or yum directly, I used yumex, I suppose yumex could have a depsolving issue,
it's  certainly much quicker than it was on FC6 :-)

I'm dual-booted back to windows now so can't check rpm -qR at the moment.

I'll boot back to Fedora, remove inkscape and the libs I installed manually,
then try again using rpm/yum rather then yumex and check what happens.

Comment 3 Denis Leroy 2007-06-06 02:58:16 EDT
Also, do you have any other repos enabled other than fedora and fedora-updates ?
Comment 4 Denis Leroy 2007-06-06 09:12:01 EDT
We're seeing similar reports on the mailing lists. Another question: how did you
install F-7, i.e. with what media (DVD, single CD spin, liveCD, ...) ?
Comment 5 Andy Burns 2007-06-06 09:52:59 EDT
Machine is a fresh install from F7 DVD.

I just yum removed all the "manual" dependencies with

# yum remove glibmm24 gtkmm24 cairomm libsigc++ libsig++20 gc

and it *DID* want to remove inkscape for dependencies, I was expecting it not
to, to be honest, so I let it remove all.

I then did a yum install inkscape, it wanted to pull in all those packages it
had just removed, and more besides

 ImageMagick-c++         i386       6.3.2.9-3.fc7    fedora            152 k
 ImageMagick-perl        i386       6.3.2.9-3.fc7    fedora            148 k
 cairomm                 i386       1.2.4-1.fc7      fedora             43 k
 gc                      i386       6.8-3.fc7        fedora            133 k
 glibmm24                i386       2.12.8-1.fc7     fedora            150 k
 gtkmm24                 i386       2.10.9-1.fc7     fedora            1.1 M
 libEMF                  i386       1.0.3-3.fc7      fedora             90 k
 perl-DateManip          noarch     5.44-3.fc7       fedora            144 k
 perl-Parse-Yapp         noarch     1.05-36.fc6      fedora             46 k
 perl-XML-DOM            noarch     1.44-2.fc6       fedora            138 k
 perl-XML-Parser         i386       2.34-6.1.2.2.1   fedora            209 k
 perl-XML-RegExp         noarch     0.03-2.fc6       fedora            8.2 k
 perl-XML-XQL            noarch     0.68-4.fc7       fedora            109 k
 plotutils               i386       2.5-3.fc6        fedora            1.5 M
 pstoedit                i386       3.44-6.fc7       fedora            463 k

I cancelled that and tried yumex instead of yum, this was no different at this
point, the same larger list of dependencies were identified.

So it seems that either yum's metadata can get confused, or its depsolver can
sometimes bypass something.

Comment 6 Andy Burns 2007-06-06 09:56:23 EDT
I have no other repos configured at all, sorry I forgot to try the rpm -qR
before removing inkscape. 

It looks to me more like yum skated over inkscape's deps rather than the
inkscape RPM failed to list its deps.

Comment 7 Denis Leroy 2007-06-13 11:57:22 EDT
*** Bug 243597 has been marked as a duplicate of this bug. ***
Comment 8 Andy Burns 2007-07-23 19:08:35 EDT
Seems unfair to leave this assigned as an inkscape bug, duping to a more general
yum/pirut bz entry

*** This bug has been marked as a duplicate of 242368 ***

Note You need to log in before you can comment on or make changes to this bug.