Bug 243597 - Inkscape does not launch on FC7
Inkscape does not launch on FC7
Status: CLOSED DUPLICATE of bug 242748
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-10 08:22 EDT by Andreas Färber
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 11:57:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Färber 2007-06-10 08:22:50 EDT
Description of problem:
Inkscape package depends on gc package.

Version-Release number of selected component (if applicable):
0.45.1-1.fc7

How reproducible:

Steps to Reproduce:
1. install Inkscape
2. in Gnome, Select Graphics > Inkscape
  
Actual results:
"Launching Inkscape" is visible in taskbar and disappears, Inkscape does not open.

Expected results:
Inkscape should open

Additional info:
ldd indicates a dependency of /usr/bin/inkscape on libgc.so.1
Comment 1 Denis Leroy 2007-06-11 09:59:57 EDT
Looks like you have a mix of i386 and x86_64 packages, or something like that.
Did you do a clean F-7 install, or an upgrade from FC-6 ?

Could you install the 'yum-utils' package and run the following command ? :

package-cleanup --problems
Comment 2 Andreas Färber 2007-06-11 15:21:50 EDT
I did a clean net install (boot.iso) of F7 on a Pentium III, so if some x86_64 packages got installed it's still 
a bug. Mirror used was ftp.stw-bonn.de I believe.
There was an (i386) FC4 installation on the machine but it was repartitioned and formatted.
Comment 3 Andreas Färber 2007-06-11 15:30:17 EDT
Similar problems also surfaced for Skencil (0.6.17-13.fc7):
- according to /usr/bin/skencial it did not find tk84.so: the tk package was not installed as a dependency
- manually installing tk leads to the next error, Python complaining about python-imaging
- if I manually install python-imaging and surrounding packages then I get a memory access error 
("Speicherzugriffsfehler")
Let me know if I should file a separate bug on that.
Comment 4 Andreas Färber 2007-06-11 15:37:56 EDT
$ package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Missing dependencies:
Package gnochm requires python-chm >= 0.8.4
Package pstoedit requires libEMF.so.1
Package pstoedit requires libMagick++.so.10
Package pstoedit requires libplotter.so.2
Package inkscape requires perl(Image::Magick)
Package inkscape requires perl(XML::XQL)
Package inkscape requires perl(XML::XQL::DOM)
Package xfig requires transfig >= 1:3.2.5

These packages and some others were installed graphically in Gnome using Package
Manager ("Paket-Manager"), no crashes or errors.
Comment 5 Denis Leroy 2007-06-11 17:20:21 EDT
We've had similar reports of yum installations leading to broken deps, something
that's normally technically not possible. 2 questions :

1. did you install inkscape with a manual yum command ?

2. from what F-7 media did you install from ? (DVD, single-CD spin, live CD,
network install)
Comment 6 Andreas Färber 2007-06-11 18:22:46 EDT
See comments #3 and #5!
Comment 7 Andreas Färber 2007-06-11 18:24:14 EDT
sry, #2 and #4 obviously: no manual yum
Comment 8 Denis Leroy 2007-06-13 11:57:19 EDT
So you installed inkscape with the 'add/remove software' menu entry ? (aka pirut).


*** This bug has been marked as a duplicate of 242748 ***
Comment 9 Andreas Färber 2007-06-14 03:10:02 EDT
Yes! (The window title and about dialog both said Paket-Manager.)

Note You need to log in before you can comment on or make changes to this bug.