Bug 242820 - Crashed on search
Summary: Crashed on search
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: 7
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
: 251802 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-05 23:14 UTC by James Buckle
Modified: 2008-08-02 23:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 19:51:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Buckle 2007-06-05 23:14:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070603 Fedora/2.0.0.4-2.fc8 Firefox/2.0.0.4

Description of problem:
Couldnt find the F7/FC7 in the release options.

Works fine before and after but triggered a complete pirut dissappearance when i clicked search.

Version-Release number of selected component (if applicable):
pirut-1.3.7-1.fc7

How reproducible:
Couldn't Reproduce


Steps to Reproduce:
1.
2.
3.

Actual Results:


Expected Results:
Search!

Additional info:
Component: Software Manager
Summary: TB5e195ffa pirut:172:_searchClicked:AttributeError: 'NoneType' object has no attribute 'strip'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 172, in _searchClicked
    t = entry.get_text().strip()
AttributeError: 'NoneType' object has no attribute 'strip'

Local variables in innermost frame:
widget: <gtk.Entry object at 0x8fbe464 (GtkEntry at 0x8c93228)>
self: <__main__.PackageManager object at 0x8bc1cec>
stop: <gtk.Button object at 0x8fbe52c (uninitialized at 0x0)>
search: <gtk.Button object at 0x8fbe504 (uninitialized at 0x0)>
entry: <gtk.Entry object at 0x8fbe554 (uninitialized at 0x0)>
.2: (<gtk.Entry object at 0x8fbe554 (uninitialized at 0x0)>, <PirutPackageList object at 0x8fbeb94 (pirut+PackageList+PirutPackageList at 0xb208778)>, <gtk.Button object at 0x8fbe504 (uninitialized at 0x0)>, <gtk.Button object at 0x8fbe52c (uninitialized at 0x0)>)
plist: <PirutPackageList object at 0x8fbeb94 (pirut+PackageList+PirutPackageList at 0xb208778)>

Comment 1 James Buckle 2007-06-05 23:55:52 UTC
Seems to be fairly repeatable if I:

1) seach out some items
2) click on items
3) enter a new item to search for, without applying
4) hit search

Comment 2 James Buckle 2007-06-05 23:56:45 UTC
(in 2) I meant click on the checkbox as if to add it)

Comment 3 Jeremy Katz 2007-06-06 02:48:22 UTC
What version of gtk2 and pygtk2 do you have installed?  I triggered this on a
rawhide box, but not on F7 afaict...

Comment 4 James Buckle 2007-06-06 12:42:08 UTC
gtk2.i386 2.10.11-6.fc7 

Not sure on the pygtk2 at the moment, will have to check when i get home later.

Thanks,
James

Comment 5 James Buckle 2007-06-07 22:41:51 UTC
pygtk2-2.10.4-2.fc7

Sorry it took so long.

Comment 6 Jeremy Katz 2007-08-10 19:51:23 UTC
I still can't reproduce this; but I've put something in CVS which will avoid it
anyway

Comment 7 Jeremy Katz 2007-08-13 15:24:51 UTC
*** Bug 251802 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.