Bug 251802 - exception occurs when try to find another package in pirut
exception occurs when try to find another package in pirut
Status: CLOSED DUPLICATE of bug 242820
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-11 09:27 EDT by han pingtian
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-13 11:24:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description han pingtian 2007-08-11 09:27:12 EDT
Description of problem:


Version-Release number of selected component (if applicable):
First, I find a package and select it. Then, when I try to find another package,
a exception occurs:

Component: pirut
Summary: TB5e195ffa pirut:172:_searchClicked:AttributeError: 'NoneType' object
has no attribute 'strip'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 172, in _searchClicked
    t = entry.get_text().strip()
AttributeError: 'NoneType' object has no attribute 'strip'

Local variables in innermost frame:
widget: <gtk.Entry object at 0x906a4dc (GtkEntry at 0xa3cb588)>
self: <__main__.PackageManager object at 0x8b312ac>
stop: <gtk.Button object at 0x8f16dec (uninitialized at 0x0)>
search: <gtk.Button object at 0x8f16d9c (uninitialized at 0x0)>
entry: <gtk.Entry object at 0x8f16e14 (uninitialized at 0x0)>
.2: (<gtk.Entry object at 0x8f16e14 (uninitialized at 0x0)>, <PirutPackageList
object at 0x8d134b4 (pirut+PackageList+PirutPackageList at 0xa6da950)>,
<gtk.Button object at 0x8f16d9c (uninitialized at 0x0)>, <gtk.Button object at
0x8f16dec (uninitialized at 0x0)>)
plist: <PirutPackageList object at 0x8d134b4 (pirut+PackageList+PirutPackageList
at 0xa6da950)>

It seems this exception always occurs when try to search another one or two
packages.

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2007-08-13 11:24:46 EDT

*** This bug has been marked as a duplicate of 242820 ***

Note You need to log in before you can comment on or make changes to this bug.