Bug 242857 - syste-cdinstall-helper doesn't work
syste-cdinstall-helper doesn't work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
: 245136 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-06 00:53 EDT by Jeff Norden
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.3.9-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 18:24:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Norden 2007-06-06 00:53:45 EDT
Description of problem:

system-cdinstall-helper doesn't work out of the box.  It does now have a man
page, which is a start, though :-)

Version-Release number of selected component (if applicable):
pirut-1.3.7-1.fc7

How reproducible:
Steps to Reproduce:
1. at the command line, type:
   system-cdinstall-helper file:///media/Fedora\ 7\ x86_64\ DVD/
2. click "next" in the window that comes up
  
Actual results:
The crash gives the following error messages:
----------------------------------------
Loading "installonlyn" plugin
Component: CD Installer
Summary: TB3c0e3816 system-cdinstall-helper:146:_busyCursor:NameError: global  
 name 'gdk' is not defined

Traceback (most recent call last):
  File "/usr/sbin/system-cdinstall-helper", line 174, in _prepare
    self.doRefresh(thisrepo = self.cdreponame)
  File "/usr/sbin/system-cdinstall-helper", line 168, in doRefresh
    self.doRefreshRepos(thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 258, in
doRefreshRepos
    self._busyCursor()
  File "/usr/sbin/system-cdinstall-helper", line 146, in _busyCursor
    self.mainwin.window.set_cursor(gdk.Cursor(gdk.WATCH))
 NameError: global name 'gdk' is not defined

Local variables in innermost frame:
self: <__main__.CDInstaller object at 0xf42190>
-----------

Maybe there is some python package with gdk glue that is needs to be required by
pirut?


Expected results:

I should be able to install packages from the dvd.
Comment 1 Jeremy Katz 2007-06-08 16:51:30 EDT
Fixed in CVS for 1.3.9 which I'll push as an F7 update as long as nothing else
comes up in the next few days
Comment 2 Jeremy Katz 2007-06-21 07:38:25 EDT
*** Bug 245136 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2007-07-23 14:49:58 EDT
pirut-1.3.9-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2007-08-10 18:24:16 EDT
pirut-1.3.9-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.