Bug 245136 - /usr/sbin/system-cdinstall-helper - NameError: global name 'gdk' is not defined
/usr/sbin/system-cdinstall-helper - NameError: global name 'gdk' is not defined
Status: CLOSED DUPLICATE of bug 242857
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
noarch Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-21 07:06 EDT by Mohd Izhar Firdaus Ismail
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 07:38:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohd Izhar Firdaus Ismail 2007-06-21 07:06:30 EDT
Description of problem:
class gdk called without parent, supposed to be gtk.gdk ...

Version-Release number of selected component (if applicable):
pirut-1.3.7-1.fc7

How reproducible:
everytime

Steps to Reproduce:
1. system-cdinstall-helper http://url/of/repository/
2. click next, a progressbar will appear, and the app crashes

  
Actual results:
crash

Component: CD Installer
Summary: TB3c0e3816 system-cdinstall-helper:146:_busyCursor:NameError: global
name 'gdk' is not defined

Traceback (most recent call last):
  File "/usr/sbin/system-cdinstall-helper", line 174, in _prepare
    self.doRefresh(thisrepo = self.cdreponame)
  File "/usr/sbin/system-cdinstall-helper", line 168, in doRefresh
    self.doRefreshRepos(thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 258, in
doRefreshRepos
    self._busyCursor()
  File "/usr/sbin/system-cdinstall-helper", line 146, in _busyCursor
    self.mainwin.window.set_cursor(gdk.Cursor(gdk.WATCH))
NameError: global name 'gdk' is not defined

Local variables in innermost frame:
self: <__main__.CDInstaller object at 0x9dac18c>


Expected results:
progressbar continue, shows package selection menu

Additional info:

--- /tmp/system-cdinstall-helper-orig   2007-06-21 16:51:39.000000000 +0800
+++ /tmp/system-cdinstall-helper-new    2007-06-21 16:52:24.000000000 +0800
@@ -143,7 +143,7 @@
         self.xml.signal_autoconnect(sigs)
 
     def _busyCursor(self):
-        self.mainwin.window.set_cursor(gdk.Cursor(gdk.WATCH))
+        self.mainwin.window.set_cursor(gtk.gdk.Cursor(gtk.gdk.WATCH))
         self.mainwin.set_sensitive(False)
         _runGtkMain()
Comment 1 Jeremy Katz 2007-06-21 07:38:23 EDT

*** This bug has been marked as a duplicate of 242857 ***

Note You need to log in before you can comment on or make changes to this bug.