Bug 242956 - F7 CDROM installation method fails to recognize CD/DVD drive
F7 CDROM installation method fails to recognize CD/DVD drive
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-06 13:18 EDT by Gerry Reno
Modified: 2008-02-13 09:16 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 17:01:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from the three commands (79.26 KB, text/plain)
2007-09-22 13:33 EDT, K Pedersen
no flags Details
output of lspci -vvxx (32.37 KB, text/plain)
2007-09-23 11:51 EDT, Christopher Brown
no flags Details
out of dmesg (24.33 KB, text/plain)
2007-09-23 11:51 EDT, Christopher Brown
no flags Details
output of dmidecode (22.31 KB, text/plain)
2007-09-23 11:52 EDT, Christopher Brown
no flags Details
lspci output (25.58 KB, text/plain)
2007-11-16 03:28 EST, Paul Bickerstaff
no flags Details
dmesg output (30.78 KB, text/plain)
2007-11-16 03:28 EST, Paul Bickerstaff
no flags Details
dmidecode output (21.09 KB, text/plain)
2007-11-16 03:29 EST, Paul Bickerstaff
no flags Details
lspci -vvxx (24.76 KB, application/octet-stream)
2007-11-17 22:03 EST, vfiend
no flags Details
dmesg (21.98 KB, application/octet-stream)
2007-11-17 22:06 EST, vfiend
no flags Details
dmidecode (16.12 KB, application/octet-stream)
2007-11-17 22:06 EST, vfiend
no flags Details

  None (edit)
Description Gerry Reno 2007-06-06 13:18:50 EDT
Description of problem:
When installing F7 from the DVD, after you select the installation type as CDROM
the install then fails to recognize the CD/DVD drive and prompts for driver
installation.

Version-Release number of selected component (if applicable):


How reproducible:
Always on certain machines.

Steps to Reproduce:
1. Put F7 installation DVD in DVD drive.
2. Boot from DVD drive.
3. At Installation Type screen select CDROM.
  
Actual results:
Install gets stuck because it cannot recognize CD/DVD drive.

Expected results:
Installation recognizes CD/DVD drive and completes F7 installation.

Additional info:
This has happened on two systems with Lite-On CD/DVD (Sony?) drives and also
when installing F7 in QEMU 0.8.2 on FC6 host.
Comment 1 Andrea Bruna 2007-06-09 09:33:17 EDT
I have the same problem with a Slimtype (Lite-on) DVD A DS8A1P but (to me) it
looks like an issue with the kernel released with Fedora 7.

Unofrtunately in the forum there are other people with Lite-on/Sony drives
experiencing the same problem:
http://fedoraforum.org/forum/showthread.php?t=156543&page=2&pp=15&highlight=lite-on

Comment 2 Yann Golanski 2007-06-15 04:06:14 EDT
Yeah, I can confirm this bug with a Pioneer DVR-111BK 16x16 DVD-RW.

Forum post:  http://forums.fedoraforum.org/showthread.php?t=157680
Comment 3 Danny 2007-06-17 15:00:47 EDT
Im seeing the same issue with a TS-H553 and a QSI SDW-085. Problem may exist 
with the changing of device nodes for ATA drives from FC6 to F7?
Comment 4 Jordi Prats 2007-06-18 09:27:17 EDT
I get the same error on a HP DL360G5 using a stardard IDE drive:

http://www.superwarehouse.com/HP_Slim_Line_CD-RW_DVD-ROM_Combo_Drive/331903-B21/p/293644

Comment 5 Torgeir Veimo 2007-06-19 09:34:53 EDT
I had this problem on a motherboard with VIA chipsets and a celeron 850
processor (a MS-6723 board). The DVD-ROM drive was then the slave on a single
connector connected to the primary IDE channel. Putting the DVD-ROM as master on
the seconrady IDE channel fixed it.
Comment 6 Bill Waddington 2007-06-20 19:29:51 EDT
Similar problem on ThinkPad T61.  Prior to error, it hangs (times out?) for a
long time at "Loading SCSI driver - Loading ahci driver".  It isn't clear to me
that it is having trouble finding the *source* of the install.  It may be
getting past that, and looking for a suitable *destination*.
Trying an FC5 install on this T61, the actual error seems to be in locating a
hard drive.  When asked to select an appropriate driver, it already has
"advanced ahci device" showing, and just selecting "done" allows installation to
proceed.  (This may just be noise on my part.....)
Comment 7 Bill Waddington 2007-06-21 11:29:08 EDT
(In reply to comment #6)
> Similar problem on ThinkPad T61.  Prior to error, it hangs (times out?) for a
> long time at "Loading SCSI driver - Loading ahci driver".  It isn't clear to me
> that it is having trouble finding the *source* of the install.  It may be
> getting past that, and looking for a suitable *destination*.
> Trying an FC5 install on this T61, the actual error seems to be in locating a
> hard drive.  When asked to select an appropriate driver, it already has
> "advanced ahci device" showing, and just selecting "done" allows installation to
> proceed.  (This may just be noise on my part.....)

Additional (probably useless) data point: FC6 32 bit (6.93) installs OK on this
T61 w/the usual tap-dance around anaconda bugs (don't select "extras").

Comment 8 Kevin Hendricks 2007-06-22 13:35:16 EDT
The priority on this bug should be change to high because even if you install via network, post installation 
the CD and DVD are not recognized.  After booting, simply check dmesg output and you will see the drive 
is not found.  This makes Fedora 7 unusable on my machine because I can not create or restore from dvd 
backups.

 
Comment 9 Gerry Reno 2007-06-22 15:20:11 EDT
Kevin, I agree.  Without a CD/DVD drive it's very difficult to restore any
backups.  You could boot into rescue and enable networking and then load the
backups into another CD/DVD drive on another non-F7 machine but who has time for
all this.  
After struggling to get F7 installed on a couple machines and failing on many
others, I've given up on F7 and I'm going to wait for F8 to see if these
installation problems get fixed.  F7 install is too much hassle.

Comment 10 Alan Cox 2007-06-22 16:10:00 EDT
This bug is mostly being used for general tracking. Its too many different
systems and different devices to consider as a single bug and some of them are
going to get fixed by different patches on the way.
Comment 11 Niln On 2007-06-24 06:38:14 EDT
Same problem with my LG GSA-4163B.  When installing from the DVD, Anaconda does
not recognize the disc.  However, I'm able to boot (and later install from) the
LiveCD using the same DVD drive.
Comment 12 Niln On 2007-06-24 06:40:51 EDT
Are the kernel / modules different or compiled differently between the DVD and
LiveCD versions?
Comment 13 Andrea Bruna 2007-06-25 02:27:28 EDT
(In reply to comment #10)
> This bug is mostly being used for general tracking. Its too many different
> systems and different devices to consider as a single bug and some of them are
> going to get fixed by different patches on the way.

Alan, there will ever be a re-spin of Fedora 7 with all these patches applied 
(as it happened with F6) or should we wait for Fedora 8? 
Comment 14 Chris Lumens 2007-06-25 10:47:06 EDT
Reassigning to kernel on the basis of several comments on this report, which
makes it look like this is happening post-install as well.
Comment 15 H Oudenhoven 2007-06-29 01:06:04 EDT
I experienced the same problem when I installed FC6 on my computer. My
installation got as far as selecting the keyboard and then couldn't find a
driver for the drive it was installing from! I am using an ASUS DRW-1608P3S. A
colleague of mine eventually got it going, but I don't know exactly what he did.
I think he somehow told it that I was using a generic CDROM drive. Later I used
a F7 update disc to install Fedora 7, but this time had no problem so I figured
the problem had been solved. I agree with Kevin: the priority for this bug
should be changed to HIGH as it seems to be ongoing.
Comment 16 Chuck Ebbert 2007-06-29 16:35:07 EDT
Patch that should fix most of these problems will be in the next F-7 kernel.
It just went into upstream 2.6.22-rc6
Comment 17 Tom Attwood 2007-07-03 19:15:12 EDT
I had this problem using tdk DVD media, used a maxwell DVD with same .iso and 
problem left. Cheap media is part of the problem.
Comment 18 Jon Roland 2007-07-10 10:53:28 EDT
Confirm bug for Toshiba CD/DVDW SD-R53 drive. Also unable to install F7 from
LiveCD, which is unable to create RAMdisk.
Comment 19 Vinayak D. Bhende 2007-08-02 06:17:52 EDT
I am having the same problem while installing Fedora 7 through a DVD on my 
laptop (Dell Latitude D630).If I select CDROM as packages media it asks for 
drivers for CDROM.Then I went back to previous screen and selected Local Hard 
disk as media for packages.This time it shows the DVD drive as sda2 but does 
not take the path for the iso file.I tried giving the path as /images to 
boot.iso.But it does not work.How to resolve this issue.
Also I couldnt find the DVD drivers for fedora.
Comment 20 Mike Harpe 2007-08-15 09:02:42 EDT
I'm also having this problem on a Dell Inspiron E530, Intel Core 2 Duo with 
BIOS 1.0.3. I also have this weird problem with the keyboard doubling all my 
keystrokes which makes using the driver selection menu frustrating to say the 
least.
Comment 21 Albert 2007-08-23 08:48:02 EDT
I have an ASUS DVD-RW, same problem. :(
Comment 22 Jack Schmidt 2007-08-26 17:55:38 EDT
Confirm problem for Matshita DVD-RAM UJ-851S on a new HP dv6563cl notebook, F7
x86-64.  I'll try FC6 next.  :-(


Comment 23 Jack Schmidt 2007-08-27 12:11:28 EDT
For Matshita DVD-RAM UJ-851S on a new HP dv6563cl notebook, the problem went
away with "Fedora8 Test 1" aka F7.90 aka Rawhide, x86_64.
Comment 24 Albert 2007-08-27 22:21:33 EDT
It appears that most latest linux distributions can't recognize the DVD-Rom. I
have tried Gentoo 2007, Knoppix 5.1.1, Fedora 7, and worse yet, even Fedora 3
didn't work neither.

All with exactly the same problem - prompt for a driver for the rom. :(

Something extra silly with my system?
Comment 25 Dmitriy Gritsenko 2007-08-28 23:44:06 EDT
Confirm problem on a new HP Compaq 6710b F7 x86-64. Unfortunately I don't know
the DVD-RW type :-(
Comment 26 Jon Roland 2007-08-29 01:40:57 EDT
We have a lot of confirmations, including reports that the problem does not
appear in F8. Obviously someone knows how to fix it, so has it been taken up by
anyone as an action item? I would like to hear that someone is working on a fix
and whether there is some estimate of how long it will take. Otherwise we might
as well write off F7 as a failure and wait for F8, and put out an announcement
of that.
Comment 27 Chuck Ebbert 2007-08-29 13:51:01 EDT
Problem is almost certainly fixed in the F7 kernel updates, but nobody has done
a respin of F7 so people can install it. The Pegasos PPC systems need a respin
of the install disks too.
Comment 28 Bardasu Alexandru 2007-09-04 08:34:05 EDT
I also confirm this bug on HP Pavillion DV9500.
Comment 29 Raghvendra 2007-09-06 13:53:49 EDT
I faced same problem on HP Pavilon DV6500.
Comment 30 Sudhi 2007-09-13 13:50:44 EDT
I had the same problem with Dell Vostro 1400 laptop. After selecting
installation type as CDROM, it shows a list of available drivers and prompts for
driver installation.
Comment 31 Christopher Brown 2007-09-13 18:57:42 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

Could I suggest that people with this issue test Fedora 8 Test 2 if possible?

You can get it from:

http://fedoraproject.org/wiki/Distribution/Download

This will help prevent the same bug occurring in the Fedora 8 install. I have
added a blocker bug to flag this appropriately.

Cheers
Chris
Comment 32 Arnaud Mombrial 2007-09-15 14:11:29 EDT
Hi everybody, 

Really new here, so I don't know if it would help in a way ....

Same pb with a HP Notebook 6910p.

The only distro that have been successfully installed on this notebook is an
OpenSuse 10.2.

Comment 33 K Pedersen 2007-09-20 06:52:01 EDT
Same problem with Fedora 8 Test 2 and Pioneer DVR-111D.
Comment 34 Christopher Brown 2007-09-20 07:28:23 EDT
As this is preventing an install of Fedora, it is obviously pretty critical to
resolve this sooner rather than later. Could all reporters please post the
output from the following commands, assuming they are able to get a working
system running:

# lspci -vvxx
# dmesg
# dmidecode (you may need to install this)

and we will have a lot more to go on. You can also try installing by adding
acpi=off to the boot parameters. Pressing the Escape key twice at the first
screen enables you to do this.

Cheers
Chris
Comment 35 K Pedersen 2007-09-22 13:33:30 EDT
Created attachment 203171 [details]
Output from the three commands
Comment 36 Christopher Brown 2007-09-23 11:51:04 EDT
Created attachment 203501 [details]
output of lspci -vvxx

Splitting the output into three
Comment 37 Christopher Brown 2007-09-23 11:51:59 EDT
Created attachment 203511 [details]
out of dmesg
Comment 38 Christopher Brown 2007-09-23 11:52:35 EDT
Created attachment 203521 [details]
output of dmidecode
Comment 39 Cesar Ventura 2007-09-27 16:54:35 EDT
  Ok, I had the same problem of the DVD not being recognized. Tried Fedora 7
then  Fedora 8 test(7.91). Both were 64 bit versions.  I finally got it to work
without a problem by removing 2 gig of ram from the system.  If it helps, I have
the following configuration.
ASUS M2N SLI 4 Gig of Ram with AMD 5600
IDE drive 0 80 Gig WD  (Fedora 7)
Sata 1 Seagate 250 Gig  (Windows Vista Ultimate 64)
Sata 2 WD 200 Gig (Windows XP Pro)
Sata 3 Samsung DVD Writer
Sata 4 Pioneer DVD Writer
  I had to add "mem=4096M" to get it to boot into graphical mode after the
install, and the 2 gig was added back.
Comment 40 Ben Hilburn 2007-10-02 12:12:51 EDT
I am working with Dell Inspiron 530s, and am experiencing the same issues.

I have tried F7, F8T1, F8T2, and a pre-release of the Unity Project's F7 respin.
 None of them have worked except F8T1, which worked for a little while until an
update killed that too.

Booting with the SATA controller in IDE mode results in the installer trying to
load the ata_piix driver for a while, giving up, and then asking me where the
installation media is.

Booting with the SATA controller in RAID mode simply results in a kernel panic.

Booting with the acpi=off kernel parameter has no affect.
Comment 41 Andrea Bruna 2007-10-08 16:46:31 EDT
Fedora 8 test3, test2 and test1 seem to work on my Acer 5920 with Slimtype DVD A
DS8A1P
Comment 42 Chuck Ebbert 2007-10-08 16:55:11 EDT
(In reply to comment #40)
> I am working with Dell Inspiron 530s, and am experiencing the same issues.
> 
> I have tried F7, F8T1, F8T2, and a pre-release of the Unity Project's F7 respin.
>  None of them have worked except F8T1, which worked for a little while until an
> update killed that too.
> 
> Booting with the SATA controller in IDE mode results in the installer trying to
> load the ata_piix driver for a while, giving up, and then asking me where the
> installation media is.
> 
> Booting with the SATA controller in RAID mode simply results in a kernel panic.
> 
> Booting with the acpi=off kernel parameter has no affect.

Did you try adding "pci=nomsi,nommconf" to the kernel options?

See https://fedoraproject.org/wiki/KernelCommonProblems
Comment 43 K Pedersen 2007-10-13 08:43:14 EDT
"libata.pata_dma=1" works with Pioneer DVR-111D.
Comment 44 Chuck Ebbert 2007-10-15 14:11:38 EDT
Removing from blocker list since we have the pata_dma option.
Comment 45 igor 2007-10-17 06:16:14 EDT
pci=nomsi,nommconf;libata.pata_dma=1 options change nothing on my pc
MB     ASUS  M2NPV-VM
DVD-RW ASUS  1814BL
Comment 46 Chuck Ebbert 2007-10-17 12:41:12 EDT
(In reply to comment #45)
> pci=nomsi,nommconf;libata.pata_dma=1 options change nothing on my pc
> MB     ASUS  M2NPV-VM
> DVD-RW ASUS  1814BL

Which install disc did you try? f8t3 didn't have the Anaconda update that makes
libata.pata_dma option work. (And you need to use a space between options, not a
semicolon.)

This option has been changed to 'libata.dma' for Fedora 8 final, since that is
what went into kernel 2.6.24.
Comment 47 Jon Roland 2007-11-15 11:14:14 EST
Please report on whether this bug has been fixed in the latest release of F8 for
the systems which experienced it, or on any others. Thanks.
Comment 48 Paul Bickerstaff 2007-11-16 03:28:10 EST
Created attachment 260881 [details]
lspci output

For Pioneer DVR111D system on Asus A8N-SLI Premium motherboard with Athlon64
X2.
Comment 49 Paul Bickerstaff 2007-11-16 03:28:56 EST
Created attachment 260891 [details]
dmesg output

For Pioneer DVR111D system on Asus A8N-SLI Premium motherboard with Athlon64
X2.
Comment 50 Paul Bickerstaff 2007-11-16 03:29:53 EST
Created attachment 260901 [details]
dmidecode output

For Pioneer DVR111D system on Asus A8N-SLI Premium motherboard with Athlon64
X2.
Comment 51 Paul Bickerstaff 2007-11-16 03:33:50 EST
(In reply to comment #47)
> Please report on whether this bug has been fixed in the latest release of F8 for
> the systems which experienced it, or on any others. Thanks.

For me this bug is still in F8 -- at least the same symptoms as in F7, described
in this bug, are present.

My system has a Pioneer DVR 111D with an Asus A8N-SLI Premium motherboard and
Athlon64 X2 cpu.

As with F7 I've been able to install F8 using the network (and using a fix
published here for a very disturbing anaconda bug) but this option is not
universally available and I consider the continued presence of this bug to be a
significant issue.

I'll try and attach additional information on my system as an attachment. The
fact it has xen after the F8 upgrade is not relevant. Although the xen kernel
was present before the upgrade it was not the running xen in F7.


Comment 52 vfiend 2007-11-17 22:03:22 EST
Created attachment 262671 [details]
lspci -vvxx
Comment 53 vfiend 2007-11-17 22:04:02 EST
I have this problem in Fedora 8, it will not let me install with the DVD. I
installed by pointing it at the ISO on my hard drive, however, now I cannot use
my DVD drive on the installed system. Any pointers on how I can make this work
would be welcome.

Booting the installed system or install disc with pci=nomsi,nommconf or
libata.pata_dma=1 did not help. I'll upload the output of the three commands.

(This is odd because I have not had any problems with distros like Fedora 7 or
Ubuntu 7.10 in the past.)
Comment 54 vfiend 2007-11-17 22:06:06 EST
Created attachment 262681 [details]
dmesg

(so sorry for the taint, but it happens when booting off the F8 install dvd as
well so it's not really relevant)
Comment 55 vfiend 2007-11-17 22:06:29 EST
Created attachment 262691 [details]
dmidecode
Comment 56 vfiend 2007-11-18 06:51:51 EST
I actually just solved my problem by setting the CD/DVD drive's jumper from
Master to Cable Select. Really weird considering Windows XP and Ubuntu 7.10 were
seeing the drive okay, I guess it's a weird libata issue..
Comment 57 Tim Wunder 2007-11-26 21:40:18 EST
I've esperienced this with the released F8 install DVD using an Optiarc DVD RW
AD-7170A, ATAPI CD/DVD-ROM drive on my Asus M2N-SLI Deluxe mobo (nForce 570 SLI
chipset). The same drive works fine with my son's Abit KT7A mobo (KT133x/KM133
chipset). The Asus board works fine with an NEC DVD RW ND-3550A. The FC6 install
worked fine with the Optiarc DVD drive on the Asus M2N.

The referenced boot options made no difference. 
Comment 58 Anchal Khare 2007-12-24 03:37:58 EST
I also having the same problem with Lenovo 3000 N200 0769-CUQ. (with Sata HDD)
Comment 59 Jon Roland 2008-01-10 21:57:43 EST
Any progress on this, especially for current distros of F8? It is holding up a
lot of people from adopting F8.
Comment 60 Christopher Brown 2008-01-10 22:12:20 EST
You might wish to test a spin from the fedora unity folks:

http://spins.fedoraunity.org/spins

which resolved a number of issues with F8-final installation.
Comment 61 Alan Cox 2008-01-11 11:14:47 EST
The bug is such a random collection of reports I'm not actually tracking it and
don't intend to. I'm working instead off the specific reports of
controller/device problems one by one. The big one with >4GB and Nvidia isn't
fixed yet but is actively being worked on upstream. The problems with tsscorp
cdroms returning bogus cable detect information should be worked around. Some
ALi is still under investigation.
Comment 62 Arthur Buliva 2008-01-22 13:49:33 EST
HP Compaq 6820s has the same "No Driver found" error
Comment 63 Christopher Brown 2008-01-22 17:01:32 EST
(In reply to comment #61)
> The bug is such a random collection of reports I'm not actually tracking it and
> don't intend to. I'm working instead off the specific reports of
> controller/device problems one by one. The big one with >4GB and Nvidia isn't
> fixed yet but is actively being worked on upstream. The problems with tsscorp
> cdroms returning bogus cable detect information should be worked around. Some
> ALi is still under investigation.

Essentially there are two issue with this report:

1) The number of disparate bugs make it impossible to address in a single bug
2) The fact that it relates to a distribution release (and is therefore
impossible to resolve at that version point) means it can really never be
resolved within the Fedora 8 lifecycle

I am therefore suggesting the following:

a) All people attached to this bug test with spins from the fedora unity project
as previously indicated:

http://spins.fedoraunity.org/spins

This _may_ resolve a number of issues which will allow an installable version of
Fedora 8.

b) Test with Fedora 9 Alpha - due out any day now at:

http://torrent.fedoraproject.org

With all the above I am therefore closing this bug as CANTFIX. Thank you to all
reporters for adding themselves to the bugs and providing requested information
however I hope you understand the reasoning behind this.

Should neither the fedoraunity respins or the Fedora 9 Alpha release be
installable for you please open a new bug against kernel - rawhide and copy
myself into it and I shall endeavour to work with all parties to ensure the
issues are addressed so that Fedora 9 is a release that you can use.

Cheers
Chris
Comment 64 Jon Roland 2008-01-22 20:40:48 EST
At the risk of stating the obvious, this problem was not reported until F7 and
later F8. There apparently was no problem for F6 and previous versions. What
changed to break what had been working? What is to prevent going back to what
worked for F6 and stick to that except for conservative enhancements that don't
affect recognition of disk drivers, which were, after all, recognized by the
BIOS to load the installer. Perhaps the solution is to remove any code that
overrides the BIOS for that function.
Comment 65 Jon Stanley 2008-01-22 20:53:53 EST
Jon -

Fedora is not a "conservative" distribution as you seem to imply it is.  F7 and
later introduced significant changes to the ATA subsystem (namely abstracting it
via libata).  It is not fair to say that no QA went into this, since it works
for most people (myself included - I have been able to install and use both F7
and F8).

The problem with this bug is that it has turned into a rat's nest of separate
issues.  So I'd like to suggest that you take the actions that Chris mentioned
in comment #63 - namely try a unity respin or F9 Alpha, which should hit real
soon (the freeze has already occurred and install testing is taking place now to
prove that the tree as frozen is actually installable).

If you still have problems, please open a separate bug, detailing the exact
hardware that you have that is not working (chipset + drive) and we'll action
that accordingly.

Thanks!
-Jon
Comment 66 Jon Roland 2008-01-22 21:23:25 EST
My problem, however, is that it is not enough to get it to work on my own
systems. First, it reduces my confidence that later versions will work as well.
Second, it makes me hesitate to recommend Fedora to others, many of whom have a
variety of systems with all kinds of drives and drivers. I submit that we should
be seeking a more robust solution, one that will almost always work if the
installer was itself installed and is running. 

I respectfully suggest that an exception handler be inserted at the point where
the installer reports it is not recognizing the drive from which it just
installed itself, and revert back to what worked in F6, which I presume was
loading via the BIOS. In other words, if the libata approach doesn't work, there
needs to be a fallback.
Comment 67 Alan Cox 2008-01-23 06:51:33 EST
The old approach was to load via the kernel drivers, then new likewise. You are
assuming that these bugs are even driver level. This bug was closed because its
a mash of assorted unrelated, unclassified reports with all sorts of causes. And
despite what you comment older FC's tended to end up with such a random 'it
broke' type bug report too.
Comment 68 Jon Roland 2008-01-23 07:18:35 EST
No, I am assuming that the installer was loaded through the BIOS, before the
kernel and its drivers could be loaded, because it was executing to even produce
the error message, and that if it could install that much of itself in that way
it should be able to find the rest of itself the same way. I find no previous
bug reports with the same symptoms. Other Linux installers don't seem to have
this problem. I can install using any of them on the same systems. I do not
agree that the reports are unrelated. They indicate a design defect in the
installer that other installers don't have, and that the Fedora installer should
not have, either, if Fedora is to compete with them. Passing the buck to the
respin efforts is not the right approach. I urge it be reopened and kept open
until we can be assured the problem will not recur under any scenario.
Comment 69 Christopher Brown 2008-01-23 08:43:18 EST
Jon,

The issue here is that the above reports relate to different drivers under
different circumstances. This is the reason the report was closed, not because
we do not believe the problem is not a valid one.

I disagree that testing out re-spins is passing the buck. The unity re-spin
project fills an important gap and offers the chance to have an installable
release should any official installer release bugs appear (which they often do).
I also offered the option of testing the Fedora 9 Alpha release and if this
fails, filing a new bug and copying me into this so that we can work together
with the kernel developers to make sure Fedora 9 is an installable release for you.

Re-opening this bug (which has become the defacto "Fedora does not install" bug)
would solve nothing as the kernel engineers have indicated they are no longer
tracking it due to reasons already stated. Surely you understand that.

Essentially, if you want Fedora installable for you, test with Fedora 9 alpha,
open a new bug (if it doesn't work) and copy me into it. I will be more than
happy to work with you and the kernel team to get it resolved. I detest
installer bugs above all others as I am aware of the large amount of
disappointment and loss of goodwill they can cause.

Cheers
Chris
Comment 70 Jon Roland 2008-01-23 09:05:47 EST
We are still arguing past each other. I don't see this as a kernel problem but
as an installer problem. The installer that can load the first part of itself
should be able to install the rest of itself, even if there is a problem later
with the kernel or drivers, which should be reported as something like, "Cannot
find driver for disk from which your installer was loaded." In other words, the
installer medium should not be trying to use a filesystem itself that requires a
Linux driver to read it. It should be readable using only the BIOS. Once
installed, it should search the system for drives it has drivers for. So, it
might report, "Found drivers for disks /dev/hdcx, ..., but cannot find driver
for disk /dev/hdcy from which the installer was loaded. Please select one of
these other drives for the installation, or ESC to abort."
Comment 71 Alan Cox 2008-01-23 09:24:52 EST
I suggest a little light reading - you cannot use BIOS services once you enter
32/64bit mode. No Linux uses BIOS services to load beyond the initrd and kernel
- and you cannot load more without hitting memory problems.
Comment 72 Bill Waddington 2008-01-23 10:04:15 EST
(In reply to comment #67)
> This bug was closed because its a mash of assorted unrelated, unclassified
> reports with all sorts of causes.

It seems to me that this mash is caused in part because the installer falls over
in what *seems* to be the same place for several different reasons, at least in
the default GUI mode.

It's a little late to ask, but what anaconda option would produce a more
detailed running account of what's going on?  This bug (bugs...) has been a
total show-stopper on my ThinkPad t61.  If I can't install, I can't test/report
on any thing else Fedora...

Thanks,
Bill

Comment 73 Jon Roland 2008-01-23 10:31:23 EST
(In reply to comment #71)
> I suggest a little light reading - you cannot use BIOS services once you enter
> 32/64bit mode. No Linux uses BIOS services to load beyond the initrd and kernel
> - and you cannot load more without hitting memory problems.
> 

Alright, so how are the other Linux installers doing it? They don't seem to be
having these problems. I can install SuSE or Debian-based distros on any system
that the F7/F8 installers fail on. Do they come with more drivers? Wny can't we
just borrow the code from their installers for use in the Fedora installer, or
revert to the code that worked for F6, at least as a fallback? There seems to be
a design flaw in whatever was done differently beginning with the F7 installer.
Comment 74 mohamed 2008-02-13 09:16:19 EST
hi,

i mananged to get through this by using;

acpi=off

when booting of the spin dvd, i haven't tried it wit the official spin.  But
what is reallyyyy annoying is the mouse and keyboard both of which are connected
through usb are extermely slow, does this have anything to do with the acpi=off?
 they are both operating incredibly slow.

ps. i am new to linux

Note You need to log in before you can comment on or make changes to this bug.