Bug 242957 - [RHEL5] Evolution crashed in first-time wizard stage for some timezones.
[RHEL5] Evolution crashed in first-time wizard stage for some timezones.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution-data-server (Show other bugs)
5.0
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Matthew Barnes
:
: 245128 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-06 13:25 EDT by Oleg L. Sadov
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0603
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:29:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for evolution-data-server timezone crash fixing (421 bytes, patch)
2007-06-06 13:25 EDT, Oleg L. Sadov
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 444807 None None None Never

  None (edit)
Description Oleg L. Sadov 2007-06-06 13:25:06 EDT
Description of problem:
Evolution crushed in first-time wizard stage for timezones: Europe/Moscow,
Europe/Volgograd, Asia/Irkutsk, Asia/Makassar, Asia/Ujung_Pandang,
Asia/Ulaanbaatar, Asia/Ulan_Bator.

Version-Release number of selected component (if applicable):
1.8.0-15.0.2 or 1.8.0-15.0.3

How reproducible:
TZ=Europe/Moscow evolution

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Evolution crush

Expected results:


Additional info:
This bug is a consequence of removing TZNAME tag from timezone ICS VCARDs
(Australia/Perth.ics and Asia/Jerusalem.ics) by a
evolution-data-server-1.8.0-updated-zoneinfo.patch.
Comment 1 Oleg L. Sadov 2007-06-06 13:25:06 EDT
Created attachment 156373 [details]
Patch for evolution-data-server timezone crash fixing
Comment 3 RHEL Product and Program Management 2007-06-06 14:05:44 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Matthew Barnes 2007-06-26 16:50:58 EDT
Fixed in evolution-data-server-1.8.0-21.el5.
Comment 6 Matthew Barnes 2007-06-27 00:28:09 EDT
*** Bug 245128 has been marked as a duplicate of this bug. ***
Comment 10 errata-xmlrpc 2007-11-07 12:29:04 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0603.html

Note You need to log in before you can comment on or make changes to this bug.