Bug 243090 - yum installs 32 and 64 bit packages, but only one of the versions become active, because they replace each other
yum installs 32 and 64 bit packages, but only one of the versions become acti...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-07 05:27 EDT by IBM Bug Proxy
Modified: 2014-01-21 17:58 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-20 10:15:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 35267 None None None Never

  None (edit)
Description IBM Bug Proxy 2007-06-07 05:27:12 EDT
LTC Owner is: suzukikp@in.ibm.com
LTC Originator is: dmfaria@br.ibm.com


Problem description:
When you try to run yum install or yum update for some program (eg "yum install
gdb"), sometimes yum finds more than one version, one 32 bits and the other 64
bits version (eg gdb.ppc and gdb.ppc64). Then if you follow the installation
process, yum will install one of the versions and then will install the other
over the previous one. 
Now running yum info or yum list or yum search for the same program that you
installed it will show that both versions are installed, but you will be able to
use only one of them. If you remove just one of the versions with yum remove,
the other version won't be installed.


Environment
I used Fedora 7 GAd version.
# uname -a
Linux cell14.ltc.austin.ibm.com 2.6.21-1.3176.cbe2.901 #1 SMP Wed May 30
03:01:30 CEST 2007 ppc64 ppc64 ppc64 GNU/Linux

Machine type (p650, x235, SF2, etc.): QS20
Cpu type (Power4, Power5, IA-64, etc.): CELL

Is this reproducible?
Before doing this, remove all gdb packages from your system. Steps:
# yum install gdb
...
***This installs 32-bit and 64-bit versions of gdb

# yum list gdb
Loading "installonlyn" plugin
Installed Packages
gdb.ppc                                  6.6-8.fc7              installed
gdb.ppc64                                6.6-8.fc7              installed
***As you can see, both versions are installed.

# file /usr/bin/gdb
/usr/bin/gdb: ELF 32-bit MSB executable, PowerPC or cisco 4500, version 1
(SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.9, stripped
***Only the 32-bit version is accessible.

# yum remove gdb.ppc
...
***This removes the 32-bit version

# file /usr/bin/gdb
/usr/bin/gdb: ERROR: cannot open `/usr/bin/gdb' (No such file or directory)
***GDB is not installed anymore

# yum list gdb
Loading "installonlyn" plugin
Installed Packages
gdb.ppc64                                6.6-8.fc7              installed
Available Packages
gdb.ppc                                  6.6-8.fc7              fedora
***BUT yum tells me that I still have gdb installed

[root@cell14 /]# gdb
bash: gdb: command not found
[root@cell14 /]# gdb64
bash: gdb64: command not found

Both the gdb.ppc & gdb.ppc64 rpms provides the files with same name(but of
different platform 32/64bit). So installing both the rpms causes the second rpm
to erase whatever the first rpm had installed. Again, if we remove any one of
these rpms, that will erase (single) set of files provided by both the rpms.

This is a packaging issue from Redhat's side.

FYI,

[root@cell14 ~]# rpm -ql gdb.ppc
/usr/bin/gcore
/usr/bin/gdb
/usr/bin/gdbserver
/usr/bin/gdbtui
/usr/bin/gstack
/usr/bin/run
/usr/share/doc/gdb-6.6
/usr/share/doc/gdb-6.6/COPYING
/usr/share/doc/gdb-6.6/COPYING.LIB
/usr/share/doc/gdb-6.6/NEWS
/usr/share/doc/gdb-6.6/README
/usr/share/info/annotate.info.gz
/usr/share/info/gdb.info.gz
/usr/share/info/gdbint.info.gz
/usr/share/info/stabs.info.gz
/usr/share/man/man1/gdb.1.gz
/usr/share/man/man1/gdbserver.1.gz
/usr/share/man/man1/gdbtui.1.gz
/usr/share/man/man1/run.1.gz

[root@cell14 ~]# rpm -ql gdb.ppc64
/usr/bin/gcore
/usr/bin/gdb
/usr/bin/gdbserver
/usr/bin/gdbtui
/usr/bin/gstack
/usr/bin/run
/usr/share/doc/gdb-6.6
/usr/share/doc/gdb-6.6/COPYING
/usr/share/doc/gdb-6.6/COPYING.LIB
/usr/share/doc/gdb-6.6/NEWS
/usr/share/doc/gdb-6.6/README
/usr/share/info/annotate.info.gz
/usr/share/info/gdb.info.gz
/usr/share/info/gdbint.info.gz
/usr/share/info/stabs.info.gz
/usr/share/man/man1/gdb.1.gz
/usr/share/man/man1/gdbserver.1.gz
/usr/share/man/man1/gdbtui.1.gz
/usr/share/man/man1/run.1.gz

- Suzuki

-------------------------------------------


Daniel and me were worried about this issue because, in theory, this could mix
the whole system with 32 and 64 bit programs. But, dispite this issue with yum,
the system is 100% 32 bit.
I checked all binaries at /bin, /sbin/ and /usr/bin, and for the 2100 files
inside, only 6 were 64 bit binaries. These 6 files were installed manually using
rpm, and have nothing to do with fedora's package system.
But, besides that, any package installed which has 2 different arch versions at
the repositories will be installed, as Daniel told. Both will be downloaded, and
we can possibly assume that 64 bit versions are installed first, and the 32 bit
versions last. Need to check this.

I'm attaching a output of a "yum update" showing this at a recently installed
machine.

Example showing yum trying to install 32 and 64 bit versions of the same
package  :


[root@cell16 bin]# yum update
Loading "installonlyn" plugin
Setting up Update Process
fedora                    100% |=========================| 2.1 kB    00:00
ftp://mirror.cs.princeton.edu/pub/mirrors/fedora/linux/updates/7/ppc/repodata/repomd.xml:
[Errno 4] IOError: [Errno ftp error] 421 Sorry, mirror already has 27 users
logged on.  Try again in 10 minutes.
Trying other mirror.
updates                   100% |=========================| 1.9 kB    00:00
Resolving Dependencies
--> Running transaction check
filelists.sqlite.bz2      100% |=========================| 244 kB    00:01
---> Package postgresql-server.ppc 0:8.2.4-1.fc7 set to be updated
---> Package system-config-nfs.noarch 0:1.3.25-1.fc7 set to be updated
---> Package postgresql-python.ppc 0:8.2.4-1.fc7 set to be updated
---> Package gpm.ppc64 0:1.20.1-84.fc7 set to be updated
---> Package fluxbox.ppc 0:1.0.0-0.2.rc3.fc7 set to be updated
---> Package NetworkManager-glib.ppc 1:0.6.5-3.fc7 set to be updated
---> Package gpm-devel.ppc64 0:1.20.1-84.fc7 set to be updated
---> Package postgresql-libs.ppc 0:8.2.4-1.fc7 set to be updated
---> Package firefox.ppc64 0:2.0.0.4-2.fc7 set to be updated
---> Package gpm.ppc 0:1.20.1-84.fc7 set to be updated
---> Package NetworkManager-glib.ppc64 1:0.6.5-3.fc7 set to be updated
---> Package NetworkManager.ppc 1:0.6.5-3.fc7 set to be updated
---> Package system-config-users.noarch 0:1.2.58-1.fc7 set to be updated
---> Package NetworkManager.ppc64 1:0.6.5-3.fc7 set to be updated
---> Package firefox.ppc 0:2.0.0.4-2.fc7 set to be updated
---> Package postgresql.ppc 0:8.2.4-1.fc7 set to be updated
---> Package gpm-devel.ppc 0:1.20.1-84.fc7 set to be updated
---> Package wpa_supplicant.ppc 1:0.5.7-3.fc7 set to be updated

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 NetworkManager          ppc        1:0.6.5-3.fc7    updates           508 k
 NetworkManager          ppc64      1:0.6.5-3.fc7    updates           506 k
 NetworkManager-glib     ppc        1:0.6.5-3.fc7    updates            31 k
 NetworkManager-glib     ppc64      1:0.6.5-3.fc7    updates            31 k
 firefox                 ppc64      2.0.0.4-2.fc7    updates            22 M
 firefox                 ppc        2.0.0.4-2.fc7    updates            21 M
 fluxbox                 ppc        1.0.0-0.2.rc3.fc7  updates           1.0 M
 gpm                     ppc64      1.20.1-84.fc7    updates           211 k
 gpm                     ppc        1.20.1-84.fc7    updates           211 k
 gpm-devel               ppc64      1.20.1-84.fc7    updates            30 k
 gpm-devel               ppc        1.20.1-84.fc7    updates            30 k
 postgresql              ppc        8.2.4-1.fc7      updates           3.1 M
 postgresql-libs         ppc        8.2.4-1.fc7      updates           210 k
 postgresql-python       ppc        8.2.4-1.fc7      updates            70 k
 postgresql-server       ppc        8.2.4-1.fc7      updates           4.6 M
 system-config-nfs       noarch     1.3.25-1.fc7     updates           190 k
 system-config-users     noarch     1.2.58-1.fc7     updates           372 k
 wpa_supplicant          ppc        1:0.5.7-3.fc7    updates           256 k

Transaction Summary
=============================================================================
Install      0 Package(s)
Update      18 Package(s)
Remove       0 Package(s)

Total download size: 54 M
Is this ok [y/N]:
Comment 1 IBM Bug Proxy 2007-06-20 09:35:26 EDT
----- Additional Comments From suzukikp@in.ibm.com (prefers email at suzuki@in.ibm.com)  2007-06-20 09:32 EDT -------
Redhat,

Any updates here ?

Thanks

Suzuki 
Comment 2 Paul Nasrat 2007-06-20 10:15:47 EDT
This is by design as part of multilib
Comment 3 IBM Bug Proxy 2007-06-25 02:55:29 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ASSIGNED                    |REJECTED
         Resolution|                            |NOTABUG




------- Additional Comments From suzukikp@in.ibm.com (prefers email at suzuki@in.ibm.com)  2007-06-25 02:51 EDT -------
Daniel,

Redhat has closed this as NOT A BUG. Doing the same here.

Please feel free to re-open if you do not agree.

Thanks

Suzuki 

Note You need to log in before you can comment on or make changes to this bug.