Bug 243148 - Wrong init script
Wrong init script
Status: CLOSED DUPLICATE of bug 243127
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openib (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Doug Ledford
Depends On: 243143
  Show dependency treegraph
Reported: 2007-06-07 11:16 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-23 10:48:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Marciniszyn 2007-06-07 11:16:22 EDT
+++ This bug was initially created as a clone of Bug #243143 +++

Description of problem:
The quagga init scripts contain constructions that prevent correct status
command call and also return incorrect error code. This bug is presented in all
init scripts in this package. Example of such error:
if [ ! -f $CONFIG ]; then
    exit 0

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:

For an example of the script that returns the error codes correctly and always
runs status see:

This bug is tracked by 237789.
Comment 1 Martin Bacovsky 2007-08-21 09:02:50 EDT
/etc/ofed/opensm.conf doesn't belong to quagga package. My guess is the right
component should be openib. Since there is another bug on initscripts filed
against quagga I'm changing the component.
Comment 2 Doug Ledford 2007-08-23 10:48:24 EDT
opensm is part of openib, and I handled the opensm init script already when
doing the other bug against openib.  Closing this out as a dup.

*** This bug has been marked as a duplicate of 243127 ***

Note You need to log in before you can comment on or make changes to this bug.