Bug 243143 - Wrong init script
Summary: Wrong init script
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: quagga   
(Show other bugs)
Version: 5.0
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Martin Bacovsky
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
: 237805 (view as bug list)
Depends On: 249302
Blocks: 237789 243148
TreeView+ depends on / blocked
 
Reported: 2007-06-07 15:02 UTC by Michal Marciniszyn
Modified: 2014-02-10 23:03 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0563
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 20:10:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0563 normal SHIPPED_LIVE quagga bug fix update 2007-11-07 23:09:25 UTC

Description Michal Marciniszyn 2007-06-07 15:02:33 UTC
Description of problem:
The quagga init scripts contain constructions that prevent correct status
command call and also return incorrect error code. This bug is presented in all
init scripts in this package. Example of such error:
CONFIG=/etc/ofed/opensm.conf
if [ ! -f $CONFIG ]; then
    exit 0
fi

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.

Comment 1 RHEL Product and Program Management 2007-06-07 15:15:12 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.

Comment 2 Daniel Riek 2007-06-15 23:22:47 UTC
Re-opening for evaluation as Quagga is now approved with testing by IBM.

Comment 3 Martin Bacovsky 2007-06-21 13:06:35 UTC
*** Bug 237805 has been marked as a duplicate of this bug. ***

Comment 5 Martin Bacovsky 2007-06-25 12:35:22 UTC
This issue should be fixed in quagga-0.98.6-3.el5.

Comment 9 errata-xmlrpc 2007-11-07 20:10:10 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0563.html



Note You need to log in before you can comment on or make changes to this bug.