Bug 243149 - Wrong init script
Wrong init script
Status: CLOSED DUPLICATE of bug 247040
Product: Fedora
Classification: Fedora
Component: quagga (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Bacovsky
Depends On:
  Show dependency treegraph
Reported: 2007-06-07 11:17 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-26 09:26:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Marciniszyn 2007-06-07 11:17:54 EDT
+++ This bug was initially created as a clone of Bug #243143 +++

Description of problem:
The quagga init scripts contain constructions that prevent correct status
command call and also return incorrect error code. This bug is presented in all
init scripts in this package. Example of such error:
if [ ! -f $CONFIG ]; then
    exit 0

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:

For an example of the script that returns the error codes correctly and always
runs status see:

This bug is tracked by 237789.

-- Additional comment from pm-rhel@redhat.com on 2007-06-07 11:15 EST --
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 1 Martin Bacovsky 2007-07-26 09:26:47 EDT
Closing tis bug because of bz#247040 which is more general.

*** This bug has been marked as a duplicate of 247040 ***

Note You need to log in before you can comment on or make changes to this bug.