Bug 243158 - Gnash plugin crashes X
Summary: Gnash plugin crashes X
Status: CLOSED DUPLICATE of bug 243860
Alias: None
Product: Fedora
Classification: Fedora
Component: gnash (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Patrice Dumas
QA Contact: Fedora Extras Quality Assurance
URL: http://www.ynet.co.il
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-07 16:26 UTC by Pavel Rosenboim
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-17 18:28:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pavel Rosenboim 2007-06-07 16:26:37 UTC
Description of problem:


Version-Release number of selected component (if applicable):
gnash-plugin 0.7.2-2.fc7

How reproducible:
Always

Steps to Reproduce:
0. Install gnash-plugin
1. Open http://www.ynet.co.il. There is a flash ad after head article.
Sometimes, just image ad is shown. In this case, remove all cookies from the
site and refresh until you get flash ad.
2. Close an ad by clicking X in its left bottom corner.
3.
  
Actual results:
Whole X session crashes and X restarts.

Following backtrace is logged in /var/log/Xorg.0.log:
Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x81) [0x80ceb41]
1: [0x850420]
2: /usr/lib/xorg/modules/extensions//libGLcore.so(xmesa_check_and_update_buffer_
size+0x32) [0x1193272]
3: /usr/lib/xorg/modules/extensions//libGLcore.so(XMesaResizeBuffers+0x29) [0x11
95a09]
4: /usr/lib/xorg/modules/extensions//libGLcore.so [0x11ccf70]
5: /usr/lib/xorg/modules/extensions//libglx.so [0xf983ba]
6: /usr/bin/Xorg(compPositionWindow+0x59) [0x81021a9]
7: /usr/bin/Xorg(ResizeChildrenWinSize+0x1af) [0x80772ef]
8: /usr/bin/Xorg(miMoveWindow+0x130) [0x81363c0]
9: /usr/bin/Xorg(compMoveWindow+0xad) [0x81031cd]
10: /usr/bin/Xorg(ConfigureWindow+0x7bc) [0x807697c]
11: /usr/bin/Xorg(ProcConfigureWindow+0xa1) [0x8088ae1]
12: /usr/bin/Xorg [0x814efd1]
13: /usr/bin/Xorg(Dispatch+0x1aa) [0x808936a]
14: /usr/bin/Xorg(main+0x495) [0x80710a5]
15: /lib/libc.so.6(__libc_start_main+0xe0) [0x125f70]
16: /usr/bin/Xorg(FontFileCompleteXLFD+0x1e1) [0x8070391]

Fatal server error:
Caught signal 11.  Server aborting

I have NVidia GeForce MX440 video card, running with nv driver.

Comment 1 Patrice Dumas 2007-06-07 21:02:13 UTC
Is it
http://ybanners.mediazone.co.il/yafora/ynetPrime.swf

Maybe you could try to rebuild locally gnash to see if it
is the same bug than Bug 217020

Comment 2 Pavel Rosenboim 2007-06-08 20:17:00 UTC
I rebuilt locally source rpm but it didn't resolve the problem. X server keeps
crashing.

Comment 3 Riku Seppala 2007-06-15 22:27:28 UTC
same bug? https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=243860

Comment 4 Pavel Rosenboim 2007-06-16 12:24:20 UTC
Indeed, looks like it is a same bug.

Comment 5 Patrice Dumas 2007-06-17 18:28:23 UTC
Yep, this is a duplicate, thanks!

*** This bug has been marked as a duplicate of 243860 ***


Note You need to log in before you can comment on or make changes to this bug.