Bug 243159 - Upgrade does not recognize existing install
Summary: Upgrade does not recognize existing install
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-07 16:26 UTC by Orion Poplawski
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 17:13:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log (17.32 KB, text/plain)
2007-06-07 16:26 UTC, Orion Poplawski
no flags Details

Description Orion Poplawski 2007-06-07 16:26:56 UTC
Description of problem:

Trying to do PXE kickstart upgrade of FC6 machine.  Using the update.img
mentioned in bug 241395.

Instead of upgrading the existing install, it asks to partition the disk.

Existing /etc/fstab:

/dev/rootvg/root        /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
/dev/rootvg/data1       /export/data1           ext3    defaults        1 2
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
/dev/rootvg/usr         /usr                    ext3    defaults        1 2
/dev/rootvg/var         /var                    ext3    defaults        1 2
/dev/rootvg/swap        swap                    swap    defaults        0 0
tmpfs                   /tmp                    tmpfs   defaults        0 0

Comment 1 Orion Poplawski 2007-06-07 16:26:56 UTC
Created attachment 156481 [details]
anaconda log

Comment 2 Chris Lumens 2007-06-07 20:57:34 UTC
This is because we're skipping a step we shouldn't be.  Reassigning to myself
for investigation.

Comment 3 Chris Lumens 2007-06-11 17:13:43 UTC
This is fixed in the updates.img referenced in the other common F7 anaconda
bugs.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.