Bug 241395 - FC6 -> F7 anaconda upgrade traceback
FC6 -> F7 anaconda upgrade traceback
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
: 248596 253227 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-25 13:58 EDT by James Laska
Modified: 2013-09-02 02:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-25 14:42:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-logs.tgz (11.95 KB, application/x-compressed-tar)
2007-05-25 13:58 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2007-05-25 13:58:13 EDT
# RPM anaconda-11.2.0.65-1.x86_64.rpm
# ARCH x86_64

Probing for video card:   nVidia Corporation NV44 [Quadro NVS 285]
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 949, in <module>
    kickstart.setSteps(anaconda)
  File "/usr/lib/anaconda/kickstart.py", line 1056, in setSteps
    upgrade.setSteps(anaconda)
AttributeError: 'bool' object has no attribute 'setSteps'

Attaching anaconda-logs.tgz  (not the tmp/anaconda.log includes several attempts
to recreate the failure in order to capture the output)

(~)> tar -ztvf ~/Desktop/anaconda-logs.tgz 
-rw-r--r-- root/root     23134 2007-06-01 20:58:34 tmp/syslog
-rw-r--r-- root/root     65056 2007-06-01 21:16:35 tmp/anaconda.log
-rw------- root/root      1017 2007-06-01 21:15:19 tmp/ks.cfg
-rw-r--r-- root/root       338 2007-06-01 21:16:35 tmp/trace.txt

I believe this is the RC2 tree (.treeinfo below):

[general]
family = Fedora
timestamp = 1180061782.66
variant = Fedora
totaldiscs = 1
version = 7
discnum = 1
packagedir = Fedora
arch = x86_64
Comment 1 James Laska 2007-05-25 13:58:13 EDT
Created attachment 155469 [details]
anaconda-logs.tgz
Comment 2 Chris Lumens 2007-05-25 14:42:03 EDT
Fixed in head, and I think we're going to pull this into an updates.img.
Comment 3 Orion Poplawski 2007-05-31 13:40:40 EDT
I'm hitting this - is the updates.img available?
Comment 4 Chris Lumens 2007-06-06 13:47:27 EDT
This bug is now addressed by an updates image.  It is available for download at:

    http://people.redhat.com/clumens/f7-updates.img

Instructions for using updates disks are located at:

    http://fedoraproject.org/wiki/Anaconda/Updates

If possible, please test this image out and report if it fixes your issue or
not.  Once we are confident that your issue is solved by this image, we are
going to announce it more publicly.  This fix may also be included in an updated
anaconda package later for people who are making custom Fedora distributions. 
Thanks for your time.
Comment 5 Orion Poplawski 2007-06-06 16:56:46 EDT
update bombs with:

/tmp/updates/kickstart.py line 30
 import pykickstart.commands as commands
  ImportError: No module named commands
Comment 6 Chris Lumens 2007-06-06 17:11:51 EDT
Thanks for the report.  Please try it now.
Comment 7 Orion Poplawski 2007-06-06 17:38:33 EDT
Anaconda starts up okay, but then it asks how I want to partition the disk
rather than upgrading the existing install.
Comment 8 Chris Lumens 2007-06-07 11:55:33 EDT
Sounds like anaconda is not detecting your existing installation and therefore
doesn't give you the option of install vs. upgrade.  What's your layout?  What's
in the anaconda log files?  This may be better served with a different bug, in fact.
Comment 9 Orion Poplawski 2007-06-07 12:27:30 EDT
Opened bug #243159 for the upgrade issue.
Comment 10 Orion Poplawski 2007-06-07 16:28:05 EDT
Chris -

  Any chance that the anaconda fixes for this will be released as a F7 update so
that respins of an updated F7 work?
Comment 11 Chris Lumens 2007-06-07 16:36:06 EDT
I've committed the fixes in the updates.img to the F7 branch of anaconda.  We'll
probably build a new one in a few weeks to give more time to see what are the
really common bugs.  Then, anyone who wants to make a new F7 can take advantage
of the fixes.
Comment 12 Orion Poplawski 2007-06-07 16:39:05 EDT
Excellent! Thanks!
Comment 13 Chris Lumens 2007-07-17 13:35:29 EDT
*** Bug 248596 has been marked as a duplicate of this bug. ***
Comment 14 Chris Lumens 2007-08-17 10:32:10 EDT
*** Bug 253227 has been marked as a duplicate of this bug. ***
Comment 15 Jean Visagie 2007-08-21 12:35:52 EDT
Greetings,

I am trying to do a kickstart upgrade from a custom FC6 to a custom FC7 distro.
After encountering the known issue (line 949), I downloaded the f7-updates.img
file, renamed it to updates.img and put it under the images/ folder of my custom
distro cd. The installer then continues till it displays the 'transferring
install image to harddrive' message. I then get the error show below. Is it at
all possible to use the updates like this (in the images/ folder of the cd), as
the wiki states that is is possible to do this with network install.

Traceback (most recent call first):
  File "/tmp/treedir.27118/instimage/usr/lib/anaconda/isys.py", line 244, in
lochangefd
    _isys.lochangefd(loop, targ)
  File "/usr/lib/anaconda/image.py", line 188, in systemMounted
    isys.lochangefd("/tmp/loop", self.loopbackFile)
  File "/tmp/treedir.27118/instimage/usr/lib/anaconda/yuminstall.py", line 1107,
in doPreInstall
    if self.method.systemMounted (anaconda.id.fsset, anaconda.rootPath):
  File "/tmp/treedir.27118/instimage/usr/lib/anaconda/backend.py", line 230, in
doPreInstall
    anaconda.backend.doPreInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 203, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 605, in run
    anaconda.dispatch.gotoNext()
  File "/tmp/updates/anaconda", line 955, in <module>
    anaconda.intf.run(anaconda)
SystemError: (6, 'No such device or address')

Note You need to log in before you can comment on or make changes to this bug.