Bug 243203 - Livecd-creator fails with an Almost Default kickstart
Livecd-creator fails with an Almost Default kickstart
Status: CLOSED DUPLICATE of bug 241604
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-07 16:46 EDT by Nicolas A. Corrarello
Modified: 2013-03-05 22:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 15:39:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kickstart (3.59 KB, application/octet-stream)
2007-06-07 16:46 EDT, Nicolas A. Corrarello
no flags Details
Filelist of locally created repository (26.54 KB, application/x-gzip)
2007-06-07 17:30 EDT, Nicolas A. Corrarello
no flags Details
primary.xml.gz (11.29 KB, application/x-gzip)
2007-06-07 17:32 EDT, Nicolas A. Corrarello
no flags Details

  None (edit)
Description Nicolas A. Corrarello 2007-06-07 16:46:10 EDT
Description of problem:
When trying to create a live-cd with a slightly modified kickstart and a repo
with Missing packages, the following error occur
Importing additional filelist information
Traceback (most recent call last):
  File "/usr/bin/livecd-creator", line 1088, in <module>
    sys.exit(main())
  File "/usr/bin/livecd-creator", line 1069, in main
    target.install()
  File "/usr/bin/livecd-creator", line 871, in install
    self.installPackages(self.packages, self.epackages, self.groups)
  File "/usr/bin/livecd-creator", line 483, in installPackages
    self.ayum.runInstall()
  File "/usr/bin/livecd-creator", line 270, in runInstall
    self.downloadPkgs(dlpkgs)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 798, in downloadPkgs
    remote_pkgs.sort(mediasort)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 747, in mediasort
    a = a.getDiscNum()
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 485, in getDiscNum
    return int(fragid)
ValueError: invalid literal for int() with base 10: ''


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Using the kickstart attached and creating a repo like the one I'm using
  
Actual results:
The error

Expected results:
A live cd

Additional info:
Comment 1 Nicolas A. Corrarello 2007-06-07 16:46:11 EDT
Created attachment 156507 [details]
Kickstart
Comment 2 Nicolas A. Corrarello 2007-06-07 16:46:57 EDT
Extra packages:
[root@edgar ~]# tree packages/
packages/
|-- abiword-2.4.6-5.fc7.i386.rpm
|-- amsn-0.96-7.fc7.i386.rpm
|-- bwidget-1.8.0-1.fc6.noarch.rpm
|-- fftw-3.1.2-3.fc6.i386.rpm
|-- gnome-python2-gtkmozembed-2.14.3-2.fc7.i386.rpm
|-- gnumeric-1.6.3-6.fc7.i386.rpm
|-- gparted-0.3.3-10.fc7.i386.rpm
|-- gstreamer-python-0.10.7-2.fc7.i386.rpm
|-- libmpcdec-1.2.2-4.fc6.i386.rpm
|-- libofa-0.9.3-8.fc6.i386.rpm
|-- libsexy-0.1.11-1.fc7.i386.rpm
|-- libtunepimp-0.5.3-3.fc7.i386.rpm
|-- listen-0.5-15.fc7.1.i386.rpm
|-- ntfs-3g-1.516-1.fc7.i386.rpm
|-- ntfsprogs-1.13.1-3.fc6.i386.rpm
|-- python-musicbrainz2-0.4.1-1.fc7.noarch.rpm
|-- python-mutagen-1.11-1.fc7.noarch.rpm
|-- python-sexy-0.1.9-3.fc7.i386.rpm
|-- python-sqlite2-2.3.3-1.fc7.i386.rpm
|-- repodata
|   |-- filelists.xml.gz
|   |-- other.xml.gz
|   |-- primary.xml.gz
|   `-- repomd.xml
|-- sox-13.0.0-1.i386.rpm
|-- tcl-8.4.13-16.fc7.i386.rpm
|-- tcldom-3.1-10.fc7.i386.rpm
|-- tcllib-1.9-4.fc7.noarch.rpm
|-- tclsoap-1.6.7-4.fc7.noarch.rpm
|-- tcltls-1.5.0-11.fc6.i386.rpm
|-- tclxml-3.1-11.fc7.i386.rpm
|-- tk-8.4.13-5.fc7.i386.rpm
`-- tkdnd-1.0a2-7.fc6.i386.rpm

1 directory, 32 files
Comment 3 Jeremy Katz 2007-06-07 16:51:01 EDT
One of your repos has bits that are confusing yum -- how are you running
createrepo?  And can you include a snippet of the primary.xml.gz files for your
repos?
Comment 4 Nicolas A. Corrarello 2007-06-07 17:29:40 EDT
I'm creating the repo with:
# cd /root
# createrepo packages/
I attach the file requested
Comment 5 Nicolas A. Corrarello 2007-06-07 17:30:50 EDT
Created attachment 156516 [details]
Filelist of locally created repository
Comment 6 Nicolas A. Corrarello 2007-06-07 17:32:01 EDT
Created attachment 156517 [details]
primary.xml.gz
Comment 7 Nicolas A. Corrarello 2007-06-07 17:33:10 EDT
Going home now... If you need anything just ask
Comment 8 Jeremy Katz 2007-06-13 15:39:42 EDT

*** This bug has been marked as a duplicate of 241604 ***

Note You need to log in before you can comment on or make changes to this bug.