Bug 24323 - up2date fails
Summary: up2date fails
Status: CLOSED DUPLICATE of bug 18994
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-18 23:45 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-18 23:45:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-01-18 23:45:18 UTC
When trying to run up2date in the batch mode, (RH7.0), I get the 
following message:


[root@admin cajun]# up2date -ua

Retrieving list of all available packages...

Removing installed packages from list of updates...
100.0%
Removing packages marked to skip from list...
100.0%
Getting headers for available packages...
100.0%
Removing packages with files marked to skip from list...
Traceback (innermost last):
  File "/usr/sbin/up2date", line 394, in ?
   main()
  File "/usr/sbin/up2date", line 377, in main
   sys.exit(batchRun(onlyList, pkgNames, fullUpdate))
  File "/usr/sbin/up2date", line 139, in batchRun
   updated, skipped = up2date.getUpdatedPackageList(printit, percent)
  File "/usr/share/rhn/up2date/up2date.py", line 897, in 
getUpdatedPackageList
   progressCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 854, in 
removeSkipFilesPackagesFromList
   if checkModified(h, f_i):
  File "/usr/share/rhn/up2date/up2date.py", line 773, in checkModified
   installedHdr = installedHeader(hdr['name'])
  File "/usr/share/rhn/up2date/up2date.py", line 162, in installedHeader
   for index in db.findbyname(pkgName):
rpm.error: error reading from database
[root@admin cajun]#

I've tried rebuilding the rpm database by 'rpm --rebuilddb' but that has 
not helped. 

------------------
This was posted to the redhat-list where Trond Eivind Glomsrxd 
(teg@redhat.com) suggested to run without the 'a' flag 'up2date -u'.  This 
yeilded different results, however still failed:

[root@admin cajun]# up2date -u

Retrieving list of all available packages...

Removing installed packages from list of updates...
100.0%
Removing packages marked to skip from list...
100.0%
Getting headers for available packages...
100.0%
Removing packages with files marked to skip from list...
Traceback (innermost last):
File "/usr/sbin/up2date", line 394, in ?
main()
File "/usr/sbin/up2date", line 377, in main
sys.exit(batchRun(onlyList, pkgNames, fullUpdate))
File "/usr/sbin/up2date", line 139, in batchRun
updated, skipped = up2date.getUpdatedPackageList(printit, percent)
File "/usr/share/rhn/up2date/up2date.py", line 897, in 
getUpdatedPackageList
progressCallback)
File "/usr/share/rhn/up2date/up2date.py", line 854, in 
removeSkipFilesPackagesFromList
if checkModified(h, f_i):
File "/usr/share/rhn/up2date/up2date.py", line 789, in checkModified
if installedFileMD5s[j] != md5(fileName):
File "/usr/share/rhn/up2date/up2date.py", line 218, in md5
f = open(fileName, "r")
IOError: [Errno 2] No such file or directory: 
'/usr/share/Eterm/pix/pixmaps.list.base'
[root@admin cajun]#

Comment 1 Preston Brown 2001-02-09 03:45:48 UTC

*** This bug has been marked as a duplicate of 18994 ***


Note You need to log in before you can comment on or make changes to this bug.