This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 243253 - ohci_hcd dies sporadically
ohci_hcd dies sporadically
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks: FCMETA_USB
  Show dependency treegraph
 
Reported: 2007-06-08 06:06 EDT by Atte Kojo
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 02:49:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Atte Kojo 2007-06-08 06:06:10 EDT
Description of problem:
Now and then the external mouse of my laptop stops working and syslog says:

Jun  8 12:45:12 vaahtera kernel: ohci_hcd 0000:00:02.0: HC died; cleaning up
Jun  8 12:45:12 vaahtera kernel: usb 1-1: USB disconnect, address 2
Jun  8 12:45:12 vaahtera kernel: ohci_hcd 0000:00:02.0: leak ed dfd3b040 (#81) 
state 0 (has tds)

After this happens, disconnecting and reconnecting the mouse doesn't help.

Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3194.fc7

How reproducible:
Haven't found any clear sequence that triggers this, this usually happens a 
while before the kernel hangs completely (nothing works, keyboard doesn't 
wokr, doesn't respond to pings).

Additional info:
I'm also a victim of bug #240982
Comment 1 Atte Kojo 2007-06-19 08:00:26 EDT
This also happens with kernel-2.6.21-1.3228.fc7
Comment 2 Atte Kojo 2007-08-01 02:59:31 EDT
Still in kernel-2.6.22-1.33.fc7
Comment 3 Christopher Brown 2007-09-14 09:36:59 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

I have added the USB subsystem maintainer to this bug as he may wish to add any
comments.

Does your laptop support USB 2.0 or is it an older model?
Are you running this under vmware?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 4 Atte Kojo 2007-09-17 00:59:10 EDT
Well, since then I've switched using FreeBSD on the laptop, because the ata 
driver crashes the kernel on the machine now and then (a known bug, but I got 
tired waiting for the fix).

Anyway, the USB subsystem dies also with FreeBSD, so this seems to be a 
hardware issue and can be closed as invalid as far as I'm concerned.

Note You need to log in before you can comment on or make changes to this bug.